summaryrefslogtreecommitdiff
path: root/dev-ada/gps-bin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ada/gps-bin
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ada/gps-bin')
-rw-r--r--dev-ada/gps-bin/Manifest3
-rw-r--r--dev-ada/gps-bin/gps-bin-2016.ebuild76
-rw-r--r--dev-ada/gps-bin/metadata.xml13
3 files changed, 92 insertions, 0 deletions
diff --git a/dev-ada/gps-bin/Manifest b/dev-ada/gps-bin/Manifest
new file mode 100644
index 000000000000..30df2a9a83e9
--- /dev/null
+++ b/dev-ada/gps-bin/Manifest
@@ -0,0 +1,3 @@
+DIST gnat-gpl-2016-x86_64-linux-bin.tar.gz 372813330 SHA256 d083c01e054d0aeda7c67967306cfa5a8df12268664f9098a2d9b331aa24dfe7 SHA512 5115ac3be0badc5125ee048a98230f18363d72107da3325ce602c0e618cee2e3646a0decc00a2388f14bc61bfed51dd0622f365f5f7ee8b0cec2187ebcf8e075 WHIRLPOOL 7802a81533e5faad9c6913a2feae4e57fa4ce54ad7b561b23fbb64fdd9fa4bf3753e3c89e8d8fe15dce7a1294def8a5a4252f6aa66b4aef98d5669c2d08e0dd5
+EBUILD gps-bin-2016.ebuild 1833 SHA256 5a1dbbf2b5aaae1794a732562ee6bef9886c9b92c42e94851f03ac59ed409160 SHA512 4b5c41fa1755570920e91bb2224ce9007656f55b46df3b425dcefd8ffbebdab9ef0814a0214a6d9b197984b5649b30c8858ea69ca66e678cf588544090aeab17 WHIRLPOOL ebc506466f19597f212aa67a7f22f9ecee65a0d9426dcf1b61d3dc9c3eeaaada7739653aedacad2a52a58515b78255d385a4b3dfcc67edd8669a7e31f22a4a02
+MISC metadata.xml 1001 SHA256 75c363fd37ab0a74106e9bbbc284f8d291589736b8a843259965d1fcba9df329 SHA512 5dbed34739c5dd8d3900285af76acf0c0029ace65789be6e94ccee6f67514f8de1c21dfcb7a0ee2990bd9427f5360672367ca865d572363147cf8f586fa25499 WHIRLPOOL d2e359dbe47d55826148e2971a5794807c34cc75992451a23fe09543bf285eb381d00bc732f593f6775a4d4433c3308a6ebaf664b5fe7c6663c2c4aac60ab338
diff --git a/dev-ada/gps-bin/gps-bin-2016.ebuild b/dev-ada/gps-bin/gps-bin-2016.ebuild
new file mode 100644
index 000000000000..25fd9b696789
--- /dev/null
+++ b/dev-ada/gps-bin/gps-bin-2016.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+MY_P=gnat-gpl-2016-x86_64-linux-bin
+
+DESCRIPTION="The GNAT Programming Studio"
+HOMEPAGE="http://libre.adacore.com/tools/gps/"
+SRC_URI="http://mirrors.cdn.adacore.com/art/5739cefdc7a447658e0b016b -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-ada/gnatcoll[iconv,postgresql,projects,readline,sqlite]
+ dev-ada/gprbuild[shared]
+ dev-db/sqlite
+ dev-lang/gnat-gpl
+ dev-libs/atk
+ dev-libs/glib
+ dev-libs/gobject-introspection
+ dev-libs/libffi
+ media-libs/fontconfig
+ media-libs/freetype
+ sys-devel/llvm
+ sys-devel/clang
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+
+ x11-libs/pango
+ x11-themes/adwaita-icon-theme
+ x11-themes/hicolor-icon-theme"
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ GCC=${ADA:-$(tc-getCC)}
+ GNATLS="${GCC/gcc/gnatls}"
+ GNAT="${GCC/gcc/gnat}"
+ GNATMAKE="${GCC/gcc/gnatmake}"
+ if [[ -z "$(type ${GNATLS} 2>/dev/null)" ]] ; then
+ eerror "You need a gcc compiler that provides the Ada Compiler:"
+ eerror "1) use gcc-config to select the right compiler or"
+ eerror "2) set ADA=gcc-4.9.4 in make.conf"
+ die "ada compiler not available"
+ fi
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ into /opt/${P}
+ dobin bin/gps_exe
+ dobin bin/gps_cli
+ insinto /opt/${P}/share
+ doins -r share/doc
+ doins -r share/examples
+ doins -r share/gpr
+ doins -r share/gprconfig
+ doins -r share/gps
+ doins -r share/themes
+ insinto /opt/${P}/lib/
+ doins -r lib/python2.7
+ dosym ../../../usr/bin/gnatinspect /opt/${P}/bin/gnatinspect
+ dosym ../../../usr/bin/${GNATLS} /opt/${P}/bin/gnatls
+ dosym ../../../usr/bin/${GNATMAKE} /opt/${P}/bin/gnatmake
+ dosym ../../../usr/bin/${GNAT} /opt/${P}/bin/gnat
+ dosym ../../opt/${P}/bin/gps_exe /usr/bin/gps
+}
diff --git a/dev-ada/gps-bin/metadata.xml b/dev-ada/gps-bin/metadata.xml
new file mode 100644
index 000000000000..ebe9a3559c56
--- /dev/null
+++ b/dev-ada/gps-bin/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <longdescription lang="en">
+ GPS, the GNAT Programming Studio, is a cutting-edge Free Software IDE that streamlines the interaction between developers and their software. With its intuitive interface, GPS is easy to use, simplifying source navigation and highlighting the fundamental ideas in the program.
+
+By displaying core application structures, such as call graphs, program entity graphs, and project dependencies, GPS facilitates the development of systems. GPS helps construct reliable code while providing the same interface and behavior across a variety of platforms. Designed by programmers for programmers, GPS is a new kind of IDE that offers the experience of designing software in a uniquely comfortable environment.
+ </longdescription>
+</pkgmetadata>