summaryrefslogtreecommitdiff
path: root/dev-ada/xmlada/xmlada-2021-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-17 23:18:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-17 23:18:13 +0100
commita0d1bdbd841fa761e38f468e1009cd058af305fd (patch)
tree7e025c4f7b68d5b31d24058f9e029c18da4db031 /dev-ada/xmlada/xmlada-2021-r2.ebuild
parent5b9522db2ae57aa61163fb9aff331742e9e22330 (diff)
gentoo auto-resync : 17:09:2022 - 23:18:12
Diffstat (limited to 'dev-ada/xmlada/xmlada-2021-r2.ebuild')
-rw-r--r--dev-ada/xmlada/xmlada-2021-r2.ebuild94
1 files changed, 94 insertions, 0 deletions
diff --git a/dev-ada/xmlada/xmlada-2021-r2.ebuild b/dev-ada/xmlada/xmlada-2021-r2.ebuild
new file mode 100644
index 000000000000..f5640a9457f6
--- /dev/null
+++ b/dev-ada/xmlada/xmlada-2021-r2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ADA_COMPAT=( gnat_202{0..1} )
+inherit ada multiprocessing
+
+MYP=${P}-${PV}0518-19D50-src
+ID=6a2cf72f308cc787926b12ddc20993fcf2b8ea79
+ADAMIRROR=https://community.download.adacore.com/v1
+
+DESCRIPTION="Set of modules that provide a simple manipulation of XML streams"
+HOMEPAGE="http://libre.adacore.com/"
+SRC_URI="${ADAMIRROR}/${ID}?filename=${MYP}.tar.gz -> ${MYP}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+shared static-libs static-pic"
+REQUIRED_USE="|| ( shared static-libs static-pic )
+ ${ADA_REQUIRED_USE}"
+
+RDEPEND="${ADA_DEPS}"
+DEPEND="${RDEPEND}
+ dev-ada/gprbuild[${ADA_USEDEP}]"
+
+S="${WORKDIR}"/${MYP}
+
+PATCHES=( "${FILESDIR}"/${PN}-2019-gentoo.patch )
+
+src_compile() {
+ build () {
+ gprbuild -j$(makeopts_jobs) -m -p -v -XLIBRARY_TYPE=$1 \
+ -XBUILD=Production -XPROCESSORS=$(makeopts_jobs) xmlada.gpr \
+ -largs ${LDFLAGS} \
+ -cargs ${ADAFLAGS} || die "gprbuild failed"
+ }
+ if use shared; then
+ build relocatable
+ fi
+ if use static-libs; then
+ build static
+ fi
+ if use static-pic; then
+ build static-pic
+ fi
+}
+
+src_test() {
+ GPR_PROJECT_PATH=schema:input_sources:dom:sax:unicode \
+ gprbuild -j$(makeopts_jobs) -m -p -v -XLIBRARY_TYPE=static \
+ -XBUILD=Production -XPROCESSORS=$(makeopts_jobs) xmlada.gpr \
+ -XTESTS_ACTIVATED=Only \
+ -largs ${LDFLAGS} \
+ -cargs ${ADAFLAGS} || die "gprbuild failed"
+ emake --no-print-directory -C tests tests | tee xmlada.testLog
+ grep -q DIFF xmlada.testLog && die
+}
+
+src_install() {
+ build () {
+ gprinstall -XLIBRARY_TYPE=$1 -f -p -XBUILD=Production \
+ -XPROCESSORS=$(makeopts_jobs) --prefix="${D}"/usr \
+ --install-name=xmlada --build-var=LIBRARY_TYPE \
+ --build-var=XMLADA_BUILD \
+ --build-name=$1 xmlada.gpr || die "gprinstall failed"
+ }
+ if use shared; then
+ build relocatable
+ fi
+ if use static-libs; then
+ build static
+ fi
+ if use static-pic; then
+ build static-pic
+ fi
+
+ einstalldocs
+ rm -f "${D}"/usr/share/doc/${PN}/.buildinfo
+ dodoc xmlada-roadmap.txt
+ rm -rf "${D}"/usr/share/gpr/manifests
+ dodir /usr/share/gnatdoc
+ mv "${D}"/usr/share/doc/${PN} "${D}"/usr/share/gnatdoc/ || die
+ rm -f "${D}"/usr/share/examples/xmlada/*/b__*
+ rm -f "${D}"/usr/share/examples/xmlada/*/*.adb.std*
+ rm -f "${D}"/usr/share/examples/xmlada/*/*.ali
+ rm -f "${D}"/usr/share/examples/xmlada/*/*.bexch
+ rm -f "${D}"/usr/share/examples/xmlada/*/*.o
+ rm -f "${D}"/usr/share/examples/xmlada/*/*example
+ rm -f "${D}"/usr/share/examples/xmlada/dom/domexample2
+ rm -f "${D}"/usr/share/examples/xmlada/sax/saxexample_main
+ mv "${D}"/usr/share/examples/xmlada "${D}"/usr/share/doc/"${PF}"/examples || die
+}