summaryrefslogtreecommitdiff
path: root/dev-build/autoconf-wrapper
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-15 19:18:29 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-15 19:18:29 +0000
commit4c588f061163483deaeecd52e6a5743762d2603e (patch)
treeb350c2c1cadf3ac9598a043421fcaf654b9e2bc7 /dev-build/autoconf-wrapper
parentb9d13f23ed10bb803607f6ef67f0df2f078aa70f (diff)
gentoo auto-resync : 15:01:2024 - 19:18:28
Diffstat (limited to 'dev-build/autoconf-wrapper')
-rw-r--r--dev-build/autoconf-wrapper/Manifest6
-rw-r--r--dev-build/autoconf-wrapper/autoconf-wrapper-20221207-r1.ebuild45
-rw-r--r--dev-build/autoconf-wrapper/autoconf-wrapper-20231224.ebuild47
-rw-r--r--dev-build/autoconf-wrapper/autoconf-wrapper-99999999.ebuild47
-rw-r--r--dev-build/autoconf-wrapper/metadata.xml13
5 files changed, 158 insertions, 0 deletions
diff --git a/dev-build/autoconf-wrapper/Manifest b/dev-build/autoconf-wrapper/Manifest
new file mode 100644
index 000000000000..7998850da291
--- /dev/null
+++ b/dev-build/autoconf-wrapper/Manifest
@@ -0,0 +1,6 @@
+DIST autotools-wrappers-at-20221207.tar.gz 3646 BLAKE2B 82bec40e03ae5ec133252fd3c05c3fed537bb415e800918df9c9d783d48a9d76cbe60c53dd7daf6d94653d79fc52be8c089183dda996e8a72dd03ffa83098613 SHA512 12ea99721e6fc60a3ed7351d6c228aaf6e4eef0bd0444eda8cd742f74fa91150ef07bb52f6bcad4a350269e8032f5d4e204d2f2108b0d9c441ddd7f9755862b7
+DIST autotools-wrappers-at-20231224.tar.gz 3645 BLAKE2B fbf414240fe3a4b5d2c24ea649cc347df46bf7f0297bc0d27f98265f57753a596929277403496d76d6249f878bffa8be3e77b62ce9138df6920dd9a5216b300a SHA512 a3cc51e1eb1d055a8161b86bc3497a9bea3cb972d8d22b2f9fc712ca5ecb7809e84083a5754705911f2d037cbff83747476e96b412bfe11183273764de0d5331
+EBUILD autoconf-wrapper-20221207-r1.ebuild 1194 BLAKE2B 3755e3c5f27c70a0fe6a6f35281ed3309a6901e4b4fee4b2d1bef1452925168ab9854c67b72496e8a0871cf76c6eebeef8c5b0ecb4fd13f8cc7c255318de2a2a SHA512 82d6b8c82347984febeebb1e3639e4613ed352cb9579c18ceae7f0974fff1f4ac9cd4a604241f077e34cbea8aeca4427819030b05b828dfb86d162953ede9bbe
+EBUILD autoconf-wrapper-20231224.ebuild 1276 BLAKE2B e5d466db04b6c673ef04d78be254f7bcc4d9dc986a3153f08ca680272ed832867164853c3bcf8b7e9f38087321f53b900ba0f3846ae891dc078068e1d6d9242f SHA512 a262438c1d6418bf4c860716aebe24b8a0d3071c0b4f8ce450c4b4f508ff33217789dc30d5f1ba146663379ce295336f8eaa3360337055efd71c876323cc9ece
+EBUILD autoconf-wrapper-99999999.ebuild 1276 BLAKE2B e5d466db04b6c673ef04d78be254f7bcc4d9dc986a3153f08ca680272ed832867164853c3bcf8b7e9f38087321f53b900ba0f3846ae891dc078068e1d6d9242f SHA512 a262438c1d6418bf4c860716aebe24b8a0d3071c0b4f8ce450c4b4f508ff33217789dc30d5f1ba146663379ce295336f8eaa3360337055efd71c876323cc9ece
+MISC metadata.xml 435 BLAKE2B 006f03645ce3cb9a4f7cad6411f3487500f58f351bbacfb6e1e3de494214fccb8b478a2cea35d289ee0a487fa7eaf31ca444cbf82d1d9eeee1822928e223009b SHA512 3b699336ca3dbf40bcfddb1db91f8d3803574c9c6765b477b93e50d756ac3c441e5bedfbbc71fcbea697a2f31b9a41fcbbb01a38d5acc8d29b48779a405f8f6c
diff --git a/dev-build/autoconf-wrapper/autoconf-wrapper-20221207-r1.ebuild b/dev-build/autoconf-wrapper/autoconf-wrapper-20221207-r1.ebuild
new file mode 100644
index 000000000000..417ec628886f
--- /dev/null
+++ b/dev-build/autoconf-wrapper/autoconf-wrapper-20221207-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="autotools-wrappers-at-${PV}"
+
+DESCRIPTION="Wrapper for autoconf to manage multiple autoconf versions"
+HOMEPAGE="https://gitweb.gentoo.org/proj/autotools-wrappers.git"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="
+ https://anongit.gentoo.org/git/proj/autotools-wrappers.git
+ https://github.com/gentoo/autotools-wrappers
+ "
+ inherit git-r3
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/autotools-wrappers.git/snapshot/${MY_P}.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+
+ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+src_prepare() {
+ default
+
+ # usr/bin/aclocal: bad substitution -> /bin/sh != POSIX shell
+ if use prefix ; then
+ sed -i -e '1c\#!'"${EPREFIX}"'/bin/sh' ac-wrapper.sh || die
+ fi
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/misc
+ doexe ac-wrapper.sh
+
+ dodir /usr/bin
+ local x=
+ for x in auto{conf,header,m4te,reconf,scan,update} ifnames ; do
+ dosym -r /usr/$(get_libdir)/misc/ac-wrapper.sh /usr/bin/${x}
+ done
+}
diff --git a/dev-build/autoconf-wrapper/autoconf-wrapper-20231224.ebuild b/dev-build/autoconf-wrapper/autoconf-wrapper-20231224.ebuild
new file mode 100644
index 000000000000..13b3c2d923ec
--- /dev/null
+++ b/dev-build/autoconf-wrapper/autoconf-wrapper-20231224.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="autotools-wrappers-at-${PV}"
+
+# Remember to modify LAST_KNOWN_VER 'upstream' on new autoconf releases!
+
+DESCRIPTION="Wrapper for autoconf to manage multiple autoconf versions"
+HOMEPAGE="https://gitweb.gentoo.org/proj/autotools-wrappers.git"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="
+ https://anongit.gentoo.org/git/proj/autotools-wrappers.git
+ https://github.com/gentoo/autotools-wrappers
+ "
+ inherit git-r3
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/autotools-wrappers.git/snapshot/${MY_P}.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+src_prepare() {
+ default
+
+ # usr/bin/aclocal: bad substitution -> /bin/sh != POSIX shell
+ if use prefix ; then
+ sed -i -e '1c\#!'"${EPREFIX}"'/bin/sh' ac-wrapper.sh || die
+ fi
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/misc
+ doexe ac-wrapper.sh
+
+ dodir /usr/bin
+ local x=
+ for x in auto{conf,header,m4te,reconf,scan,update} ifnames ; do
+ dosym -r /usr/$(get_libdir)/misc/ac-wrapper.sh /usr/bin/${x}
+ done
+}
diff --git a/dev-build/autoconf-wrapper/autoconf-wrapper-99999999.ebuild b/dev-build/autoconf-wrapper/autoconf-wrapper-99999999.ebuild
new file mode 100644
index 000000000000..13b3c2d923ec
--- /dev/null
+++ b/dev-build/autoconf-wrapper/autoconf-wrapper-99999999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="autotools-wrappers-at-${PV}"
+
+# Remember to modify LAST_KNOWN_VER 'upstream' on new autoconf releases!
+
+DESCRIPTION="Wrapper for autoconf to manage multiple autoconf versions"
+HOMEPAGE="https://gitweb.gentoo.org/proj/autotools-wrappers.git"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="
+ https://anongit.gentoo.org/git/proj/autotools-wrappers.git
+ https://github.com/gentoo/autotools-wrappers
+ "
+ inherit git-r3
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/autotools-wrappers.git/snapshot/${MY_P}.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+src_prepare() {
+ default
+
+ # usr/bin/aclocal: bad substitution -> /bin/sh != POSIX shell
+ if use prefix ; then
+ sed -i -e '1c\#!'"${EPREFIX}"'/bin/sh' ac-wrapper.sh || die
+ fi
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/misc
+ doexe ac-wrapper.sh
+
+ dodir /usr/bin
+ local x=
+ for x in auto{conf,header,m4te,reconf,scan,update} ifnames ; do
+ dosym -r /usr/$(get_libdir)/misc/ac-wrapper.sh /usr/bin/${x}
+ done
+}
diff --git a/dev-build/autoconf-wrapper/metadata.xml b/dev-build/autoconf-wrapper/metadata.xml
new file mode 100644
index 000000000000..2847c0b0420f
--- /dev/null
+++ b/dev-build/autoconf-wrapper/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="gentoo">proj/autotools-wrappers</remote-id>
+ <remote-id type="github">gentoo/autotools-wrappers</remote-id>
+ </upstream>
+</pkgmetadata>