summaryrefslogtreecommitdiff
path: root/dev-cpp/benchmark/benchmark-1.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-14 00:49:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-14 00:49:44 +0000
commit4828c25c25aacf399de429d381288982fd7e0d0e (patch)
treea265b5f79cf1b578c4e54483be1466f657f4baba /dev-cpp/benchmark/benchmark-1.7.1.ebuild
parentf8d671851faf1ca201cec0490ead4642c8987bae (diff)
gentoo auto-resync : 14:11:2022 - 00:49:44
Diffstat (limited to 'dev-cpp/benchmark/benchmark-1.7.1.ebuild')
-rw-r--r--dev-cpp/benchmark/benchmark-1.7.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-cpp/benchmark/benchmark-1.7.1.ebuild b/dev-cpp/benchmark/benchmark-1.7.1.ebuild
new file mode 100644
index 000000000000..fdf73017860e
--- /dev/null
+++ b/dev-cpp/benchmark/benchmark-1.7.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="A microbenchmark support library"
+HOMEPAGE="https://github.com/google/benchmark"
+SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="debug doc lto test"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="doc? ( app-doc/doxygen )
+ test? ( >=dev-cpp/gtest-1.11.0 )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBENCHMARK_ENABLE_ASSEMBLY_TESTS=OFF
+ -DBENCHMARK_ENABLE_DOXYGEN=$(usex doc)
+ -DBENCHMARK_ENABLE_GTEST_TESTS=$(usex test)
+ -DBENCHMARK_ENABLE_LTO=$(usex lto)
+ -DBENCHMARK_ENABLE_TESTING=$(usex test)
+ -DBENCHMARK_ENABLE_WERROR=OFF
+ -DBENCHMARK_USE_BUNDLED_GTEST=OFF
+ )
+
+ use debug || append-cppflags -DNDEBUG
+
+ cmake_src_configure
+}