summaryrefslogtreecommitdiff
path: root/dev-cpp/catch/catch-1.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-10 00:43:02 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-10 00:43:02 +0000
commita5332b59346f7cbf0fdbd148b54aa8a84aaf8190 (patch)
treee6d8d3589fcd01fbc3f1286185639163daa81424 /dev-cpp/catch/catch-1.9999.ebuild
parentfceeaf01a28ee71065cf3798b70b77d3bc4ef199 (diff)
gentoo resync : 10.11.2017
Diffstat (limited to 'dev-cpp/catch/catch-1.9999.ebuild')
-rw-r--r--dev-cpp/catch/catch-1.9999.ebuild19
1 files changed, 7 insertions, 12 deletions
diff --git a/dev-cpp/catch/catch-1.9999.ebuild b/dev-cpp/catch/catch-1.9999.ebuild
index 8949a527ca65..4cad4e13c4b7 100644
--- a/dev-cpp/catch/catch-1.9999.ebuild
+++ b/dev-cpp/catch/catch-1.9999.ebuild
@@ -4,7 +4,7 @@
EAPI=6
EGIT_REPO_URI="https://github.com/philsquared/Catch.git"
-EGIT_BRANCH=master
+EGIT_BRANCH=Catch1.x
inherit cmake-utils git-r3
DESCRIPTION="Modern C++ header-only framework for unit-tests"
@@ -14,21 +14,16 @@ SRC_URI=""
LICENSE="Boost-1.0"
SLOT="0"
KEYWORDS=""
-IUSE=""
+IUSE="test"
-# CMake is only used to build & run tests, so override phases
-src_configure() { :; }
-src_compile() { :; }
-
-src_test() {
+src_configure() {
+ local mycmakeargs=(
+ -DNO_SELFTEST=$(usex !test)
+ )
cmake-utils_src_configure
- cmake-utils_src_compile
- cmake-utils_src_test
}
src_install() {
- # same location as used in fedora
- insinto /usr/include/catch
- doins -r include/.
+ cmake-utils_src_install
dodoc -r docs/.
}