summaryrefslogtreecommitdiff
path: root/dev-cpp/catch/catch-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /dev-cpp/catch/catch-9999.ebuild
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'dev-cpp/catch/catch-9999.ebuild')
-rw-r--r--dev-cpp/catch/catch-9999.ebuild19
1 files changed, 14 insertions, 5 deletions
diff --git a/dev-cpp/catch/catch-9999.ebuild b/dev-cpp/catch/catch-9999.ebuild
index d7763c4ccaa9..5318b054d396 100644
--- a/dev-cpp/catch/catch-9999.ebuild
+++ b/dev-cpp/catch/catch-9999.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
-inherit cmake-utils
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit cmake-utils python-any-r1
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -25,11 +26,19 @@ SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
+BDEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
src_configure() {
local mycmakeargs=(
-DCATCH_ENABLE_WERROR=OFF
-DBUILD_TESTING=$(usex test)
- -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
)
+ use test &&
+ mycmakeargs+=(-DPYTHON_EXECUTABLE="${PYTHON}")
+
cmake-utils_src_configure
}