summaryrefslogtreecommitdiff
path: root/dev-cpp/cpp-hocon/cpp-hocon-0.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-cpp/cpp-hocon/cpp-hocon-0.3.0.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-cpp/cpp-hocon/cpp-hocon-0.3.0.ebuild')
-rw-r--r--dev-cpp/cpp-hocon/cpp-hocon-0.3.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-cpp/cpp-hocon/cpp-hocon-0.3.0.ebuild b/dev-cpp/cpp-hocon/cpp-hocon-0.3.0.ebuild
new file mode 100644
index 000000000000..082eef626412
--- /dev/null
+++ b/dev-cpp/cpp-hocon/cpp-hocon-0.3.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Provides C++ support for the HOCON configuration file format"
+HOMEPAGE="https://github.com/puppetlabs/cpp-hocon"
+SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+DEPEND="
+ >=dev-libs/boost-1.54:=[nls]
+ >=dev-libs/leatherman-0.9.3:=
+ "
+RDEPEND="${DEPEND}"
+
+#PATCHES=( "${FILESDIR}"/${PN}-0.2.1-cmake.patch )