summaryrefslogtreecommitdiff
path: root/dev-cpp/cpp-taskflow
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-cpp/cpp-taskflow
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-cpp/cpp-taskflow')
-rw-r--r--dev-cpp/cpp-taskflow/Manifest4
-rw-r--r--dev-cpp/cpp-taskflow/cpp-taskflow-3.2.0.ebuild44
-rw-r--r--dev-cpp/cpp-taskflow/cpp-taskflow-9999.ebuild44
-rw-r--r--dev-cpp/cpp-taskflow/metadata.xml20
4 files changed, 0 insertions, 112 deletions
diff --git a/dev-cpp/cpp-taskflow/Manifest b/dev-cpp/cpp-taskflow/Manifest
deleted file mode 100644
index e3a5c61b503a..000000000000
--- a/dev-cpp/cpp-taskflow/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-DIST cpp-taskflow-3.2.0.tar.gz 79152157 BLAKE2B 03b4b1cf772c9dec4557a706c7872de95312d4e72ec7dcef1accfd1d5eaf470e60440d75ea0c993ab494ef460dc44639719ea1732fa92c54d64dde31b90b9224 SHA512 e30d95b69f64524c9b06cf7442236998f91b1083818f06439888d78d5a1b988bc952c02fd0ec88114283cbe6c31a7bbfe810a7114998f4b5f60c4cff921bb0fa
-EBUILD cpp-taskflow-3.2.0.ebuild 916 BLAKE2B 4d5305037f08b64b32462dc9215442f97f48a4985fa4582d76432ccdb4bff650d21e43e0181b9ea0a5f8f3be344d5e9e1dc51f180852f8284639a1405b6190df SHA512 27c769ebc5b91284dc0f902c96a2fdc70f068e85e0edda344414f0433f6f3c5923c4afb34805a2f6c4416beb93ed17a41472b961dac1c38dd38d8a3b0af47dd8
-EBUILD cpp-taskflow-9999.ebuild 916 BLAKE2B 4d5305037f08b64b32462dc9215442f97f48a4985fa4582d76432ccdb4bff650d21e43e0181b9ea0a5f8f3be344d5e9e1dc51f180852f8284639a1405b6190df SHA512 27c769ebc5b91284dc0f902c96a2fdc70f068e85e0edda344414f0433f6f3c5923c4afb34805a2f6c4416beb93ed17a41472b961dac1c38dd38d8a3b0af47dd8
-MISC metadata.xml 663 BLAKE2B d9364c3cb5391e8b95488f7016d1dcf51400970c8ea0737549c91ca3ec4ac1132c3c34d76bc2aaefe80dbef2887ae28e150d8d396d297c19fc2d45b7f827417e SHA512 054c5840f22ed9ecb67c85a7ca78898ab7897de5bb254ab61a602ec1031e92cde398525c9c97c59d0b66a57f3fab5f8acb0efa511c958a6754dcf7f2c0c77359
diff --git a/dev-cpp/cpp-taskflow/cpp-taskflow-3.2.0.ebuild b/dev-cpp/cpp-taskflow/cpp-taskflow-3.2.0.ebuild
deleted file mode 100644
index 9b146d9dc546..000000000000
--- a/dev-cpp/cpp-taskflow/cpp-taskflow-3.2.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Modern C++ Parallel Task Programming"
-HOMEPAGE="https://cpp-taskflow.github.io"
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://github.com/cpp-taskflow/${PN}.git"
- inherit git-r3
- S="${WORKDIR}/cpp-taskflow-${PV}"
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/taskflow-${PV}"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( dev-cpp/doctest )"
-
-HTML_DOCS=( docs/. )
-
-src_prepare() {
- rm -r "${S}/3rd-party" || die "rm failed"
- default
- cmake_src_prepare
-}
-
-src_configure() {
- # TODO: enable CUDA via USE flag
- local mycmakeargs=(
- -DTF_BUILD_CUDA=OFF
- -DTF_BUILD_EXAMPLES=$(usex examples)
- -DTF_BUILD_TESTS=$(usex test)
- )
-
- cmake_src_configure
-}
diff --git a/dev-cpp/cpp-taskflow/cpp-taskflow-9999.ebuild b/dev-cpp/cpp-taskflow/cpp-taskflow-9999.ebuild
deleted file mode 100644
index 9b146d9dc546..000000000000
--- a/dev-cpp/cpp-taskflow/cpp-taskflow-9999.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Modern C++ Parallel Task Programming"
-HOMEPAGE="https://cpp-taskflow.github.io"
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://github.com/cpp-taskflow/${PN}.git"
- inherit git-r3
- S="${WORKDIR}/cpp-taskflow-${PV}"
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/taskflow-${PV}"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( dev-cpp/doctest )"
-
-HTML_DOCS=( docs/. )
-
-src_prepare() {
- rm -r "${S}/3rd-party" || die "rm failed"
- default
- cmake_src_prepare
-}
-
-src_configure() {
- # TODO: enable CUDA via USE flag
- local mycmakeargs=(
- -DTF_BUILD_CUDA=OFF
- -DTF_BUILD_EXAMPLES=$(usex examples)
- -DTF_BUILD_TESTS=$(usex test)
- )
-
- cmake_src_configure
-}
diff --git a/dev-cpp/cpp-taskflow/metadata.xml b/dev-cpp/cpp-taskflow/metadata.xml
deleted file mode 100644
index 5b4c8bac454b..000000000000
--- a/dev-cpp/cpp-taskflow/metadata.xml
+++ /dev/null
@@ -1,20 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>tamiko@gentoo.org</email>
- <name>Matthias Maier</name>
- </maintainer>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <longdescription>
- Cpp-Taskflow is faster, more expressive, and easier for drop-in
- integration than many of existing task programming frameworks in
- handling complex parallel workloads.
- </longdescription>
- <upstream>
- <remote-id type="github">cpp-taskflow/cpp-taskflow</remote-id>
- </upstream>
-</pkgmetadata>