summaryrefslogtreecommitdiff
path: root/dev-cpp/cpp-taskflow
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-cpp/cpp-taskflow
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-cpp/cpp-taskflow')
-rw-r--r--dev-cpp/cpp-taskflow/Manifest2
-rw-r--r--dev-cpp/cpp-taskflow/cpp-taskflow-2.6.0.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-cpp/cpp-taskflow/Manifest b/dev-cpp/cpp-taskflow/Manifest
index ccbb8c11d2ef..59113d5cc7b0 100644
--- a/dev-cpp/cpp-taskflow/Manifest
+++ b/dev-cpp/cpp-taskflow/Manifest
@@ -1,5 +1,7 @@
AUX cpp-taskflow-2.4.0-do_not_compile_examples.patch 2634 BLAKE2B 6b326b97e721061892abe0e01bcfb49dffea91b641684b1c860c8f8384153103107d9ab26dfaa4b577897e49f45fa2a6cfaaf5cf49409afa429b5dd0c7aefda9 SHA512 21b61ba80536cf8baa24c67e35902b66fb98408f86be8a4611b15304525c2e14a20af80507ccdd4d6a365303abdc38d1d199f1888baa0a35a04483a837ddadd5
AUX cpp-taskflow-2.4.0-fix_installation_path.patch 739 BLAKE2B 6cf25c76b91d3e60c7a9f35bcf0d5a89f28dd42efb32c3fa57eefd9b716e9905d20cd8becc0a47cf74f992bf2e77b6051034f62533dbfdab4b57a70a4b24eecf SHA512 36e2284da55eba9ca24a34e8baa105a28e411d54927378f6978c96c19af08a760fc4f3caff6ec4f325d63ca8974e7b66e27e3c69ba39e22f6b8e67d3ae303b24
DIST cpp-taskflow-2.4.0.tar.gz 76993334 BLAKE2B 8f257165ab72dbe6c1cf6a86886669008e9f16f1dfd4871defc452bdb9dfa3e45ab9bfbbdc874b4ba566a2a7d8984a666ce2933b2c6d2215467f7fbfa03ac520 SHA512 dd6c7500e39d7058871280d12e120bd28d9609e5289f1d7851b3b59e2c1bfe74d3040d902bd5b26895e558b563c8abad878e7bc343e199e7356940c02a64217f
+DIST cpp-taskflow-2.6.0.tar.gz 68626469 BLAKE2B d85b1615be47c1e98e613e7875424892613205a0cc3f380f7d6fd0521045c5750441e9267382ec5282299e4074a7b85f442e53f38a2f12aff7d3d925a94b8773 SHA512 43b023c7d744ae1e0baf6f504f32da481e950ec5cc34fe5511e4bbb8905203e4726917ee103b1c02544a75c6216c2ca481034be810b61a35511a3d7a2b278133
EBUILD cpp-taskflow-2.4.0-r1.ebuild 603 BLAKE2B 0620b659d11e94d1fde1e6f53767a98aded76fc8f7b2af238e0ff4a900484dbae00a288e12bce48a4c3adde8ced548dcef577528473328408e93219b1e49ebb3 SHA512 fd5822c2ff54904142ebf6fc5c36f263ce16178d6b161aa412dad4cb378f9e9449943e2a836cc815c9e3d6ef4f4f32bed6ef86ae0f712689cc81bb2cc4b9887f
+EBUILD cpp-taskflow-2.6.0.ebuild 873 BLAKE2B 61b2318d8380aaabf27a8965bf5759b90d8941d9c7cb183273141d462fc4cfc0d41b705fc5a69537d5154325298634dde3808a207ea0bca29f49b230e589bf47 SHA512 914ad99f49f82aa63a8a700ac4c9e6bd6f0e9af0b0e90a651f7d02fb0b180fd5b1e359b8b9fbab7557a0ca242c9440a9384d66d7a9ee5ad1c0291fcb4eed033a
MISC metadata.xml 662 BLAKE2B 9a3c9f4208ed92f0957323e281cedd321b9e15c15af231eeca1b88b8e0d87df81a546afd8877f496151c0815cb566d9e205fe1eb8b8fce33114435e2c66f75ab SHA512 9b0b6de9d422df44507429af356aa0d31411a564efe4a58065cdff38845f1e1e53fef6aef8a8537ccfff8ee36e3e77beff65aca3bda4efb2a5f3166c41ea68d2
diff --git a/dev-cpp/cpp-taskflow/cpp-taskflow-2.6.0.ebuild b/dev-cpp/cpp-taskflow/cpp-taskflow-2.6.0.ebuild
new file mode 100644
index 000000000000..aba4692adef3
--- /dev/null
+++ b/dev-cpp/cpp-taskflow/cpp-taskflow-2.6.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Modern C++ Parallel Task Programming"
+HOMEPAGE="https://cpp-taskflow.github.io"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND=""
+
+S="${WORKDIR}/taskflow-${PV}"
+
+PATCHES=(
+)
+
+HTML_DOCS=( docs/. )
+
+src_prepare() {
+ default
+
+ # fix library directoy
+ sed -i "s#/lib#/$(get_libdir)#g" CMakeLists.txt || die "sed failed"
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ # FIXME: enable CUDA and TESTS via use flag
+ local mycmakeargs=(
+ -DTF_BUILD_CUDA=OFF
+ -DTF_BUILD_TESTS=OFF
+ -DTF_BUILD_EXAMPLES=OFF
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if $(use doc); then
+ einstalldocs
+ fi
+}