summaryrefslogtreecommitdiff
path: root/dev-cpp/cpptoml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-12 03:02:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-12 03:02:41 +0000
commit51be8f45b17e3da3ac48eca6b16b703bb58fda76 (patch)
treebc6f18bc4913276cff3f8c2f2ec357f9026c602c /dev-cpp/cpptoml
parent0ab98a20dbfb8c64ab93e02280abb4ff18652ae0 (diff)
gentoo auto-resync : 12:11:2024 - 03:02:41
Diffstat (limited to 'dev-cpp/cpptoml')
-rw-r--r--dev-cpp/cpptoml/Manifest4
-rw-r--r--dev-cpp/cpptoml/cpptoml-0.1.1.ebuild31
-rw-r--r--dev-cpp/cpptoml/files/cpptoml-0.1.1-limits.patch15
-rw-r--r--dev-cpp/cpptoml/metadata.xml22
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-cpp/cpptoml/Manifest b/dev-cpp/cpptoml/Manifest
new file mode 100644
index 000000000000..cda5a5f3201a
--- /dev/null
+++ b/dev-cpp/cpptoml/Manifest
@@ -0,0 +1,4 @@
+AUX cpptoml-0.1.1-limits.patch 398 BLAKE2B 3f32f6eb64b315801e48a9c4af7d64f6d29f6ed9e08e6eec8027af1362f194406df3bfa5e366af7729e39f9e6dabc194487ece8be0773b93ccd42c2a33e04ab2 SHA512 5069644bf32d6f617de522c6db58c1855feb9554fa4b87d44b52f392766c9e6059bf1060fdb77f4474e345de00e78c2d5b20e939eab559d6b5d780fb31dd9aed
+DIST cpptoml-0.1.1.tar.gz 47398 BLAKE2B c0ce036bec4731c4dfe96d01076b9ca18a1c4108180d5dbc839dfc44b37eb0c7af85f685a6356ef92fa684219e2883dd341e64a2012505dacc3df73dfb9e28ca SHA512 14edce576514d53a7e13562d7f8d2b66ea2b95f44038396c0e26232ec81783042ebecec31ee272a99afef96d5c8582a8e81ea5167a787844b98de6ee6f545cc5
+EBUILD cpptoml-0.1.1.ebuild 628 BLAKE2B 0d14998fd91d722bd38a65e9188c73719995b96825de6ea5ae8469fd10b55161eb53400f2a4ba47f169b7ad3f54ee01c2daa10a87dd1a3772199671ee84339ef SHA512 78e15eebfb619cc2af9b268c52bc22ed74d84d67afe6f61c647c7fbac610be5bb48f17e12e41d2b45252d496c26538fcac2be249d5685c4a4fdaff511d963d5a
+MISC metadata.xml 822 BLAKE2B ee55b32633362a35150d6465a65a3af1c35727e0652dcda66eae510b21f86bc5c969acd27fd822ff9d94ec9cba034e5f7b9df85ce02298eda2e5f89b0135e975 SHA512 8019ded1e37c739fb642b552608954292d91cf20ece97c35249ffe9da68d77c44209a78cbdc5227a560f85923c160bd5567b11a0aab19f36989ff05ee25a1860
diff --git a/dev-cpp/cpptoml/cpptoml-0.1.1.ebuild b/dev-cpp/cpptoml/cpptoml-0.1.1.ebuild
new file mode 100644
index 000000000000..27c81a63572b
--- /dev/null
+++ b/dev-cpp/cpptoml/cpptoml-0.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake toolchain-funcs
+
+DESCRIPTION="Header-only library for parsing TOML"
+HOMEPAGE="https://github.com/skystrife/cpptoml"
+SRC_URI="https://github.com/skystrife/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+PATCHES=(
+ "${FILESDIR}/${P}-limits.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCPPTOML_BUILD_EXAMPLES=$(usex examples)
+ )
+
+ if [[ $(tc-get-cxx-stdlib) == libc++ ]]; then
+ mycmakeargs+=(-DENABLE_LIBCXX=ON)
+ fi
+
+ cmake_src_configure
+}
diff --git a/dev-cpp/cpptoml/files/cpptoml-0.1.1-limits.patch b/dev-cpp/cpptoml/files/cpptoml-0.1.1-limits.patch
new file mode 100644
index 000000000000..484f98044be4
--- /dev/null
+++ b/dev-cpp/cpptoml/files/cpptoml-0.1.1-limits.patch
@@ -0,0 +1,15 @@
+From c55a516e90133d89d67285429c6474241346d27a Mon Sep 17 00:00:00 2001
+From: Dirk Eddelbuettel <edd@debian.org>
+Date: Mon, 30 Nov 2020 09:41:49 -0600
+Subject: [PATCH] g++-11 requires limits header
+
+--- a/include/cpptoml.h
++++ b/include/cpptoml.h
+@@ -14,6 +14,7 @@
+ #include <cstring>
+ #include <fstream>
+ #include <iomanip>
++#include <limits>
+ #include <map>
+ #include <memory>
+ #include <sstream>
diff --git a/dev-cpp/cpptoml/metadata.xml b/dev-cpp/cpptoml/metadata.xml
new file mode 100644
index 000000000000..88ca6c8a4ea6
--- /dev/null
+++ b/dev-cpp/cpptoml/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+A header-only library for parsing TOML configuration files.
+
+Targets: TOML v0.5.0 as of August 2018.
+
+This includes support for the new DateTime format, inline tables, multi-line basic and raw strings, digit separators, hexadecimal integers, octal integers, binary integers, and float special values.
+ </longdescription>
+ <maintainer type="person" proxied="yes">
+ <email>sin-ack@protonmail.com</email>
+ <name>sin-ack</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ddemidov/vexcl</remote-id>
+ </upstream>
+</pkgmetadata>