summaryrefslogtreecommitdiff
path: root/dev-cpp/cpptoml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-24 03:02:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-24 03:02:55 +0000
commit530a5a826feeb71085fb8a01927f4d775a0b131b (patch)
treeb7669c45ea3f2a3a37b2437817a370226bb1c819 /dev-cpp/cpptoml
parent71dd9d29cdaf7cc0ecdb9ea37d128726a941c630 (diff)
gentoo auto-resync : 24:11:2024 - 03:02:54
Diffstat (limited to 'dev-cpp/cpptoml')
-rw-r--r--dev-cpp/cpptoml/Manifest3
-rw-r--r--dev-cpp/cpptoml/cpptoml-0.1.1-r1.ebuild (renamed from dev-cpp/cpptoml/cpptoml-0.1.1.ebuild)9
-rw-r--r--dev-cpp/cpptoml/files/cpptoml-0.1.1-remove-libcxx-config.patch37
3 files changed, 42 insertions, 7 deletions
diff --git a/dev-cpp/cpptoml/Manifest b/dev-cpp/cpptoml/Manifest
index cda5a5f3201a..29a872d825fe 100644
--- a/dev-cpp/cpptoml/Manifest
+++ b/dev-cpp/cpptoml/Manifest
@@ -1,4 +1,5 @@
AUX cpptoml-0.1.1-limits.patch 398 BLAKE2B 3f32f6eb64b315801e48a9c4af7d64f6d29f6ed9e08e6eec8027af1362f194406df3bfa5e366af7729e39f9e6dabc194487ece8be0773b93ccd42c2a33e04ab2 SHA512 5069644bf32d6f617de522c6db58c1855feb9554fa4b87d44b52f392766c9e6059bf1060fdb77f4474e345de00e78c2d5b20e939eab559d6b5d780fb31dd9aed
+AUX cpptoml-0.1.1-remove-libcxx-config.patch 1042 BLAKE2B d67e924cd53bcc65323675d8e77c94c71401ed8c623e0ca3f73254c5a532b520fe203a001da6116a49bcb572100c181445667d76c00878200f1a275ce75a04af SHA512 8356a685b3bca874984533b14262b17ebfc189e08a0f8c7e74bbe9b46ff6ebd8d3eedfd0a998ec5dd22eada59acf1673bcec22b9490d23863995e0bbb9b5569a
DIST cpptoml-0.1.1.tar.gz 47398 BLAKE2B c0ce036bec4731c4dfe96d01076b9ca18a1c4108180d5dbc839dfc44b37eb0c7af85f685a6356ef92fa684219e2883dd341e64a2012505dacc3df73dfb9e28ca SHA512 14edce576514d53a7e13562d7f8d2b66ea2b95f44038396c0e26232ec81783042ebecec31ee272a99afef96d5c8582a8e81ea5167a787844b98de6ee6f545cc5
-EBUILD cpptoml-0.1.1.ebuild 628 BLAKE2B 0d14998fd91d722bd38a65e9188c73719995b96825de6ea5ae8469fd10b55161eb53400f2a4ba47f169b7ad3f54ee01c2daa10a87dd1a3772199671ee84339ef SHA512 78e15eebfb619cc2af9b268c52bc22ed74d84d67afe6f61c647c7fbac610be5bb48f17e12e41d2b45252d496c26538fcac2be249d5685c4a4fdaff511d963d5a
+EBUILD cpptoml-0.1.1-r1.ebuild 578 BLAKE2B 21f0ab444b7aecf02a219a0ef472e95e85a0fb3dcfb52c19f5c9fe49a61568e45b9cb1a9a968770f5832e0281a6586ad968f40c0e6297a6f5ae4e2783289456e SHA512 35bb51b9656e54f6d757b1350c5f8340240b4d34192bc8d79e479f605e85a4a54ebc7f17d369300d04060d73fb8da3a2438b232783105d76d756c2b576958171
MISC metadata.xml 822 BLAKE2B ee55b32633362a35150d6465a65a3af1c35727e0652dcda66eae510b21f86bc5c969acd27fd822ff9d94ec9cba034e5f7b9df85ce02298eda2e5f89b0135e975 SHA512 8019ded1e37c739fb642b552608954292d91cf20ece97c35249ffe9da68d77c44209a78cbdc5227a560f85923c160bd5567b11a0aab19f36989ff05ee25a1860
diff --git a/dev-cpp/cpptoml/cpptoml-0.1.1.ebuild b/dev-cpp/cpptoml/cpptoml-0.1.1-r1.ebuild
index 27c81a63572b..d353eccd491f 100644
--- a/dev-cpp/cpptoml/cpptoml-0.1.1.ebuild
+++ b/dev-cpp/cpptoml/cpptoml-0.1.1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake toolchain-funcs
+inherit cmake
DESCRIPTION="Header-only library for parsing TOML"
HOMEPAGE="https://github.com/skystrife/cpptoml"
@@ -11,11 +11,12 @@ SRC_URI="https://github.com/skystrife/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~arm64"
IUSE="examples"
PATCHES=(
"${FILESDIR}/${P}-limits.patch"
+ "${FILESDIR}/${P}-remove-libcxx-config.patch"
)
src_configure() {
@@ -23,9 +24,5 @@ src_configure() {
-DCPPTOML_BUILD_EXAMPLES=$(usex examples)
)
- if [[ $(tc-get-cxx-stdlib) == libc++ ]]; then
- mycmakeargs+=(-DENABLE_LIBCXX=ON)
- fi
-
cmake_src_configure
}
diff --git a/dev-cpp/cpptoml/files/cpptoml-0.1.1-remove-libcxx-config.patch b/dev-cpp/cpptoml/files/cpptoml-0.1.1-remove-libcxx-config.patch
new file mode 100644
index 000000000000..a25f004d83e5
--- /dev/null
+++ b/dev-cpp/cpptoml/files/cpptoml-0.1.1-remove-libcxx-config.patch
@@ -0,0 +1,37 @@
+From bfb98b0f1e0ffdc187e87c79e1c3114eadc3fa0e Mon Sep 17 00:00:00 2001
+From: sin-ack <sin-ack@protonmail.com>
+Date: Sat, 23 Nov 2024 20:28:52 +0100
+Subject: [PATCH] Remove custom configuration for libc++
+
+This doesn't seem to be necessary anymore for libc++ support, and
+actually breaks builds on system-libcxx systems.
+---
+ CMakeLists.txt | 6 ------
+ 1 file changed, 6 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4ec25cc..6f4753b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -11,7 +11,6 @@ include(CMakePushCheckState)
+
+ cmake_push_check_state()
+
+-option(ENABLE_LIBCXX "Use libc++ for the C++ standard library" ON)
+ option(CPPTOML_BUILD_EXAMPLES "Build examples" ON)
+
+ set(CMAKE_EXPORT_COMPILE_COMMANDS 1)
+@@ -25,11 +24,6 @@ if(UNIX OR MINGW)
+ if(CMAKE_GENERATOR STREQUAL "Ninja")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fcolor-diagnostics")
+ endif()
+-
+- if(ENABLE_LIBCXX)
+- find_package(LIBCXX REQUIRED)
+- set_libcxx_required_flags()
+- endif()
+ endif()
+ endif()
+
+--
+2.45.2