summaryrefslogtreecommitdiff
path: root/dev-cpp/ctemplate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-cpp/ctemplate
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-cpp/ctemplate')
-rw-r--r--dev-cpp/ctemplate/Manifest2
-rw-r--r--dev-cpp/ctemplate/ctemplate-2.4.ebuild76
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-cpp/ctemplate/Manifest b/dev-cpp/ctemplate/Manifest
index 61dbd80d5f29..7b30c55fe9cc 100644
--- a/dev-cpp/ctemplate/Manifest
+++ b/dev-cpp/ctemplate/Manifest
@@ -1,5 +1,7 @@
AUX 70ctemplate-gentoo.el 282 BLAKE2B 6004cc2b2e543f47c0c808bf494160c4b7e7e4768a954c1b0d99bc065a89145875dfc2b1e386bdf3a5e4dbb375a0bf5badc45b1666320f2a00fa8bd108f16c09 SHA512 36bc5424cb6dce40026f1d08b8764bf43d42159ff20e7d81484f5baf1c1e3c2042c12b1a60fc3cef48e297e816a12dbc41169988a6537ee41a2e2528b3c834a3
AUX ctemplate-2.3-fix-build-system.patch 1196 BLAKE2B db2efeaaae0a33b33bf81c6b968b809e31dfdf91ab5adb2a9851748c01a883e19a4b590002c20ca13e517c142264b8361fd6e5f3582a3650388bc4e0a5d6340d SHA512 4402af1034780d00f733231d9ce534cf54a4474a1153bc534274bc2f5163aba8b39e2ad7613151ffd34f3b7d4ba1d3a0c51badf8f1712aea6a1b65d963e3bea4
DIST ctemplate-2.3.tar.bz2 564389 BLAKE2B e0c95ac534eb0b7fdff3e87e08f3b1b8aa735bec8eef05bebcf87a51375cbc93e768a18ba005248edda023869b21679dbadaf3d6462e71666fa5d85b96172851 SHA512 546645389a8bfed59686b62b43cb7d53714ac98e1b75311c217bb0f3b6201d5d486766b1ce7e35bf15032372e45c36b27008f54085bd0c9ef0dd0b7e04b8e3f5
+DIST ctemplate-2.4.tar.gz 391923 BLAKE2B 96b585ed6ca323fc461857e1f2f381e0ca5c229d8c6039c24efcf34fb9ddf45cc36bef141af337e591e1cdd95ca510ea5ba1e539554322c578c25187b1906195 SHA512 4955489e7327bce18802d50fd9dfc8ac12af685e556d1c9d0eb2b7a2f4a9b6086e30be8388d694ec8912623738973d0c76e9ca97196c63c139ee5b468d4858b7
EBUILD ctemplate-2.3-r1.ebuild 1543 BLAKE2B dbcfc8010c9fc64b5c3dbf8c4a9ee53b4e629fed6b8cf31f5726be2d8a0ab4995635fa0fe5de6af4569438f11e1e699c73271227afd24244fd2e1587c12cfd8d SHA512 4403ad7458a0915e34aa429c6a7bfa8240d1ca885936a1e88d9594b3329b3821b96ef6499e3b958fe195c8c256e1bd25f766f5f6d56115d57c7aa9b78b6b1d23
+EBUILD ctemplate-2.4.ebuild 1525 BLAKE2B a7b3746a2feddf9273e033a2ba5bd08392f55e80f4a1551545f930505bcd06bcac0dc7487b7bcde424e51772dfc52d2120425fa1e33c5f020542b8e3e3b10bb3 SHA512 9c7e8123aad8e4e8e38de3e037c0e2e0c490a729b567023c0db9f08119fa835cb71aa3a1b43ad21916ea252c45e0083b2f6d3e379dcc2de93936307297f1784d
MISC metadata.xml 313 BLAKE2B 881d0e8b5849fc9ab98017806d6989ae27d27268bcfa6178db02eb2ef64e88509fd3230faa99440a866d9941832c1a7bf0dfc31f97244be2e04b3438db9bff8e SHA512 2d6beb50366ed619ca45b0552392b711e286f5d657946c7edc0c40aad5be2d1cc345ad1821649ac7d539f21880cb50c6d127a2584f19b82fad2d6cdc74644655
diff --git a/dev-cpp/ctemplate/ctemplate-2.4.ebuild b/dev-cpp/ctemplate/ctemplate-2.4.ebuild
new file mode 100644
index 000000000000..7d1ec59b62d8
--- /dev/null
+++ b/dev-cpp/ctemplate/ctemplate-2.4.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit autotools elisp-common python-any-r1
+
+DESCRIPTION="A simple but powerful template language for C++"
+HOMEPAGE="https://github.com/olafvdspek/ctemplate"
+SRC_URI="https://github.com/OlafvdSpek/ctemplate/archive/${P}.tar.gz"
+S="${WORKDIR}/ctemplate-${P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc emacs vim-syntax static-libs test"
+
+DEPEND="test? ( ${PYTHON_DEPS} )"
+RDEPEND="
+ emacs? ( >=app-editors/emacs-23.1:* )
+ vim-syntax? ( >=app-editors/vim-core-7 )"
+
+SITEFILE="70ctemplate-gentoo.el"
+
+# Some tests are broken in 2.3
+RESTRICT="test"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+
+ if use emacs; then
+ elisp-compile contrib/tpl-mode.el
+ fi
+}
+
+src_install() {
+ default
+ if ! use doc; then
+ rm -r "${ED}"/usr/share/doc/${PF}/html || die
+ fi
+
+ if use vim-syntax; then
+ cd "${S}/contrib" || die
+ sh highlighting.vim || die "unpacking vim scripts failed"
+ insinto /usr/share/vim/vimfiles
+ doins -r .vim/.
+ fi
+
+ if use emacs; then
+ cd "${S}/contrib" || die
+ elisp-install ${PN} tpl-mode.el tpl-mode.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ # package provides .pc files
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}