summaryrefslogtreecommitdiff
path: root/dev-cpp/elfio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-28 07:37:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-28 07:37:55 +0000
commitd46d1d3a5897cade51811b3848c7bf27969da625 (patch)
tree0dabb04db53e3fe66abe43df0a3cdff5d3b664db /dev-cpp/elfio
parente67d5b4ba05349b3bf4229d0cf7d069809c4420e (diff)
gentoo auto-resync : 28:12:2023 - 07:37:55
Diffstat (limited to 'dev-cpp/elfio')
-rw-r--r--dev-cpp/elfio/Manifest3
-rw-r--r--dev-cpp/elfio/elfio-3.11.ebuild32
-rw-r--r--dev-cpp/elfio/files/elfio-3.11-system-gtest.patch33
3 files changed, 0 insertions, 68 deletions
diff --git a/dev-cpp/elfio/Manifest b/dev-cpp/elfio/Manifest
index bc814eda4ea2..c2bfc9ae9df4 100644
--- a/dev-cpp/elfio/Manifest
+++ b/dev-cpp/elfio/Manifest
@@ -1,7 +1,4 @@
-AUX elfio-3.11-system-gtest.patch 1024 BLAKE2B 96aa3b8c38cf5159c69e4ff74388faf27f2192466e609ae6ccd04209abf7811387b5648922daf9660bc948bfde5c8681b605ac187e7b9757b742729a91e3def5 SHA512 9d75db5c673c375e64a9335e03b0fd3e2f301050388419d4032e6985ac2af8db46dcd9e7e61490e48c3fe90b2a09035a88305027577f9f0f8b1bd99cd9977e22
AUX elfio-3.12-gnuinstalldirs-docdir.patch 469 BLAKE2B a265a5c2ee8c604ff606276e224487c5a5bb3ac694d185755f6a7bd5444352a2b04918e8d308836b6ec339062db9c24c74e00cf80ad7bf9852410dc6b01360bf SHA512 a08328d732b811618fb701c6b27406e0a2495efca6f0fbfd9bbaf9e69152edbdc17e7dfb55096590c96c60bba0acf2d73d11b7e953aedca7189f074cd248f221
-DIST elfio-3.11.tar.gz 4150700 BLAKE2B 2e0270384f1fdbc8f8374c1a42b5bd0c6ba6faa8c8a7125063b682cd9808fbb3f330e2a0fa4646c8828f6d276ad8f92e36b69ab7916c3bd2b1b2ecad6708fcc1 SHA512 3a254aad62e707f2809e2997998aab6a9794d70791dc535a6de90bad3e9de3cbcc4f8e7787067ca7cd47ce2dc71cf52809747267bc36cfb08369b49a6b92cf5e
DIST elfio-3.12.tar.gz 4150640 BLAKE2B aba7c4a9c254384b3babcf740883e45b8b531ecde3bc12f3cb811ac63c1469d0d53d9bb259120d92bacad7289d811429785a784667d4632c3acc49f2c3a475e4 SHA512 f5c8bc6cc98da845f6c011fc85b98476935c5d20d72b36bff5ad2472434494115ee7c06cfa37152c528e5931c39fe3cc084bfc8e6952b2c3e8f24b8601ae212f
-EBUILD elfio-3.11.ebuild 666 BLAKE2B d0869322ea72892a19556fdee149bd0fe22624242e51d3447b6771da1b34e295a81ba0e337bc8ee63b5a5254330829de928d54b1a8347f2a322bfc4ed20dfee9 SHA512 c492ef4e16e45b506cb7e0295c6fb74c49aebcea6a3714784986279d9e9c18debb3a6162967c024e5b636cc8a9400e609e1f2f13440902857d4037ed1594482c
EBUILD elfio-3.12.ebuild 765 BLAKE2B ba3f197f5f66344b6b293170f3094ec44815661049e5e19851aeac5b52fa56bc3b22dc6c01528a51e90fbe7dc49f327c6141d900a6b6a638c37c033028fd3456 SHA512 b0d95d1df1e25bed34bc43a1f1794915854b88db640c5547446b48b49dd7de338a15a861d06be7cc20107cae1db2034a0dc200896ec0fe51917455fb014acb93
MISC metadata.xml 317 BLAKE2B 4b62079a213f05ca0fce72e62582010a9c82e11e714347c6753a1919bb8586896cef8afa5c378ffb00a5427aea6219fe7d78cc3572e214c3b2e8b09507ca685d SHA512 d550d765b42e68da41164297145ed8534b6bfb8f7976e6df57f76fb0fc8558262f010d988b66ea368d45e7c4bbbc879f6b91abba21c3f14871605e39589e5047
diff --git a/dev-cpp/elfio/elfio-3.11.ebuild b/dev-cpp/elfio/elfio-3.11.ebuild
deleted file mode 100644
index 0c82a247cdd9..000000000000
--- a/dev-cpp/elfio/elfio-3.11.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="ELF reader/producer header-only C++ library"
-HOMEPAGE="https://github.com/serge1/ELFIO"
-SRC_URI="https://github.com/serge1/${PN}/archive/Release_${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}"/${PN^^}-Release_${PV}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( dev-cpp/gtest )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.11-system-gtest.patch
-)
-
-src_configure() {
- local mycmakeargs=(
- -DFETCHCONTENT_FULLY_DISCONNECTED=ON
- -DELFIO_BUILD_TESTS=$(usex test)
- )
-
- cmake_src_configure
-}
diff --git a/dev-cpp/elfio/files/elfio-3.11-system-gtest.patch b/dev-cpp/elfio/files/elfio-3.11-system-gtest.patch
deleted file mode 100644
index 2110086c69d6..000000000000
--- a/dev-cpp/elfio/files/elfio-3.11-system-gtest.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-https://github.com/serge1/ELFIO/pull/113
-
-From 4c47fd4c783f286a73605e43e362f1e14b0296a9 Mon Sep 17 00:00:00 2001
-From: Sam James <sam@gentoo.org>
-Date: Sat, 19 Nov 2022 02:56:22 +0000
-Subject: [PATCH] tests: allow using system gtest copy
-
-Distributions often do builds with no network access available
-for both security reasons and also to ensure reproducibility.
-
-This change tells CMake to query the system for a copy of gtest,
-but if it's not available, it'll fall back to downloading via
-FetchContent.
---- a/tests/CMakeLists.txt
-+++ b/tests/CMakeLists.txt
-@@ -3,6 +3,7 @@ include(FetchContent)
- FetchContent_Declare(
- googletest
- URL https://github.com/google/googletest/archive/9a32aee22d771387c494be2d8519fbdf46a713b2.zip
-+ FIND_PACKAGE_ARGS NAMES GTest
- )
-
- # For Windows: Prevent overriding the parent project's compiler/linker settings
-@@ -44,7 +45,8 @@ target_link_libraries(
- ELFIOTest
- PRIVATE
- elfio::elfio
-- gtest_main)
-+ gtest_main
-+ GTest::gtest_main)
-
- add_test(
- NAME