summaryrefslogtreecommitdiff
path: root/dev-cpp/folly
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-24 03:02:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-24 03:02:55 +0000
commit530a5a826feeb71085fb8a01927f4d775a0b131b (patch)
treeb7669c45ea3f2a3a37b2437817a370226bb1c819 /dev-cpp/folly
parent71dd9d29cdaf7cc0ecdb9ea37d128726a941c630 (diff)
gentoo auto-resync : 24:11:2024 - 03:02:54
Diffstat (limited to 'dev-cpp/folly')
-rw-r--r--dev-cpp/folly/Manifest2
-rw-r--r--dev-cpp/folly/folly-2024.11.04.00-r1.ebuild (renamed from dev-cpp/folly/folly-2024.11.04.00.ebuild)17
2 files changed, 16 insertions, 3 deletions
diff --git a/dev-cpp/folly/Manifest b/dev-cpp/folly/Manifest
index 4256babc2df7..ab4891bcefba 100644
--- a/dev-cpp/folly/Manifest
+++ b/dev-cpp/folly/Manifest
@@ -4,5 +4,5 @@ AUX folly-2024.11.04.00-musl-fix.patch 1033 BLAKE2B 362f7047998f5867e55ade0c8992
DIST folly-v2023.06.19.00.tar.gz 3850872 BLAKE2B 6332b6de28fd4a0c19b20c4b23fa7093bded940fb07de92ad9fa7f44b8347fb5e5543e5a57c32d2414f345b4f7b306eed806c5d48a871a06833c1d2a71a34584 SHA512 9189adddf59019787969c7edb27a3e57436c2dca772f3142cdbf66e3a69b398be7ae4f2c36a9576c7ad9c51fd3703555e2a7ad6ed1ddce4036f8760d8095d371
DIST folly-v2024.11.04.00.tar.gz 4185762 BLAKE2B 16eca3bde4320b2c5dd535afddb2640f567135ea90e7a270814bda56eb0d2ba4e864e07015879bb79d1146c68e05695eb06e2219e3dd3b4f71a1434e6f2998a5 SHA512 918ec7217a58789818c502c47302d9296867456bb3dd1c36480406905875eae9a7d52900def34ac1a936af9be6010b8b77897b351c36aa8ca09c16fe1775f508
EBUILD folly-2023.06.19.00-r1.ebuild 2191 BLAKE2B eecb4073cff810ec80a55044b926b6af5524c2c4af8c7b4a9c6bc0825554418e7f2837527b10e5c5e23dbb85491143c3c333fe4f528d4b289838201d28b0ad03 SHA512 86fcebbb06a2e79f38da22654c58a5767271fa8e7bf430f4b3257b20c5ddeb372a7e4287a5e8ceac70c180c5f5c4476c68697f36f14fdcf175bdc87ee348b433
-EBUILD folly-2024.11.04.00.ebuild 1929 BLAKE2B ea1ac5dbe17f25b99b2c73fb5b56f40403269bfb7232b8308c3d70bef1ba2fe090e82c87bd864d4efdfebdf98a490b147a57841e5997b42ae239902beceb981c SHA512 b67e4e5b8e05f8b8f9cf6808b895b4a1612c6db77f93365623079601918d36f4c9ee64905ba6cb1311b5f6d9f759cc42ed48dd25e7bd6822847222b670aeddc1
+EBUILD folly-2024.11.04.00-r1.ebuild 2363 BLAKE2B ad6f310d298fe0e2b6b4353f0b4cec26875bf17b76fa5c482de326bbeca1d764278750c89888eb2b8bd4f29f8f4ee3aa16b40ded31b68603835c789075b91dd2 SHA512 ddd7f673b9106b5f2c10c8291070d382eac575264b9e0707832047df5d0ce7072678ecc82fd8dae967679914d48a433e4471fc913a7487e8f7f5b7cfe3bf28b5
MISC metadata.xml 472 BLAKE2B c82d4f4d0a0cd409f77ab20853793e45c8c7adb97ad6bdddabf5eb69eb5a523909109da1f2b311694fc5bf5fbcf4dd330957859894eae46b1b24308a04f5b7b2 SHA512 22b8c645a91f91769cadecc7b905c0b365c252e49a63fe690fbd5db82a58afe27517561f01ca5b3f37543b69b5d60af472d86f74105a6baaeb236f1b32db29de
diff --git a/dev-cpp/folly/folly-2024.11.04.00.ebuild b/dev-cpp/folly/folly-2024.11.04.00-r1.ebuild
index 27be95cd3414..fd2b8493af92 100644
--- a/dev-cpp/folly/folly-2024.11.04.00.ebuild
+++ b/dev-cpp/folly/folly-2024.11.04.00-r1.ebuild
@@ -13,7 +13,7 @@ EAPI=8
# dev-cpp/wangle
# dev-util/watchman
-inherit cmake
+inherit flag-o-matic cmake
DESCRIPTION="An open-source C++ library developed and used at Facebook"
HOMEPAGE="https://github.com/facebook/folly"
@@ -21,7 +21,7 @@ SRC_URI="https://github.com/facebook/folly/releases/download/v${PV}/${PN}-v${PV}
LICENSE="Apache-2.0"
SLOT="0/${PV}"
-KEYWORDS="~amd64 ~ppc64"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
IUSE="llvm-libunwind test"
RESTRICT="!test? ( test )"
@@ -75,6 +75,9 @@ src_configure() {
-DCMAKE_LIBRARY_ARCHITECTURE=$(usex amd64 x86_64 ${ARCH})
)
+ # https://github.com/facebook/folly/issues/1984
+ use arm64 && append-cxxflags "-flax-vector-conversions"
+
cmake_src_configure
}
@@ -87,5 +90,15 @@ src_test() {
'concurrency_concurrent_hash_map_test.*'
)
+ if use arm64; then
+ CMAKE_SKIP_TESTS+=(
+ # Tests are flaky/timing dependent on both QEMU chroot and real hardware
+ io_async_hh_wheel_timer_test.HHWheelTimerTest
+ # Times out on real hardware
+ concurrent_skip_list_test.ConcurrentSkipList
+ futures_retrying_test.RetryingTest.largeRetries
+ )
+ fi
+
cmake_src_test
}