summaryrefslogtreecommitdiff
path: root/dev-cpp/htmlcxx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-cpp/htmlcxx
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-cpp/htmlcxx')
-rw-r--r--dev-cpp/htmlcxx/Manifest5
-rw-r--r--dev-cpp/htmlcxx/files/0001-strstream-is-deprecated-use-sstream-instead.patch56
-rw-r--r--dev-cpp/htmlcxx/files/0002-Update-css_syntax.y-for-use-with-less-ancient-Bison.patch67
-rw-r--r--dev-cpp/htmlcxx/htmlcxx-0.86.ebuild35
-rw-r--r--dev-cpp/htmlcxx/metadata.xml11
5 files changed, 174 insertions, 0 deletions
diff --git a/dev-cpp/htmlcxx/Manifest b/dev-cpp/htmlcxx/Manifest
new file mode 100644
index 000000000000..b4c87079135c
--- /dev/null
+++ b/dev-cpp/htmlcxx/Manifest
@@ -0,0 +1,5 @@
+AUX 0001-strstream-is-deprecated-use-sstream-instead.patch 1442 BLAKE2B 93f0f2ec5606650bc0aac209ee80e988bb0fbbb158d9f367b39ef5f87bba9bf7dbe71fde2977d39529bae5cbe4a7da012511bdd89f105311f39459db82f2d093 SHA512 75cbb49425edc4c77c9bafd0f0fcc1d0bb8364db542229bc9a838003dd4d16e785346760e433c3cebc6aff44018d104f72c66b40257b7f82690f5c1dea8eb542
+AUX 0002-Update-css_syntax.y-for-use-with-less-ancient-Bison.patch 1265 BLAKE2B aacadc58a374a644eb2207d26e67e948e1cb4a3cbf9cf51474ab4a1c4740cf2bba18417b5d584ac096906d4271e34a5454f741527b28e1dd258fb99b5a1e2bea SHA512 c311c1d4e6cc463ec31fc13b77f1d38f68c81edda072c2486db1bdae3f19aa74db64a03056d941960c08dd193a4910930844ec6781c7c44d3ab4559eb40d4ce5
+DIST htmlcxx-0.86.tar.gz 469416 BLAKE2B 6edd4b7755db6d8911bc4ee6b1b61792b08d6a381971162a77cd3a6c7cb6cdb06e5a4a77b0a815589edab26aec04490a6b6c9edd80199f01304a506c707688b6 SHA512 dcff9c9946e1c3429af2230997c965b89a28a8ee219d8d594800106ff578bb21154e4680c38a09fb5f96cd4051c89cbf16f2151d30be93d4e3d291ff421aafcb
+EBUILD htmlcxx-0.86.ebuild 779 BLAKE2B 3079d926bebee3bccb81d11be3433ee2e2e0c83ccc2ee89675f1b7922967b3dc6f45cb4b01ac3ef14cca15c4f9af83c48bb56b8afd239ca4d623caace4a088c9 SHA512 05e1f4d67c94a604e1f933aa381d3b94aeb122cfcdbac4635682a06ff70f50db31d9cac393bb9fa334920f6a7f3cfdffbe068e02b50a89425767df6701682093
+MISC metadata.xml 324 BLAKE2B 41ae2c30cadd90db72f85f0b1a8829cccb8aa250bbd57dc10414f856dc3eadee95e94c6261901da3d7555ea30960d06b4110fd3b426e3faa72df809abded6ec3 SHA512 09d19b383ae7c72a26e069063cb28bd4b96d61e4c27505234131ef635dd2643bba26fbde2d972029969fd209eb9b0370c2a95b582b1f1516dbef31c5e7d9ac43
diff --git a/dev-cpp/htmlcxx/files/0001-strstream-is-deprecated-use-sstream-instead.patch b/dev-cpp/htmlcxx/files/0001-strstream-is-deprecated-use-sstream-instead.patch
new file mode 100644
index 000000000000..822c1c8e41a2
--- /dev/null
+++ b/dev-cpp/htmlcxx/files/0001-strstream-is-deprecated-use-sstream-instead.patch
@@ -0,0 +1,56 @@
+From 04fbe8cb7d933699f2a8ac06d89b205d933070c1 Mon Sep 17 00:00:00 2001
+From: James Le Cuirot <chewi@gentoo.org>
+Date: Wed, 14 Sep 2016 22:56:14 +0100
+Subject: [PATCH 1/3] strstream is deprecated, use sstream instead
+
+---
+ html/Uri.cc | 2 +-
+ html/utils.cc | 5 ++---
+ 2 files changed, 3 insertions(+), 4 deletions(-)
+
+diff --git a/html/Uri.cc b/html/Uri.cc
+index 4ddb3dd..034d29a 100644
+--- a/html/Uri.cc
++++ b/html/Uri.cc
+@@ -1,7 +1,7 @@
+ #include "Uri.h"
+
+ #include "wincstring.h"
+-#include <strstream>
++#include <sstream>
+ #include <cstdlib>
+ #include <cassert>
+ #include "tld.h"
+diff --git a/html/utils.cc b/html/utils.cc
+index 37ee889..e56cbaf 100644
+--- a/html/utils.cc
++++ b/html/utils.cc
+@@ -1,7 +1,7 @@
+ #include <algorithm>
+ #include <cctype>
+ #include <cstring>
+-#include <strstream>
++#include <sstream>
+ #include "Uri.h"
+
+ #include "utils.h"
+@@ -509,7 +509,7 @@ namespace htmlcxx {
+ string __serialize_gml(const tree<HTML::Node> &tr, tree<HTML::Node>::iterator it, tree<HTML::Node>::iterator end, unsigned int parent_id, unsigned int& label) {
+
+ using namespace std;
+- ostrstream ret;
++ ostringstream ret;
+ tree<HTML::Node>::sibling_iterator sib = tr.begin(it);
+ while(sib != tr.end(it)) {
+ ret << "node [ id " << ++label << "\n label \"" << label << "\"\n]\n";
+@@ -519,7 +519,6 @@ namespace htmlcxx {
+ }
+ ret << ends;
+ string str = ret.str();
+- ret.freeze(0);
+ return str;
+ }
+
+--
+2.8.2
+
diff --git a/dev-cpp/htmlcxx/files/0002-Update-css_syntax.y-for-use-with-less-ancient-Bison.patch b/dev-cpp/htmlcxx/files/0002-Update-css_syntax.y-for-use-with-less-ancient-Bison.patch
new file mode 100644
index 000000000000..c387deeca7f1
--- /dev/null
+++ b/dev-cpp/htmlcxx/files/0002-Update-css_syntax.y-for-use-with-less-ancient-Bison.patch
@@ -0,0 +1,67 @@
+From 807081583ea58b07a5ff2e0659f4173492befb8a Mon Sep 17 00:00:00 2001
+From: James Le Cuirot <chewi@gentoo.org>
+Date: Wed, 14 Sep 2016 22:56:35 +0100
+Subject: [PATCH 2/3] Update css_syntax.y for use with less ancient Bison
+
+New pregenerated css_syntax.c to follow.
+---
+ css/css_syntax.y | 24 +++++++++++++++---------
+ 1 file changed, 15 insertions(+), 9 deletions(-)
+
+diff --git a/css/css_syntax.y b/css/css_syntax.y
+index e75720d..0d9b177 100644
+--- a/css/css_syntax.y
++++ b/css/css_syntax.y
+@@ -4,13 +4,13 @@
+ #include "css_lex.h"
+ #include "parser.h"
+
+-#define YYPARSE_PARAM yyparam
+ #define YYERROR_VERBOSE 1
+ //#define YYDEBUG 1
+
+ %}
+
+-%pure_parser
++%parse-param {void *yyparam}
++%pure-parser
+
+ %union {
+ char *lexeme;
+@@ -22,6 +22,19 @@
+ int pseudo_element;
+ }
+
++%{
++
++int yylex(YYSTYPE *lvalp);
++
++int yyerror(void *yyparam, const char *s) {
++#if YYDEBUG
++ fprintf(stderr, "Error: %s\n", s);
++#endif
++ return 0;
++}
++
++%}
++
+ %token IMPORT_SYM
+ %token IMPORTANT_SYM
+ %token IDENT
+@@ -571,13 +584,6 @@ hexcolor
+
+ %%
+
+-int yyerror(char *s) {
+-#if YYDEBUG
+- fprintf(stderr, "Error: %s\n", s);
+-#endif
+- return 0;
+-}
+-
+ struct selector_list_t* css_parse(const char *buffer, int buf_len) {
+ struct selector_list_t *ret = NULL;
+ //yydebug = 1;
+--
+2.8.2
+
diff --git a/dev-cpp/htmlcxx/htmlcxx-0.86.ebuild b/dev-cpp/htmlcxx/htmlcxx-0.86.ebuild
new file mode 100644
index 000000000000..88d48de33736
--- /dev/null
+++ b/dev-cpp/htmlcxx/htmlcxx-0.86.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="A simple non-validating CSS 1 and HTML parser for C++"
+HOMEPAGE="http://htmlcxx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND="sys-devel/flex[${MULTILIB_USEDEP}]
+ virtual/yacc"
+
+PATCHES=(
+ "${FILESDIR}"/0001-strstream-is-deprecated-use-sstream-instead.patch
+ "${FILESDIR}"/0002-Update-css_syntax.y-for-use-with-less-ancient-Bison.patch
+)
+
+ECONF_SOURCE="${S}"
+
+multilib_src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+ einstalldocs
+}
diff --git a/dev-cpp/htmlcxx/metadata.xml b/dev-cpp/htmlcxx/metadata.xml
new file mode 100644
index 000000000000..ea4a05ffcd3e
--- /dev/null
+++ b/dev-cpp/htmlcxx/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">htmlcxx</remote-id>
+ </upstream>
+</pkgmetadata>