summaryrefslogtreecommitdiff
path: root/dev-cpp/htmlcxx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-cpp/htmlcxx
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-cpp/htmlcxx')
-rw-r--r--dev-cpp/htmlcxx/Manifest3
-rw-r--r--dev-cpp/htmlcxx/files/htmlcxx-0.87-c++17.patch26
-rw-r--r--dev-cpp/htmlcxx/htmlcxx-0.87.ebuild6
3 files changed, 33 insertions, 2 deletions
diff --git a/dev-cpp/htmlcxx/Manifest b/dev-cpp/htmlcxx/Manifest
index 01cab033e390..0973eb389d7d 100644
--- a/dev-cpp/htmlcxx/Manifest
+++ b/dev-cpp/htmlcxx/Manifest
@@ -1,3 +1,4 @@
+AUX htmlcxx-0.87-c++17.patch 1096 BLAKE2B a89fe85362fce52fe7bf97c6b453e15bd4801ea45059aa9dcd722ecf91c8f34d8249d17c6de0ac60f87a2f806cf03f124bc98e3cebe4a4c1e97d9c2fe0fcd30f SHA512 220f0bc91ae5f8183d429ef6a50548efb83e64eeb6df7164582295508520c5bd24eaf4853f7f8f3e1b081f63dd0ff2e87f2d18661d9da46973127cce41749b7a
DIST htmlcxx-0.87.tar.gz 477083 BLAKE2B 94977e758b4f2643f39a464094e315c11b78bc957a3eb054e6a7608828345704a82c3ca36c5ac2855054e7570daebb80d8a63639f3a7197344d25f2d16830702 SHA512 391b94c7ea2d17a04d46ac80f8146e6c2b14b289379c40f3d432ed9c0f36222ced6384d725cdecfc352e28c30f11976249b6a3f7133bbee3161a7883d197fca7
-EBUILD htmlcxx-0.87.ebuild 613 BLAKE2B 536f4256c4c0bcf4311ac5c8ce220907aafdb4c04c776f7d8018875b7e6f2c21a59115445c3695db73fde207c8fa77f52b7d9075030a8ead30f4f8ceb6876f97 SHA512 1b8bba8b6d5c2837617ea90b9aefab2ec8bc4aea29f39d6b1b3a1ec440965e73b961316a8cde85a21e5ad6f1c8caf9b54511a4fd6d1f7d527942fe69356250bf
+EBUILD htmlcxx-0.87.ebuild 658 BLAKE2B a8d5f4eac406028c768eaee09d455ad40a7c7129751210cd55e4e608e8aa5bbc2d3795396d2f7d975b19b2d4ecea07ccec7427bfbadcdcf19ee38912d3edbbab SHA512 8f7f5a562e741ab464d1fccfd03b20d2359057d3f4f0c73a33deb8910b5bcd17fab6a4c9b439bd572c6428c0a046580dcddf688e093c716bafd8b201144e30d5
MISC metadata.xml 324 BLAKE2B 41ae2c30cadd90db72f85f0b1a8829cccb8aa250bbd57dc10414f856dc3eadee95e94c6261901da3d7555ea30960d06b4110fd3b426e3faa72df809abded6ec3 SHA512 09d19b383ae7c72a26e069063cb28bd4b96d61e4c27505234131ef635dd2643bba26fbde2d972029969fd209eb9b0370c2a95b582b1f1516dbef31c5e7d9ac43
diff --git a/dev-cpp/htmlcxx/files/htmlcxx-0.87-c++17.patch b/dev-cpp/htmlcxx/files/htmlcxx-0.87-c++17.patch
new file mode 100644
index 000000000000..9f8f060de456
--- /dev/null
+++ b/dev-cpp/htmlcxx/files/htmlcxx-0.87-c++17.patch
@@ -0,0 +1,26 @@
+https://sourceforge.net/p/htmlcxx/patches/8/
+
+diff --color -Naur a/html/CharsetConverter.cc b/html/CharsetConverter.cc
+--- a/html/CharsetConverter.cc 2018-12-29 03:13:56.000000000 +0000
++++ b/html/CharsetConverter.cc 2021-05-31 23:03:10.705334580 +0100
+@@ -7,7 +7,7 @@
+ using namespace std;
+ using namespace htmlcxx;
+
+-CharsetConverter::CharsetConverter(const string &from, const string &to) throw (Exception)
++CharsetConverter::CharsetConverter(const string &from, const string &to)
+ {
+ mIconvDescriptor = iconv_open(to.c_str(), from.c_str());
+ if (mIconvDescriptor == (iconv_t)(-1))
+diff --color -Naur a/html/CharsetConverter.h b/html/CharsetConverter.h
+--- a/html/CharsetConverter.h 2018-12-29 03:13:56.000000000 +0000
++++ b/html/CharsetConverter.h 2021-05-31 23:03:19.042574598 +0100
+@@ -17,7 +17,7 @@
+ : std::runtime_error(arg) {}
+ };
+
+- CharsetConverter(const std::string &from, const std::string &to) throw (Exception);
++ CharsetConverter(const std::string &from, const std::string &to);
+ ~CharsetConverter();
+
+ std::string convert(const std::string &input);
diff --git a/dev-cpp/htmlcxx/htmlcxx-0.87.ebuild b/dev-cpp/htmlcxx/htmlcxx-0.87.ebuild
index fdcb01bc5cf2..3ac9069308c3 100644
--- a/dev-cpp/htmlcxx/htmlcxx-0.87.ebuild
+++ b/dev-cpp/htmlcxx/htmlcxx-0.87.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,6 +13,10 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="static-libs"
+PATCHES=(
+ "${FILESDIR}"/${P}-c++17.patch
+)
+
ECONF_SOURCE="${S}"
multilib_src_configure() {