summaryrefslogtreecommitdiff
path: root/dev-cpp/lucene++
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-cpp/lucene++
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-cpp/lucene++')
-rw-r--r--dev-cpp/lucene++/Manifest6
-rw-r--r--dev-cpp/lucene++/files/lucene++-3.0.7-boost-1.58.patch37
-rw-r--r--dev-cpp/lucene++/lucene++-3.0.7.ebuild36
-rw-r--r--dev-cpp/lucene++/metadata.xml11
4 files changed, 90 insertions, 0 deletions
diff --git a/dev-cpp/lucene++/Manifest b/dev-cpp/lucene++/Manifest
new file mode 100644
index 000000000000..a13c87cb96e3
--- /dev/null
+++ b/dev-cpp/lucene++/Manifest
@@ -0,0 +1,6 @@
+AUX lucene++-3.0.7-boost-1.58.patch 1149 SHA256 a77482fbd8eff1ece88132e8632e3a942495c602e9c6710db7b7151b2af4ddd2 SHA512 7fd0089895ab77da158a49510241fdc894bd3d30f7a6691ddc230f4d52631ec9222a04e13ef0a118f7838b4320fd313502f635c8f0827ba5bb4c6169fdd404b9 WHIRLPOOL 4c68548aa21ad9d1734b032a5aaf2f051a4e58b00d009265216047a27ec6839510db30b5cb7b249fca28db89e97e86e7f9aa199b3102e7e56aede5cb32aeec63
+DIST lucene++-3.0.7.tar.gz 2013570 SHA256 6c19f203311e4b44a0ccf7b1127db77436eb47159ea1c54f7531a0b1ca585e0c SHA512 92f3bba320980673cc64c983616aa38d25b44ea811237ed226741b892757fb8151e4f833aa58a18dbe7a0c9a899d94e828aa15e6d7b48a69ab730d1d772db220 WHIRLPOOL e5d18d6d0ac90f8b0ace161dc0457b2ca3546c211e96ac3c44dea4ba7d9bbd6bd9183016ceb2bccd8516261db0ca2dd4331701bb37e653e96df9453d6acbc878
+EBUILD lucene++-3.0.7.ebuild 806 SHA256 3dd6316707cf306a0b44ed88f81736dc560a2cf4cb802c81e799eb963257afa0 SHA512 82f80fdba3585f8fd165a814785c7ff2840749f8fee60ac7ade795e5f9540c626cc60847421213a2a1965826c39b42e310efa791e1010a06a3ff726abf0bfd5c WHIRLPOOL a3db6ae09422f6cbbc510ace89019492f98dcc6175ea349c0563c3d18a0b917c6e645b5dfad20ae40c20d12f9cebdd2487365dad34c4ec6bfe163f485d6222dd
+MISC ChangeLog 3298 SHA256 65a60d1b98060ee8fc99374ccfa74fd82e008a99749231ebea908adf8f3cedb8 SHA512 58ca5b31e10841b72b0ed6d03cf22427967d5a6e77a5f72629ae38b876be7f552be6aa8c9bbc2dd6f3cd429756f8599ee2cd334cfebb460a01b812ddcfb48c79 WHIRLPOOL f2fe1c56d071b3e2a5bb3fcf38dc25f1ac35690d28f763ada2536da39526ed8dbf9c6f964fae7930f00681929fa9bb66f92104fef66c80c5e8be1d30144a3042
+MISC ChangeLog-2015 845 SHA256 3642df10375289ae0ea2fc4bdeae0f7b99b633f515be4403b89a02e008d9b88c SHA512 c004acc5f9d09055a00c503dd4143c8a13dc0a7967bbf8b4ee6629d571f1f3c65b10c8c921ae44bc1b1e1c3e33b6e0f5954873e816d78dfd5a568f1098765d5d WHIRLPOOL af34a56b93bd18d55919e4a89524b92d72ef27bee6735f1583f0a0da5c055933854ebc0d6ef730be1ad374b11cc5a57f6145282c3e8124333e831cbaab5bda6b
+MISC metadata.xml 342 SHA256 0df58882b48332115e2deab0894306541a45f25a10cd21faa35ce09fcb0f80a7 SHA512 b9c2db6cd4e7f6731aa9c5a220d5b71759f7adb9f8179a334a320596a9570262ed4251b5edc004958b6f45e129bba3fd004672462ce97ac091b8e702b1535e6b WHIRLPOOL 1046d286a49240c648fdc32b56436fdad3db7ff5a430bbfdbe3c754a2ddc95050845852da8e208c1d29448d5343bb012388c7a8ba9d5468edc0b93cbdbf8ffac
diff --git a/dev-cpp/lucene++/files/lucene++-3.0.7-boost-1.58.patch b/dev-cpp/lucene++/files/lucene++-3.0.7-boost-1.58.patch
new file mode 100644
index 000000000000..9ff33fd03005
--- /dev/null
+++ b/dev-cpp/lucene++/files/lucene++-3.0.7-boost-1.58.patch
@@ -0,0 +1,37 @@
+commit 1987082cf9278a639d772b4f35a8ae2d34944177
+Author: Václav Slavík <vaclav@slavik.io>
+Date: Mon May 4 18:04:46 2015 +0200
+
+ Fix compilation with Boost 1.58
+
+ 1.58 introduces strict type checking in boost::get() and while that's
+ good in theory, the VariantUtils code makes it impractical to use.
+ Instead, use relaxed_get() to get the old behavior. relaxed_get() didn't
+ exist in older versions of Boost, so the code must check BOOST_VERSION.
+
+ Fixes #93.
+
+diff --git a/include/VariantUtils.h b/include/VariantUtils.h
+index 1e6c243..5a72e59 100644
+--- a/include/VariantUtils.h
++++ b/include/VariantUtils.h
+@@ -8,6 +8,7 @@
+ #define VARIANTUTILS_H
+
+ #include <boost/any.hpp>
++#include <boost/version.hpp>
+ #include "Lucene.h"
+ #include "MiscUtils.h"
+
+@@ -22,7 +23,11 @@ public:
+
+ template <typename TYPE, typename VAR>
+ static TYPE get(VAR var) {
++#if BOOST_VERSION < 105800
+ return var.type() == typeid(TYPE) ? boost::get<TYPE>(var) : TYPE();
++#else
++ return var.type() == typeid(TYPE) ? boost::relaxed_get<TYPE>(var) : TYPE();
++#endif
+ }
+
+ template <typename TYPE, typename VAR>
diff --git a/dev-cpp/lucene++/lucene++-3.0.7.ebuild b/dev-cpp/lucene++/lucene++-3.0.7.ebuild
new file mode 100644
index 000000000000..ddb0f0570e20
--- /dev/null
+++ b/dev-cpp/lucene++/lucene++-3.0.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MY_P="LucenePlusPlus-rel_${PV}"
+inherit cmake-utils multilib
+
+DESCRIPTION="C++ port of Lucene library, a high-performance, full-featured text search engine"
+HOMEPAGE="https://github.com/luceneplusplus/LucenePlusPlus"
+SRC_URI="https://github.com/luceneplusplus/LucenePlusPlus/archive/rel_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( LGPL-3 Apache-2.0 )"
+SLOT="0"
+KEYWORDS="amd64 hppa ~ppc ppc64 x86"
+IUSE="debug"
+
+DEPEND="dev-libs/boost:="
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( AUTHORS README.rst )
+
+PATCHES=( "${FILESDIR}/${P}-boost-1.58.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DEMO=OFF
+ -DENABLE_TEST=OFF
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/dev-cpp/lucene++/metadata.xml b/dev-cpp/lucene++/metadata.xml
new file mode 100644
index 000000000000..7e7d73fe4283
--- /dev/null
+++ b/dev-cpp/lucene++/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>johu@gentoo.org</email>
+ <name>Johannes Huber</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">luceneplusplus/luceneplusplus</remote-id>
+ </upstream>
+</pkgmetadata>