summaryrefslogtreecommitdiff
path: root/dev-cpp/mm-common/mm-common-1.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-02 20:57:17 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-02 20:57:17 +0000
commit9bc9c4dcc38dc560cff8e5d083d1e5f282ddde98 (patch)
treeaebfd3698cdc5ed079dbfd553063a19b4662965d /dev-cpp/mm-common/mm-common-1.0.5.ebuild
parentcc2c9e975285d6fb1be1b71d18ba4cca7991b921 (diff)
gentoo auto-resync : 02:12:2022 - 20:57:16
Diffstat (limited to 'dev-cpp/mm-common/mm-common-1.0.5.ebuild')
-rw-r--r--dev-cpp/mm-common/mm-common-1.0.5.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-cpp/mm-common/mm-common-1.0.5.ebuild b/dev-cpp/mm-common/mm-common-1.0.5.ebuild
new file mode 100644
index 000000000000..6c75fe90f747
--- /dev/null
+++ b/dev-cpp/mm-common/mm-common-1.0.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit gnome.org python-any-r1 meson
+
+DESCRIPTION="Build infrastructure and utilities for GNOME C++ bindings"
+HOMEPAGE="https://www.gtkmm.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+BDEPEND="${PYTHON_DEPS}"
+
+src_prepare() {
+ default
+
+ # Include project version in docdir name
+ sed -i -e "s:^install_docdir.*:& + '-' + meson.project_version():" meson.build || die
+}