summaryrefslogtreecommitdiff
path: root/dev-cpp/ms-gsl/ms-gsl-4.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-cpp/ms-gsl/ms-gsl-4.0.0.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-cpp/ms-gsl/ms-gsl-4.0.0.ebuild')
-rw-r--r--dev-cpp/ms-gsl/ms-gsl-4.0.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-cpp/ms-gsl/ms-gsl-4.0.0.ebuild b/dev-cpp/ms-gsl/ms-gsl-4.0.0.ebuild
new file mode 100644
index 000000000000..5163b667edb2
--- /dev/null
+++ b/dev-cpp/ms-gsl/ms-gsl-4.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Guideline Support Library implementation by Microsoft"
+HOMEPAGE="https://github.com/Microsoft/GSL"
+SRC_URI="https://github.com/Microsoft/GSL/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/GSL-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# header only library
+RDEPEND=""
+DEPEND="test? ( >=dev-cpp/gtest-1.9.0_pre20190607 )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.0-disable_Werror-644042.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DGSL_TEST=$(usex test)
+ )
+ cmake_src_configure
+}