summaryrefslogtreecommitdiff
path: root/dev-cpp/mvfst
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-24 03:02:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-24 03:02:55 +0000
commit530a5a826feeb71085fb8a01927f4d775a0b131b (patch)
treeb7669c45ea3f2a3a37b2437817a370226bb1c819 /dev-cpp/mvfst
parent71dd9d29cdaf7cc0ecdb9ea37d128726a941c630 (diff)
gentoo auto-resync : 24:11:2024 - 03:02:54
Diffstat (limited to 'dev-cpp/mvfst')
-rw-r--r--dev-cpp/mvfst/Manifest2
-rw-r--r--dev-cpp/mvfst/mvfst-2024.11.04.00-r1.ebuild (renamed from dev-cpp/mvfst/mvfst-2024.11.04.00.ebuild)19
2 files changed, 17 insertions, 4 deletions
diff --git a/dev-cpp/mvfst/Manifest b/dev-cpp/mvfst/Manifest
index 40f39ebe3b68..d85275fe8b55 100644
--- a/dev-cpp/mvfst/Manifest
+++ b/dev-cpp/mvfst/Manifest
@@ -1,3 +1,3 @@
DIST mvfst-2024.11.04.00.gh.tar.gz 1983543 BLAKE2B 9c8b0da32baddd04af29e892a379333f89af45957a415dfa7f6da86f9a9b39fc8fbc73e450deb51e7a61b4ddfd37f08dc3d9ba8f48f83557aab4ae762068ec14 SHA512 4a000583884777fa876f3bfc52a3420c9cf8818f943c07898ac3b313837092fc173d8db497fd59027ef405d8fa5e3114a53b3bc5cf3fef398ca712c06a1da3e0
-EBUILD mvfst-2024.11.04.00.ebuild 969 BLAKE2B 2a5f0ae62f0c03d3ff0744e14f727fd6eba9a00feede67f5fd120baf0d96498bccbdbc9b838b82f6a7efd3af34ea34bd83c9e833848bdbcd6b84747630476211 SHA512 0714d9225b36a79690ab49e8595cff9e20ab7c9212c476aecf0795ba78aac58d01188a35dfe6d036ac2528203d62fc6441bf16687be0c0a8030c569fdea9d5a6
+EBUILD mvfst-2024.11.04.00-r1.ebuild 1266 BLAKE2B 7d0d38d9d7de7135f81b10594451403bf6d3a136c05a2455871a4a89f61e58bef385db99c31adaa17f3b42a325d0b5fe4c9e305175db0734d488acc6d5766898 SHA512 4d5e1ee612753d79fe4875c5dc3b27c932540c8a5a936851bbeb2037f7ae7f3edd90148a0479fe406f32f199e5da25acd2f351d68630bc413b585f7ec40dac1c
MISC metadata.xml 472 BLAKE2B 916daab0f3a2f9df3019f592d45d217f9af4c856087053cebec1ad892961654c96957ce953e15a6c32743f6909e8e19063766a2dfdff35a6f8402caff1119d5d SHA512 3da6ea7c55662d148b91146947789430cbb6ca88b9547de2a75b007e579d2ec513b1a03517c577ad43ebc7282962db5c04a1a27f2a0e39d15cac4d6018a53e15
diff --git a/dev-cpp/mvfst/mvfst-2024.11.04.00.ebuild b/dev-cpp/mvfst/mvfst-2024.11.04.00-r1.ebuild
index b920ce229a20..7059319511db 100644
--- a/dev-cpp/mvfst/mvfst-2024.11.04.00.ebuild
+++ b/dev-cpp/mvfst/mvfst-2024.11.04.00-r1.ebuild
@@ -21,7 +21,7 @@ SRC_URI="https://github.com/facebook/mvfst/archive/refs/tags/v${PV}.tar.gz -> ${
LICENSE="MIT"
SLOT="0/${PV}"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~arm64"
IUSE="test"
RESTRICT="!test? ( test )"
@@ -40,10 +40,23 @@ DEPEND="
src_configure() {
local mycmakeargs=(
- -DCMAKE_INSTALL_DIR="$(get_libdir)/cmake/${PN}"
- -DLIB_INSTALL_DIR="$(get_libdir)"
+ -DCMAKE_INSTALL_MODULE_DIR="$(get_libdir)/cmake/${PN}"
+ -DCMAKE_INSTALL_LIBDIR="$(get_libdir)"
-DBUILD_TESTS="$(usex test ON OFF)"
)
cmake_src_configure
}
+
+src_test() {
+ if use arm64; then
+ # These tests segfault on arm64.
+ # https://github.com/facebook/mvfst/issues/363
+ CMAKE_SKIP_TESTS=(
+ QuicClientTransportIntegrationTest.ResetClient
+ QuicClientTransportIntegrationTest.TestStatelessResetToken
+ )
+ fi
+
+ cmake_src_test
+}