summaryrefslogtreecommitdiff
path: root/dev-cpp/pngpp/pngpp-0.2.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-cpp/pngpp/pngpp-0.2.9.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-cpp/pngpp/pngpp-0.2.9.ebuild')
-rw-r--r--dev-cpp/pngpp/pngpp-0.2.9.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-cpp/pngpp/pngpp-0.2.9.ebuild b/dev-cpp/pngpp/pngpp-0.2.9.ebuild
new file mode 100644
index 000000000000..4e013690de88
--- /dev/null
+++ b/dev-cpp/pngpp/pngpp-0.2.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P=${P/pp/++}
+
+DESCRIPTION="A simple but powerful C++ interface to libpng"
+HOMEPAGE="http://www.nongnu.org/pngpp/"
+SRC_URI="mirror://nongnu/${PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="media-libs/libpng:0"
+DEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}"/${PN}-0.2.9-DESTDIR.patch )
+
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install-headers
+ einstalldocs
+
+ docinto examples
+ dodoc example/*.cpp
+ docompress -x /usr/share/doc/${PF}/examples
+}