summaryrefslogtreecommitdiff
path: root/dev-cpp/prometheus-cpp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-09 12:30:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-09 12:30:03 +0100
commitd8a7472fc6314625f7d16e0427004eb448412908 (patch)
tree0dba2e223a5a5e200a4b84a4a5e3ff690e5059e7 /dev-cpp/prometheus-cpp
parent8e49340ce0aaf205556648d8fa27dd30e8cf4435 (diff)
gentoo auto-resync : 09:09:2024 - 12:30:03
Diffstat (limited to 'dev-cpp/prometheus-cpp')
-rw-r--r--dev-cpp/prometheus-cpp/Manifest2
-rw-r--r--dev-cpp/prometheus-cpp/prometheus-cpp-1.1.0.ebuild41
2 files changed, 0 insertions, 43 deletions
diff --git a/dev-cpp/prometheus-cpp/Manifest b/dev-cpp/prometheus-cpp/Manifest
index 46c499ee65e3..fc28a481935f 100644
--- a/dev-cpp/prometheus-cpp/Manifest
+++ b/dev-cpp/prometheus-cpp/Manifest
@@ -1,5 +1,3 @@
-DIST prometheus-cpp-1.1.0.tar.gz 58489 BLAKE2B af24fbc34e79c04ec80dbf4430de5a2cf0e66b7de4c06f9b37e6bc3ab7f868b948db486a4f962c7986748eff1247eb0119ad5b581ac01129ce6bfa10f7b53ec7 SHA512 0715a0eb8a7f7065e01b8039c261eaa98a77a8d035783ccef9333fb06eecd75599959807ec157514c60ed435841bcd0cdd8cd295bcf7cd88e21e1099ba12be89
DIST prometheus-cpp-1.2.4.tar.gz 73953 BLAKE2B 75ca7b8c88408b54ab806dcc8ecaa48c9d29a7cbb76fe786fc76e114fa0bfcacaced7d899f8aff24060c9cbb4836d144b25fca2ac45438982789bcf881fade67 SHA512 8c15492054189b736e502258c30aaaae0fac3c9ea61907260e6e3cd29fe4077451f9e49fd580508aa6e21691209545d9cf87011be5b046fa097a53a133167553
-EBUILD prometheus-cpp-1.1.0.ebuild 827 BLAKE2B 8f3e24ea6980ca9cb40c0aa12d16e233090ac255c439ff1db0e747b17276a2c30a1e913bd9a2593b7fb1cf68d6d40eb01d6c25670cd4a5225d8f8998905949e9 SHA512 f9fcf730f91205c19194aed4979f63d03468f55e9f40b0522be4e1ab69fedbaea3276172d47980c34b7514c1884bfb1f494225355c87f6b54aa17abde2270636
EBUILD prometheus-cpp-1.2.4.ebuild 827 BLAKE2B 419cba5e372798b831b2d71c122a952f2b4f4eaec20197dd129047af1bc9cf3a1773b590b737054388d530e697131c5b34c7e03bdc71d514a364d020231aa2e0 SHA512 2959f2b55e76807005f69b82a79c4c1dd0e9348ef23ad823fce5a834c4fcdc9229edbc9776606d9b6d20c011a552f23fae0ec573a7dd478655f3e79f3df21ce1
MISC metadata.xml 748 BLAKE2B 775f8524975b71263a032d1d7511c3406adb930428ba5f955489e8a5a70a023a96fd83a4a4eb53a528c5ffb749133420dc0a5d06a1b389ed09288ad17ee8bfbf SHA512 02958fbce2234ae1a99d9fe2a5dcd8a096c4d49ca7a403d95029f99cd4c21cdcb0cbe79af376cb02cb645c557114f79ecd9d04707ed77aece039d05a66712fc5
diff --git a/dev-cpp/prometheus-cpp/prometheus-cpp-1.1.0.ebuild b/dev-cpp/prometheus-cpp/prometheus-cpp-1.1.0.ebuild
deleted file mode 100644
index 6239a46b04df..000000000000
--- a/dev-cpp/prometheus-cpp/prometheus-cpp-1.1.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Prometheus Client Library for Modern C++"
-HOMEPAGE="https://github.com/jupp0r/prometheus-cpp"
-SRC_URI="https://github.com/jupp0r/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv ~x86"
-IUSE="test zlib"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="net-misc/curl
- sys-libs/zlib
- www-servers/civetweb[cxx]"
-DEPEND="${RDEPEND}
- test? (
- dev-cpp/benchmark
- dev-cpp/gtest
- )"
-BDEPEND="virtual/pkgconfig"
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_PULL=yes
- -DENABLE_PUSH=yes
- -DENABLE_COMPRESSION=$(usex zlib)
- -DENABLE_TESTING=$(usex test)
- -DUSE_THIRDPARTY_LIBRARIES=OFF
- -DGENERATE_PKGCONFIG=ON
- -DRUN_IWYU=OFF
- )
-
- cmake_src_configure
-}