summaryrefslogtreecommitdiff
path: root/dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.5-r1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.5-r1.ebuild')
-rw-r--r--dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.5-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.5-r1.ebuild b/dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.5-r1.ebuild
new file mode 100644
index 000000000000..152d26b69823
--- /dev/null
+++ b/dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.5-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+SRC_URI="https://github.com/martinus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+DESCRIPTION="Fast & memory efficient hashtable based on robin hood hashing for C++11/14/17/20"
+HOMEPAGE="https://github.com/martinus/robin-hood-hashing"
+
+LICENSE="MIT"
+SLOT="0"
+
+src_configure() {
+ local mycmakeargs=(
+ -DRH_STANDALONE_PROJECT=OFF
+ -DCMAKE_INSTALL_LIBDIR="${EPREFIX}/usr/share/"
+ )
+ cmake_src_configure
+}