summaryrefslogtreecommitdiff
path: root/dev-cpp/scitokens-cpp/scitokens-cpp-1.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-08 15:45:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-08 15:45:39 +0100
commitd5599da3055bf9b900513a61c3c6e4bdbb524503 (patch)
treeb64a792286dd490c9d4fc2c46bbbaa64804efc61 /dev-cpp/scitokens-cpp/scitokens-cpp-1.0.1.ebuild
parentcfeee79886441e92c8ee094e45b9bcdc9c79137a (diff)
gentoo auto-resync : 08:06:2023 - 15:45:39
Diffstat (limited to 'dev-cpp/scitokens-cpp/scitokens-cpp-1.0.1.ebuild')
-rw-r--r--dev-cpp/scitokens-cpp/scitokens-cpp-1.0.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-cpp/scitokens-cpp/scitokens-cpp-1.0.1.ebuild b/dev-cpp/scitokens-cpp/scitokens-cpp-1.0.1.ebuild
new file mode 100644
index 000000000000..e6a43dfceee1
--- /dev/null
+++ b/dev-cpp/scitokens-cpp/scitokens-cpp-1.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A C++ implementation of the SciTokens library with a C library interface"
+HOMEPAGE="https://github.com/scitokens/scitokens-cpp"
+SRC_URI="https://github.com/scitokens/scitokens-cpp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RESTRICT="test" # testing requires network
+
+DEPEND="
+ dev-db/sqlite
+ dev-libs/openssl:0=
+ net-misc/curl:0=
+ kernel_linux? ( sys-apps/util-linux )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="test? ( dev-cpp/gtest )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DSCITOKENS_BUILD_UNITTESTS=$(usex test)
+ -DSCITOKENS_EXTERNAL_GTEST=1
+ )
+ cmake_src_configure
+}