summaryrefslogtreecommitdiff
path: root/dev-cpp/string-theory
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-cpp/string-theory
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-cpp/string-theory')
-rw-r--r--dev-cpp/string-theory/Manifest3
-rw-r--r--dev-cpp/string-theory/metadata.xml15
-rw-r--r--dev-cpp/string-theory/string-theory-3.3.ebuild38
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-cpp/string-theory/Manifest b/dev-cpp/string-theory/Manifest
new file mode 100644
index 000000000000..5c3aedfe8633
--- /dev/null
+++ b/dev-cpp/string-theory/Manifest
@@ -0,0 +1,3 @@
+DIST string-theory-3.3.tar.gz 588360 BLAKE2B ad87857e6d5e3cad1346b759457b434de7612b97e1b19016b1dfc987ac67f0cab318745b14fe1f432cc921ffb1d33b875a2a62f0bc56d815dd35b405a9f08560 SHA512 86209333dce341078c3b973084bd9f3b8ff2ccac0e07a5e6acf5973bd1cfa420897b531b2d1bd6aba9f5ccc8927f85d91f06796ac0e62ec8a735564a0387d2f4
+EBUILD string-theory-3.3.ebuild 790 BLAKE2B 7f5f08a59ee1233e4ab14e520fa837e65c1697215dc8330526a7011ba66a1d28c6f7e953f36b89231dc5e44bdb9dcfccc94f54c3a060a4df37b3341b9df2741d SHA512 b6f1d3baa1c606e0bb470aec7305dae97c7096b876768e45e250bb68480198a5f278a5ce9a9ef654bb29f35e2d435caff1eeba7c59e4be6866bc98b3eb519bc3
+MISC metadata.xml 469 BLAKE2B 4826f5bd124fec7815e99d11166a0a4c79d806ace91b25f529f26e2b61e89451d2bd464e24103f24d39a1dc3bde56c608bd4cf4e167948633dbbc8381731a28c SHA512 6df6277f273d4d5a8739df38abe0e3f590bcae55b4bc00d2543f89d5429dc905c81464015f0e07933d8c5e38b9d74338d370baf4c8cf68b1ce66622f75ed1309
diff --git a/dev-cpp/string-theory/metadata.xml b/dev-cpp/string-theory/metadata.xml
new file mode 100644
index 000000000000..4f7470fb770c
--- /dev/null
+++ b/dev-cpp/string-theory/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>misanthropos@gmx.net</email>
+ <name>Richard Fröhning</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">zrax/string_theory</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/string-theory/string-theory-3.3.ebuild b/dev-cpp/string-theory/string-theory-3.3.ebuild
new file mode 100644
index 000000000000..5706dd0292ea
--- /dev/null
+++ b/dev-cpp/string-theory/string-theory-3.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="A flexible modern C++ library for string manipulation and storage"
+HOMEPAGE="https://github.com/zrax/string_theory/"
+SRC_URI="https://github.com/zrax/string_theory/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/string_theory-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ # Drop -Werror from bundled gtest
+ # bug #766468
+ sed -i -e "s/-Werror//" test/gtest-1.10.0/cmake/internal_utils.cmake || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DST_BUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}/test" || die
+ ./st_gtests || die
+}