summaryrefslogtreecommitdiff
path: root/dev-cpp/taskflow/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-13 08:16:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-13 08:16:09 +0000
commit4a74938e510c0dad732ae4c48f815dd0f0cabb46 (patch)
treee8c52cd3619bba6cf0a5c367f6c9d2cff0ac9d80 /dev-cpp/taskflow/files
parentebc282ef4dfa408accac685565b8ee5f6faec119 (diff)
gentoo auto-resync : 13:02:2023 - 08:16:09
Diffstat (limited to 'dev-cpp/taskflow/files')
-rw-r--r--dev-cpp/taskflow/files/taskflow-3.4.0-fix_doctest.patch30
1 files changed, 27 insertions, 3 deletions
diff --git a/dev-cpp/taskflow/files/taskflow-3.4.0-fix_doctest.patch b/dev-cpp/taskflow/files/taskflow-3.4.0-fix_doctest.patch
index 323d17e7f535..a63e84673f70 100644
--- a/dev-cpp/taskflow/files/taskflow-3.4.0-fix_doctest.patch
+++ b/dev-cpp/taskflow/files/taskflow-3.4.0-fix_doctest.patch
@@ -1,5 +1,5 @@
diff --git a/unittests/CMakeLists.txt b/unittests/CMakeLists.txt
-index 3397d798..1256e8e6 100644
+index 86a00bcc..5f5c36fb 100644
--- a/unittests/CMakeLists.txt
+++ b/unittests/CMakeLists.txt
@@ -1,6 +1,7 @@
@@ -11,7 +11,7 @@ index 3397d798..1256e8e6 100644
list(APPEND TF_UNITTESTS
utility
-@@ -23,8 +24,7 @@ list(APPEND TF_UNITTESTS
+@@ -24,8 +25,7 @@ list(APPEND TF_UNITTESTS
foreach(unittest IN LISTS TF_UNITTESTS)
add_executable(${unittest} ${unittest}.cpp)
@@ -46,7 +46,7 @@ index 28eeaa8c..466687a2 100644
// --------------------------------------------------------
diff --git a/unittests/basics.cpp b/unittests/basics.cpp
-index f5b9e3dd..e93c3fd3 100644
+index 290abccf..44301011 100644
--- a/unittests/basics.cpp
+++ b/unittests/basics.cpp
@@ -1,6 +1,6 @@
@@ -235,6 +235,30 @@ index 94d8f394..701365c0 100644
#include <taskflow/taskflow.hpp>
#include <taskflow/algorithm/pipeline.hpp>
+diff --git a/unittests/runtimes.cpp b/unittests/runtimes.cpp
+index 5a6155b5..4f7e5b74 100644
+--- a/unittests/runtimes.cpp
++++ b/unittests/runtimes.cpp
+@@ -1,6 +1,6 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+
+-#include <doctest.h>
++#include <doctest/doctest.h>
+ #include <taskflow/taskflow.hpp>
+ #include <taskflow/algorithm/pipeline.hpp>
+
+diff --git a/unittests/scalable_pipelines.cpp b/unittests/scalable_pipelines.cpp
+index 2534878b..e2073563 100644
+--- a/unittests/scalable_pipelines.cpp
++++ b/unittests/scalable_pipelines.cpp
+@@ -1,6 +1,6 @@
+ #define DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+
+-#include <doctest.h>
++#include <doctest/doctest.h>
+
+ #include <taskflow/taskflow.hpp>
+ #include <taskflow/algorithm/pipeline.hpp>
diff --git a/unittests/semaphores.cpp b/unittests/semaphores.cpp
index 616191b5..64b8a587 100644
--- a/unittests/semaphores.cpp