summaryrefslogtreecommitdiff
path: root/dev-cpp/toml11
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-27 12:00:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-27 12:00:02 +0100
commit345c02ca33341652116ddec6705530223af2de85 (patch)
treebcb9923530ba0703557f280b0a2bd1343bae857c /dev-cpp/toml11
parentf300354de9fe5d997850456a9e1f400193e6544f (diff)
gentoo auto-resync : 27:08:2024 - 12:00:02
Diffstat (limited to 'dev-cpp/toml11')
-rw-r--r--dev-cpp/toml11/Manifest3
-rw-r--r--dev-cpp/toml11/metadata.xml13
-rw-r--r--dev-cpp/toml11/toml11-4.2.0.ebuild26
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-cpp/toml11/Manifest b/dev-cpp/toml11/Manifest
new file mode 100644
index 000000000000..9ff259749d77
--- /dev/null
+++ b/dev-cpp/toml11/Manifest
@@ -0,0 +1,3 @@
+DIST toml11-4.2.0.tar.gz 345359 BLAKE2B 771de7b1af5b3a8f93c114ff4a4ea84b2884c9a0a9a3c304aa3489e4a4aed90d31bca41287a183ee58519455839d7fb4a3075c48d689232991dca67a850f785a SHA512 acb29d37150e5752526cf0a38ae7f207fcfd142d3c78d280e706ad404b2d32f5bae6d44d6ce13cc0bdfd3b0fa4a0a94cf732d70b1fd2a01c3c517fee8a4ef05b
+EBUILD toml11-4.2.0.ebuild 530 BLAKE2B 5790c78ef41feb0f6da40e8c54ca9a81d3c5db149d0925c2df93b41cf515b214f1763fbd20a18ae985115717d2cf019851eac82eb8b47ca9efa52faccd43cf9f SHA512 cd0eb90f7fb52c1261b2a0a23ea12dfedf63574c23a13cf43de3f6ff6bf3f75edd18e1a93a678fc83888a911b97ad65b2051076d6399a16a89531dc7892a0a4e
+MISC metadata.xml 402 BLAKE2B 3036a6fb020f076c47ad30c901b5f8a5e36af312190df2e8ae84cd374731b9711fb48b3d8f7f3463edd7b50ae99b6e4dc78d4e60dfa3b3ccc56cf4c806082063 SHA512 e438104524445b0a27547730396437403a2885403c5611fad81e438282517195b44f81040540162c7ee0ace9758f99c19feb0772ab2d8ad0cd6f853aaf64e6de
diff --git a/dev-cpp/toml11/metadata.xml b/dev-cpp/toml11/metadata.xml
new file mode 100644
index 000000000000..b6d01e802127
--- /dev/null
+++ b/dev-cpp/toml11/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ToruNiina/toml11</remote-id>
+ <bugs-to>https://github.com/ToruNiina/toml11/issues/</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/toml11/toml11-4.2.0.ebuild b/dev-cpp/toml11/toml11-4.2.0.ebuild
new file mode 100644
index 000000000000..da9ac1e07435
--- /dev/null
+++ b/dev-cpp/toml11/toml11-4.2.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="TOML for Modern C++"
+HOMEPAGE="https://toruniina.github.io/toml11/
+ https://github.com/ToruNiina/toml11/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/ToruNiina/${PN}.git"
+else
+ SRC_URI="https://github.com/ToruNiina/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DOCS=( README.md README_ja.md )