summaryrefslogtreecommitdiff
path: root/dev-cpp/tree
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-cpp/tree
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-cpp/tree')
-rw-r--r--dev-cpp/tree/Manifest2
-rw-r--r--dev-cpp/tree/files/tree-2.81-gcc11.patch33
-rw-r--r--dev-cpp/tree/files/tree-2.81-test.patch36
3 files changed, 0 insertions, 71 deletions
diff --git a/dev-cpp/tree/Manifest b/dev-cpp/tree/Manifest
index f1c08acbdf3a..9be9423dfbcb 100644
--- a/dev-cpp/tree/Manifest
+++ b/dev-cpp/tree/Manifest
@@ -1,5 +1,3 @@
-AUX tree-2.81-gcc11.patch 933 BLAKE2B c3b1afcd9325e9b452eb5b9279e4542d9f82f7d8de7060efbabecb302c2c064e5a5891533449e33f75c45078b2bc8c5fc7f7e3e8f204118345a02afa5a32b5c6 SHA512 43ec3975ecbd4b38105a2c4980da8ca0b19a5075bb6eaa5cae313c4f2eb5b8d44118dc55b778c5f973bc5ad69236bb94086cf1c72e8d9a9198ad25c14a8b5fa1
-AUX tree-2.81-test.patch 550 BLAKE2B fe73799591f7f0c65d2f031792bc87b2d85bc143bf4adb35e04db712ef95a5ba0e15d8256aec28a0ac95d2306fa45de41d1a8dc5d53629d38ede35fe87cef256 SHA512 a859891662a1093f517f43a6ea14a4e1f7d81988d0fe83253554bea83bfdecde0b51ed05795d0d6f0b3494a7cde6db56a8304397ea5ad9fb2d446647f4301514
DIST tree-3.17.tar.gz 1178425 BLAKE2B f59239b861c0495c48036d0fffa49370d4cd78a94bfc35348bbbe0232a3c1221293a23366a6289429adabcb00b21292288ce085fa54f74dc204537c95c5b7c37 SHA512 af11f693c13dd37dddf016751c0f975c21d7a5ad405879e18fbe5387400ee1fcfb42942ee8888efffcb0c985d7875f2698591139aeb18b4809e83e225a743112
EBUILD tree-3.17.ebuild 743 BLAKE2B ee1f494c9b7a0b29c220135e3304e638e45e820718967582814de04e66626ec8dbb6c132fb4e739c4b7cdc49f89f9398da9516fa3900ec8bedeb5a3cc3491c08 SHA512 4d45fa7d72cf2aba431d8fb4560dbae9608b0f6152433c2844af683b767495bbcec666b11bb967b48ce178ed2f28bf11cba2d4699fe31f8dd30b1ae4f67d1a9b
MISC metadata.xml 620 BLAKE2B 30c1a3c6c5416691c41fa2d587d80e76e72a7c349cc7e57afc723caddb6874cb849cf0db5943a12373253383845b649b522bc1abce65d036fc4757120b3524cc SHA512 ec64c3f8832072c5bac618a3990c6b488be2b6da98514d6ca508c620817c9c7ad40479c96168c7ab0078169f72f68a8e52131fb7b4786b281865e50c9a612e1a
diff --git a/dev-cpp/tree/files/tree-2.81-gcc11.patch b/dev-cpp/tree/files/tree-2.81-gcc11.patch
deleted file mode 100644
index feffe0de13cc..000000000000
--- a/dev-cpp/tree/files/tree-2.81-gcc11.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- "a/simple tree.hpp"
-+++ "b/simple tree.hpp"
-@@ -323,7 +323,7 @@
- public:
- compare_nodes(StrictWeakOrdering comp) : comp_(comp) {};
-
-- bool operator()(const tree_node *a, const tree_node *b)
-+ bool operator()(const tree_node *a, const tree_node *b) const
- {
- return comp_(a->data, b->data);
- }
---- a/tree.hh
-+++ b/tree.hh
-@@ -422,7 +422,7 @@
- public:
- compare_nodes(StrictWeakOrdering comp) : comp_(comp) {};
-
-- bool operator()(const tree_node *a, const tree_node *b)
-+ bool operator()(const tree_node *a, const tree_node *b) const
- {
- return comp_(a->data, b->data);
- }
---- a/xinlin.hh
-+++ b/xinlin.hh
-@@ -332,7 +332,7 @@
- public:
- compare_nodes(StrictWeakOrdering comp) : comp_(comp) {};
-
-- bool operator()(const tree_node *a, const tree_node *b)
-+ bool operator()(const tree_node *a, const tree_node *b) const
- {
- return comp_(a->data, b->data);
- }
diff --git a/dev-cpp/tree/files/tree-2.81-test.patch b/dev-cpp/tree/files/tree-2.81-test.patch
deleted file mode 100644
index c9e675dc7953..000000000000
--- a/dev-cpp/tree/files/tree-2.81-test.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -1,13 +1,6 @@
--
--%.o: %.cc
-- g++ -c -I. $^
--
--test1: test1.o
-- g++ -o test1 test1.o
--
--run_tests: test1 test1.req
-- ./test1 > test1.res
-- @diff test1.res test1.req
-+check: test_tree
-+ ./test_tree > mytest.output && \
-+ diff -Nu test_tree.output mytest.output
- @echo "*** All tests OK ***"
-
- clean:
---- a/test_tree.output
-+++ b/test_tree.output
-@@ -1,3 +1,8 @@
-+-----
-+hi
-+ 1
-+ 0
-+-----
- empty tree to begin with:
- 0
- 'more text' is sibling 2 in its sibling range
-@@ -309,3 +314,5 @@
- D
- I
- -----
-+G
-+H