summaryrefslogtreecommitdiff
path: root/dev-cpp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-26 00:31:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-26 00:31:47 +0000
commit8d35656b4a4e3a2ad6f87abb36b9fc3987d95a53 (patch)
tree464a1d53f3b0ad7cc1432e5b298a7ff78458527f /dev-cpp
parent85e7fcfe5631986ad1144ea54fc179d8658571d3 (diff)
gentoo auto-resync : 26:03:2025 - 00:31:47
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/Manifest.gzbin16824 -> 16827 bytes
-rw-r--r--dev-cpp/doctest/Manifest3
-rw-r--r--dev-cpp/doctest/doctest-2.4.11.ebuild8
-rw-r--r--dev-cpp/doctest/files/doctest-2.4.11-cmake4-pr888.patch31
-rw-r--r--dev-cpp/yaml-cpp/Manifest2
-rw-r--r--dev-cpp/yaml-cpp/files/yaml-cpp-0.8.0-cmake.patch32
-rw-r--r--dev-cpp/yaml-cpp/yaml-cpp-0.8.0-r1.ebuild37
7 files changed, 110 insertions, 3 deletions
diff --git a/dev-cpp/Manifest.gz b/dev-cpp/Manifest.gz
index ff4d82575f8c..fb6b62828d42 100644
--- a/dev-cpp/Manifest.gz
+++ b/dev-cpp/Manifest.gz
Binary files differ
diff --git a/dev-cpp/doctest/Manifest b/dev-cpp/doctest/Manifest
index 238a1d1679dd..fa75b720cd52 100644
--- a/dev-cpp/doctest/Manifest
+++ b/dev-cpp/doctest/Manifest
@@ -1,4 +1,5 @@
AUX doctest-2.4.11-backport-pr770.patch 2746 BLAKE2B f82437dfc44151b4b155a3e800824247356f666e6d80342096d91f07cbe351198e78b2e4cf6fc23091947ada9b518c4c4fc8b9f0cf56546acb36351ef0e06c40 SHA512 cf4464f9ff66520c4e0b413849d98b775772ff5e039b3921f6165a218f40642e62a5a79ee8e9c7fce3d27bb0a9ff61ccafb075eff82abb35e6950a2abcc94773
+AUX doctest-2.4.11-cmake4-pr888.patch 898 BLAKE2B 7d11c731453c8492b583984fdc156e3c58c221afd250657b755ad39af930d339f10ba43ec4cf64c492b3e62bb83b0a10552021e71f440707888f9374e3bb31ce SHA512 081eb9b2729addc092ae2da27630f056060b3cc4462ea533d3b5968251daf5e09d202d554bb9bdae5a27a12ea3f77adf1481a13a3ab310976eaace02e194c717
DIST doctest-2.4.11.tar.gz 2183312 BLAKE2B 277f22f3a9e275dd9f5cfffeeaf8346577223c2b872606f21fe5b8462573917a59a88bb61de145a92be61129396f9b4a87d94f4723e362428b1bd856ed84fcfb SHA512 04425686057079d3f1a6f767c487f1953050f553dbff9fc42b42dde1358fe26e46bf6219881bbfce625f15cb9c229474d82688120eb2cb2b1d8138db0cc91b3c
-EBUILD doctest-2.4.11.ebuild 745 BLAKE2B 2a862b53c921c27dc34623718b5d83e1856079cef54156d2d59bbd4351f31ac2223a2285679920d4a51e361db6680f99347ab326560c008590966b66a6c94fdc SHA512 709d479eb7a4d45583997cb92405989732e3b8d3e7a0bb3bba76521276f013adca80a0c1c85f87ade290f159ebe63222879e73bbbc901033221c5b8b58277ddb
+EBUILD doctest-2.4.11.ebuild 794 BLAKE2B 7c0d092baebe2157f157c125de3ec675c3e1f00337ffef0807feec88ed24a31961994e36584aa4de936ed7431e462bb5cb35cedabf95a9b49e45e16db51b0657 SHA512 b1fe4ffef7154ce5b50ce3e89ec3724052e5940330a5a5443ba08933427c411e988e1c8b2b237319791dabd351de267ea6b84c99f8c56d52d1551c842a70571f
MISC metadata.xml 326 BLAKE2B 3e72d429b6ab5c634954d5a9ed16f7ba2097800afac3d9d87cbf6926f196560351f5b5248dccf11b3da9e4a74f267fb1ff9ead8c18a458a87154dfc3514e7596 SHA512 381c172bf088b047ebba38d5c38d55f81b45e3a846aa54747ea01a23708b20f9f8434b18397318b4472b455990dc4b1e6626b821e2ab89cf5ad6ad92a813ed1b
diff --git a/dev-cpp/doctest/doctest-2.4.11.ebuild b/dev-cpp/doctest/doctest-2.4.11.ebuild
index bf495f020847..58604fa8f54c 100644
--- a/dev-cpp/doctest/doctest-2.4.11.ebuild
+++ b/dev-cpp/doctest/doctest-2.4.11.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022-2024 Gentoo Authors
+# Copyright 2022-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -14,7 +14,11 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="test"
RESTRICT="!test? ( test )"
-PATCHES=( "${FILESDIR}/${PN}-2.4.11-backport-pr770.patch" )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.4.11-backport-pr770.patch"
+ "${FILESDIR}/${PN}-2.4.11-cmake4-pr888.patch"
+)
src_prepare() {
sed -i '/-Werror/d' scripts/cmake/common.cmake || die
diff --git a/dev-cpp/doctest/files/doctest-2.4.11-cmake4-pr888.patch b/dev-cpp/doctest/files/doctest-2.4.11-cmake4-pr888.patch
new file mode 100644
index 000000000000..22aa020c9926
--- /dev/null
+++ b/dev-cpp/doctest/files/doctest-2.4.11-cmake4-pr888.patch
@@ -0,0 +1,31 @@
+From 82689538db96e478b5cb9f7753acf4121383df63 Mon Sep 17 00:00:00 2001
+From: "Trzcinski, Karol" <karol.trzcinski@intel.com>
+Date: Mon, 27 Jan 2025 08:53:06 +0100
+Subject: [PATCH] Bump minimal cmake version to 3.5
+
+Since cmake 3.27 appears warning like:
+
+```text
+ Compatibility with CMake < 3.5 will be removed from a future version of
+ CMake.
+```
+
+Such information may found in cmake release notes:
+https://cmake.org/cmake/help/latest/release/3.27.html
+
+Gentoo-bug: https://bugs.gentoo.org/951674
+Upstream-PR: https://github.com/doctest/doctest/pull/888
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 6d384fa96..0f6166b84 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,4 +1,4 @@
+-cmake_minimum_required(VERSION 3.0)
++cmake_minimum_required(VERSION 3.5)
+
+ if(POLICY CMP0077)
+ cmake_policy(SET CMP0077 NEW)
diff --git a/dev-cpp/yaml-cpp/Manifest b/dev-cpp/yaml-cpp/Manifest
index f9158d465a33..e7e63d3c5786 100644
--- a/dev-cpp/yaml-cpp/Manifest
+++ b/dev-cpp/yaml-cpp/Manifest
@@ -1,6 +1,8 @@
+AUX yaml-cpp-0.8.0-cmake.patch 1300 BLAKE2B ec414cb76897e5c8d72d4e7142fffa3e0dbb48a8977b411e7333c2394bf55fd89b3edf7810f106bff51354e0b73789b3c6c43a8d0c2e52b218989a95ec128cb2 SHA512 e48920b929d78661b5a0a710cb0cccf81aee58dacd7aea1d6d8395de4951bf74c0a0a863e7c0d4d89309f2249649675ced69d58bc0c84a0ac8a6cd411c87b57a
AUX yaml-cpp-0.8.0-gcc13.patch 2242 BLAKE2B 8b5b99e86a578310dd020237a82150dd0ae47dc009cff2f423ec6248c77635384c6e4ff0620a446858ec12223ea3148a006a76fd9c5a02c28cf29c0969b19dfd SHA512 429ca92104b6203695970e7bc79ed452c0dd6a02b98beb2e640a89184d10f1daedf10a5f7697942036317225c52a054c0916bfe1c54635b34b83721f72a31f6d
AUX yaml-cpp-0.8.0-gtest.patch 954 BLAKE2B 916365624688a62d2fa1f5dcbe62e65c872439efd8172a9898457797ce857003c31d8de082fe87ee9a47027f4021bc87ded88e7d4e40ed87e2da2a2333cc6d62 SHA512 781451e4477c22f059bb22b59b253bc2c2d4c0668bb00b44867d79a6d0e87f95abcfa11d35bcbf0e7aacc94b9185dfbef814018d7a58df00d93cd13ca0df8edc
AUX yaml-cpp-0.8.0-include-cstdint.patch 1090 BLAKE2B 0415488b047454dfbbf962b6e1f135c277e7c4b1cce30b76045c611d3cee9dcf6f701c8ff290ff3943442dd1d3c7ec8d5547328a91dbced7d93530d4dcb9703f SHA512 1e376b6ba5b4f5673271bb0790768ca8512efe44d821940c7bc58539d08f118bc30ebaa64a137bf7ba77987f6c5596706dcf99a9b4a58199aa0e4f7aa2969b52
DIST yaml-cpp-0.8.0.gh.tar.gz 1017151 BLAKE2B 5fd3eaec06bc04215afd2aa14ae8cd35f829f700f104931a51dbd8bb22e4e87f5cd5f2f975d3a2f464226d7165d3d106aa17bc7eab8a812c2545d2212011cf11 SHA512 aae9d618f906117d620d63173e95572c738db518f4ff1901a06de2117d8deeb8045f554102ca0ba4735ac0c4d060153a938ef78da3e0da3406d27b8298e5f38e
+EBUILD yaml-cpp-0.8.0-r1.ebuild 934 BLAKE2B a092a126c8d4a846a2057aace966c1d0c9093d597393b999e86a51b40c0647dea2a775929e5fdebbe3c78195565f3dfcf6d01bd28fdb1b15b086512487ab9108 SHA512 5eff772c522f9362bd240814600a455fffb1b0b39d896d58a52bb41518c784457d6cdfc8c78e83de215ac2a40d3d0e9a944774884a19105513c1f7725e5d7f72
EBUILD yaml-cpp-0.8.0.ebuild 886 BLAKE2B 3201a330fa6b5de80fbc96216b38ff4f52a38ba64ca652d0c002a750c8f343d6b518d19b8f621a56c5d8a95378ebb78306050a7da5072030110d7c52feb66755 SHA512 f9f2ae48d5fc6f5a2338a1582999e7db9c9cb1a2cb22880db1b5f845e1ca36e29a17353732f0fa64057d773e211a53215097d905be947998209066033d422e74
MISC metadata.xml 484 BLAKE2B e973aef681bed7de47725bab49d2acfe809ad73c97eea709bec9d5bb9d720f89bc222ff77f09b90780b2a14d6a094f9ddd24a4f15d6ad88b94060d240c5836d8 SHA512 612604d3b0c2edd157c4a55ae22d92e174cdcbc17532de7f2888b9579b4b028da2214e6d756864dfffdeca129f32e5db2241308d326c6ff21044f48bf2d87d73
diff --git a/dev-cpp/yaml-cpp/files/yaml-cpp-0.8.0-cmake.patch b/dev-cpp/yaml-cpp/files/yaml-cpp-0.8.0-cmake.patch
new file mode 100644
index 000000000000..52c6321983d7
--- /dev/null
+++ b/dev-cpp/yaml-cpp/files/yaml-cpp-0.8.0-cmake.patch
@@ -0,0 +1,32 @@
+https://bugs.gentoo.org/951842
+https://github.com/jbeder/yaml-cpp/pull/1211
+
+From 8153a1add19018f65527faad3c4d3941705baf39 Mon Sep 17 00:00:00 2001
+From: Craig Scott <craig.scott@crascit.com>
+Date: Wed, 16 Aug 2023 15:55:44 +1000
+Subject: [PATCH] Specify CMake policy range to avoid deprecation warning
+
+CMake 3.27 started issuing a deprecation warning for any
+cmake_minimum_required() call that specified a minimum
+version older than 3.5. Specifying a version range instead of
+a simple minimum version avoids that warning without
+raising the minimum supported CMake version. The NEW
+policy behavior will be used for all policies introduced up to
+CMake 3.14 with this change.
+---
+ CMakeLists.txt | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 46dc18059..1ae92e2b7 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,5 +1,6 @@
+-# 3.5 is actually available almost everywhere, but this a good minimum
+-cmake_minimum_required(VERSION 3.4)
++# 3.5 is actually available almost everywhere, but this a good minimum.
++# 3.14 as the upper policy limit avoids CMake deprecation warnings.
++cmake_minimum_required(VERSION 3.4...3.14)
+
+ # enable MSVC_RUNTIME_LIBRARY target property
+ # see https://cmake.org/cmake/help/latest/policy/CMP0091.html
diff --git a/dev-cpp/yaml-cpp/yaml-cpp-0.8.0-r1.ebuild b/dev-cpp/yaml-cpp/yaml-cpp-0.8.0-r1.ebuild
new file mode 100644
index 000000000000..8bdd15895875
--- /dev/null
+++ b/dev-cpp/yaml-cpp/yaml-cpp-0.8.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="YAML parser and emitter in C++"
+HOMEPAGE="https://github.com/jbeder/yaml-cpp"
+SRC_URI="https://github.com/jbeder/yaml-cpp/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/0.8"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? ( dev-cpp/gtest[${MULTILIB_USEDEP}] )
+"
+
+PATCHES=(
+ "${FILESDIR}/yaml-cpp-0.8.0-gtest.patch"
+ "${FILESDIR}/yaml-cpp-0.8.0-gcc13.patch"
+ "${FILESDIR}/yaml-cpp-0.8.0-include-cstdint.patch"
+ "${FILESDIR}/yaml-cpp-0.8.0-cmake.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DYAML_BUILD_SHARED_LIBS=ON
+ -DYAML_CPP_BUILD_TOOLS=OFF # Don't have install rule
+ -DYAML_CPP_BUILD_TESTS=$(usex test)
+ )
+
+ cmake-multilib_src_configure
+}