summaryrefslogtreecommitdiff
path: root/dev-cpp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-13 17:45:56 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-13 17:45:56 +0000
commitca04d5f1b74639bc2db1e371abbf0182fc431828 (patch)
tree5e6d2b5341c69d06a6d3e8352c5b8b88a5382302 /dev-cpp
parent0ded23e9afc3d3424aef90e5cec3f2ca6d6b4c30 (diff)
gentoo auto-resync : 13:12:2023 - 17:45:55
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/Manifest.gzbin14256 -> 14428 bytes
-rw-r--r--dev-cpp/tomlplusplus/Manifest3
-rw-r--r--dev-cpp/tomlplusplus/metadata.xml15
-rw-r--r--dev-cpp/tomlplusplus/tomlplusplus-3.4.0.ebuild39
4 files changed, 57 insertions, 0 deletions
diff --git a/dev-cpp/Manifest.gz b/dev-cpp/Manifest.gz
index 1967391019b1..cb8a3b866b7c 100644
--- a/dev-cpp/Manifest.gz
+++ b/dev-cpp/Manifest.gz
Binary files differ
diff --git a/dev-cpp/tomlplusplus/Manifest b/dev-cpp/tomlplusplus/Manifest
new file mode 100644
index 000000000000..dbddfbaae82f
--- /dev/null
+++ b/dev-cpp/tomlplusplus/Manifest
@@ -0,0 +1,3 @@
+DIST tomlplusplus-3.4.0.gh.tar.gz 1294731 BLAKE2B 9495ccd78707ced11744eab7c1c0bf0c0c28e283d186195bb48d1059bae7eb1a874bc964b0fc45210fd73ffd7485ecf3e1159da227d0e1c8ff249e79c08eecf0 SHA512 c227fc8147c9459b29ad24002aaf6ab2c42fac22ea04c1c52b283a0172581ccd4527b33c1931e0ef0d1db6b6a53f9e9882c6d4231c7f3494cf070d0220741aa5
+EBUILD tomlplusplus-3.4.0.ebuild 804 BLAKE2B 48f52fa0180e74c159c701e9a0e63b6ca8c36d9294178afb2866fbe6e5cb787f6070416130410151068a734d8e5dad7f3cce5cac3bfbc2491949ccb5ed2e4c5f SHA512 26dccdb39b29ad009c2ae4bdc6f4b1f5f0c0be3412d268e2e1f17c3c0867465d99f72fef404c839d0199da510e1994e1394c919dad7fd78948e4d283bf04eb62
+MISC metadata.xml 472 BLAKE2B 0b7b57b4dab3fe1f942c50c85a29550ded25998479db8e0b3a4502eca56e572047ede8085242c276fc5cce8e59a8991aa8866f695a761987aee8eb02b4d64783 SHA512 e5ded89974456e4731779fd95a11a380b32dda742e0355296f40b87062cfc960faac563bb4a7cb9f97dac2ad0744193d96383c9b3ea8688776444f9021d93055
diff --git a/dev-cpp/tomlplusplus/metadata.xml b/dev-cpp/tomlplusplus/metadata.xml
new file mode 100644
index 000000000000..e1c27afbcec2
--- /dev/null
+++ b/dev-cpp/tomlplusplus/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>julien@jroy.ca</email>
+ <name>Julien Roy</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">marzer/tomlplusplus</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/tomlplusplus/tomlplusplus-3.4.0.ebuild b/dev-cpp/tomlplusplus/tomlplusplus-3.4.0.ebuild
new file mode 100644
index 000000000000..c239fca55478
--- /dev/null
+++ b/dev-cpp/tomlplusplus/tomlplusplus-3.4.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="TOML config file parser and serializer"
+HOMEPAGE="
+https://marzer.github.io/tomlplusplus/
+https://github.com/marzer/tomlplusplus
+"
+SRC_URI="https://github.com/marzer/tomlplusplus/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local emesonargs=(
+ -Dbuild_lib=true
+ -Dgenerate_cmake_config=true
+ -Duse_vendored_libs=true # for test dependencies, header only and very restrictive version requirements
+ $(meson_use test build_tests)
+ )
+
+ meson_src_configure
+}
+
+src_test() {
+ local emesontestargs=(
+ 'tests - C'
+ )
+
+ meson_src_test "${emesontestargs[@]}"
+}