summaryrefslogtreecommitdiff
path: root/dev-db/bucardo/bucardo-5.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-db/bucardo/bucardo-5.4.1.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-db/bucardo/bucardo-5.4.1.ebuild')
-rw-r--r--dev-db/bucardo/bucardo-5.4.1.ebuild20
1 files changed, 8 insertions, 12 deletions
diff --git a/dev-db/bucardo/bucardo-5.4.1.ebuild b/dev-db/bucardo/bucardo-5.4.1.ebuild
index f70a7753f02a..a1057bb64f08 100644
--- a/dev-db/bucardo/bucardo-5.4.1.ebuild
+++ b/dev-db/bucardo/bucardo-5.4.1.ebuild
@@ -1,31 +1,27 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-RESTRICT="test"
+EAPI=8
inherit perl-module
MY_PN="Bucardo"
-
DESCRIPTION="An asynchronous PostgreSQL replication system"
HOMEPAGE="http://bucardo.org/wiki/Bucardo"
SRC_URI="http://bucardo.org/downloads/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86"
-#IUSE="test" doesn't work without extra data
-IUSE=""
+# doesn't work without extra data
+RESTRICT="test"
-DEPEND="dev-perl/DBIx-Safe
- dev-perl/DBD-Pg"
RDEPEND="dev-perl/DBIx-Safe"
-
-S=${WORKDIR}/${MY_PN}-${PV}
+DEPEND="${RDEPEND}
+ dev-perl/DBD-Pg"
src_install() {
- emake DESTDIR="${D}" INSTALL_BASE="${D}" install -j1
+ emake DESTDIR="${D}" INSTALL_BASE="${D}" install
keepdir /var/run/bucardo
}