summaryrefslogtreecommitdiff
path: root/dev-db/cpp-driver/cpp-driver-2.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-19 17:57:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-19 17:57:29 +0100
commitd473a706836012853193afc7000922601e4ada61 (patch)
tree01c43bd6b2121d90bc97ead47dd7654d9402ea1d /dev-db/cpp-driver/cpp-driver-2.7.1.ebuild
parent420eeee727d39d869d864caddb04a80dafda7160 (diff)
gentoo resync : 19.10.2017
Diffstat (limited to 'dev-db/cpp-driver/cpp-driver-2.7.1.ebuild')
-rw-r--r--dev-db/cpp-driver/cpp-driver-2.7.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-db/cpp-driver/cpp-driver-2.7.1.ebuild b/dev-db/cpp-driver/cpp-driver-2.7.1.ebuild
new file mode 100644
index 000000000000..a68364459ede
--- /dev/null
+++ b/dev-db/cpp-driver/cpp-driver-2.7.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="DataStax C/C++ Driver for Cassandra"
+HOMEPAGE="http://datastax.github.io/cpp-driver/"
+SRC_URI="https://github.com/datastax/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl libressl"
+
+RDEPEND="
+ dev-libs/libuv
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=( -DCASS_USE_OPENSSL=$(usex ssl) )
+ cmake-utils_src_configure
+}