summaryrefslogtreecommitdiff
path: root/dev-db/db-je
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-db/db-je
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-db/db-je')
-rw-r--r--dev-db/db-je/Manifest4
-rw-r--r--dev-db/db-je/db-je-3.3.75.ebuild40
-rw-r--r--dev-db/db-je/files/db-je-3.3.75-optional-test.patch45
-rw-r--r--dev-db/db-je/metadata.xml12
4 files changed, 101 insertions, 0 deletions
diff --git a/dev-db/db-je/Manifest b/dev-db/db-je/Manifest
new file mode 100644
index 000000000000..315d81bcc9b0
--- /dev/null
+++ b/dev-db/db-je/Manifest
@@ -0,0 +1,4 @@
+AUX db-je-3.3.75-optional-test.patch 1791 BLAKE2B 40c45dd4b65121a06fe180e6c9c23e2494438b504e108bc5b015cfadb21dc34c0b3e90eff3c17abf549d62ecfd595186d228f2bec65d44846d65b9d4059b95bc SHA512 a33e2ae28fa121c68990b44f5441685d50b025db784d07ee6fb78ae9a19ec8c10ee1ec91fb0296507a94792fca86b9a54b5a3e8fd1c0e076f5dc6c0c28cceb1a
+DIST je-3.3.75.tar.gz 5179709 BLAKE2B 9bc8382ad2bf54efd1a235115972761ecc38e2f641a6722623c7d2806e6eb2e2dbe65bf91e899844641365fb144fe73e021d70c02f12343e6dccb998426c229e SHA512 e28648459a3a7dcf98e8865e6859544c656c3b58688b244df568cc8c006a74dda79aadfbfb279e099c1376914cca064734da490998a864c1bd2cc3209bc64ae4
+EBUILD db-je-3.3.75.ebuild 922 BLAKE2B 4d374d1a6f714af9556b2e3545e548dd5c3c11058271581577d24d2b83d80bd54852604059f6f3e654d9fe03d9dd53eba37eb0d411ce1ef9d68b55bcf6226a4d SHA512 dcf25942c326705a46b0d1e6dd2d35d0a6367d9782fd3c14636753a5cad0942c8e3a49141a12c4a6d2dddc10e3e235e36af2969b40f715209b525bfd11719518
+MISC metadata.xml 352 BLAKE2B 8390000455654697f473905c14903172230b9667fd16c4db74dd32643b096cb7c8efa21f8614b30d676fb32e052a76c613298e2a28c362d6135f61a4fe27c242 SHA512 a3c6ce3cd97b39644238700277dd416e1ee79df975184de3429810ca4d77f7160112adef6a9b56f77243a003187f6642798b278cf8501d55da766ccfbaa861cf
diff --git a/dev-db/db-je/db-je-3.3.75.ebuild b/dev-db/db-je/db-je-3.3.75.ebuild
new file mode 100644
index 000000000000..fed1f010b3cf
--- /dev/null
+++ b/dev-db/db-je/db-je-3.3.75.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A high performance, transactional storage engine written entirely in Java"
+HOMEPAGE="http://www.oracle.com/database/berkeley-db/je/index.html"
+SRC_URI="http://download.oracle.com/berkeley-db/${P/db-/}.tar.gz"
+
+LICENSE="Sleepycat BSD"
+SLOT="3.3"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.5"
+RDEPEND=">=virtual/jre-1.5"
+S=${WORKDIR}/${P/db-/}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}" || die
+ epatch "${FILESDIR}"/${P}-optional-test.patch
+ rm -rf docs
+ cd lib || die
+ rm -v *jar || die
+ java-pkg_jar-from --build-only ant-core ant.jar
+}
+
+EANT_DOC_TARGET="javadoc-all"
+EANT_EXTRA_ARGS="-Dnotest=true"
+
+src_install() {
+ java-pkg_dojar build/lib/je.jar
+ use doc && java-pkg_dojavadoc docs
+ use source && java-pkg_dosrc src/com
+}
diff --git a/dev-db/db-je/files/db-je-3.3.75-optional-test.patch b/dev-db/db-je/files/db-je-3.3.75-optional-test.patch
new file mode 100644
index 000000000000..e8f7600398e2
--- /dev/null
+++ b/dev-db/db-je/files/db-je-3.3.75-optional-test.patch
@@ -0,0 +1,45 @@
+--- build.xml 2008-06-11 05:25:20.000000000 +0200
++++ build.xml.new 2008-08-22 15:59:53.000000000 +0200
+@@ -102,6 +102,7 @@
+ <path id="empty.classpath"/>
+
+ <path id="class.path">
++ <fileset dir="lib" includes="*.jar"/>
+ <pathelement location="${specificjar}"/>
+ <pathelement location="."/>
+ </path>
+@@ -487,14 +488,14 @@
+ <!-- JUnit unit tests -->
+ <!-- ============================================================ -->
+
+- <target name="init-unittest" depends="init">
++ <target name="init-unittest" depends="init" unless="notest">
+ <delete dir="${unittest.datadir}"/>
+ <delete dir="${unittest.reportsdir}"/>
+ <mkdir dir="${unittest.datadir}"/>
+ <mkdir dir="${unittest.reportsdir}"/>
+ </target>
+
+- <target name="clean-unittest" depends="init-unittest">
++ <target name="clean-unittest" depends="init-unittest" unless="notest">
+ <delete dir="${unittest.destdir}"/>
+ <mkdir dir="${unittest.destdir}"/>
+ <delete dir="${unittest.testserialdir}"/>
+@@ -503,7 +504,7 @@
+ <mkdir dir="${unittest.testevolvedir}"/>
+ </target>
+
+- <target name="compile-unittest" depends="compile-src">
++ <target name="compile-unittest" depends="compile-src" unless="notest">
+ <ant antfile="ant/compile.xml" dir="." inheritall="false">
+ <property name="srcdir" value="${unittest.srcdir}"/>
+ <property name="destdir" value="${unittest.destdir}"/>
+@@ -597,7 +598,7 @@
+ </path>
+
+ <target name="test"
+- depends="compile-unittest, init-unittest, jar">
++ depends="compile-unittest, init-unittest, jar" unless="notest">
+
+ <!-- Determine which tests to run. -->
+ <condition property="alltests">
diff --git a/dev-db/db-je/metadata.xml b/dev-db/db-je/metadata.xml
new file mode 100644
index 000000000000..bc74090b9d62
--- /dev/null
+++ b/dev-db/db-je/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tommy@gentoo.org</email>
+ <name>Thomas Sachau (Tommy[D])</name>
+ </maintainer>
+<maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+</pkgmetadata>