summaryrefslogtreecommitdiff
path: root/dev-db/firebird/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-03 08:59:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-03 08:59:05 +0000
commite6ba529df30e3fc9dfdf55ec5797f2f764df6e54 (patch)
tree6b38c918c796f792ef4b18b57437c05a1fd46ae8 /dev-db/firebird/files
parentfbe7acf59ebf6dc3f04a6ef108ff3887fa5d7972 (diff)
gentoo auto-resync : 03:12:2022 - 08:59:05
Diffstat (limited to 'dev-db/firebird/files')
-rw-r--r--dev-db/firebird/files/firebird-3.0.10.33601.0-configure-autoconf2.72.patch21
-rw-r--r--dev-db/firebird/files/firebird-3.0.10.33601.0-configure-clang16.patch48
-rw-r--r--dev-db/firebird/files/firebird-3.0.10.33601.0-flags.patch25
-rw-r--r--dev-db/firebird/files/firebird-3.0.10.33601.0-unbundle.patch97
4 files changed, 191 insertions, 0 deletions
diff --git a/dev-db/firebird/files/firebird-3.0.10.33601.0-configure-autoconf2.72.patch b/dev-db/firebird/files/firebird-3.0.10.33601.0-configure-autoconf2.72.patch
new file mode 100644
index 000000000000..29cca62fc790
--- /dev/null
+++ b/dev-db/firebird/files/firebird-3.0.10.33601.0-configure-autoconf2.72.patch
@@ -0,0 +1,21 @@
+https://github.com/FirebirdSQL/firebird/commit/3fe8f6510de79689a26868e244840b24dcb19567
+
+From 3fe8f6510de79689a26868e244840b24dcb19567 Mon Sep 17 00:00:00 2001
+From: AlexPeshkoff <alexander.peshkoff@gmail.com>
+Date: Wed, 23 Nov 2022 20:30:03 +0300
+Subject: [PATCH] Fixed #7394: autoconf 2.72 support
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -696,8 +696,9 @@ if test "$STD_EDITLINE" = "true"; then
+ AC_CHECK_LIB(readline, readline, [READLINE=readline EDITLINE_FLG=Y],
+ [STD_EDITLINE=false
+ if test "$EDITLINE_FLG" = "Y"; then
+- AC_MSG_WARN([[[--with-system-editline specified, not found. Using bundled editline]]])])))
++ AC_MSG_WARN([[[--with-system-editline specified, not found. Using bundled editline]]])
+ fi
++ ])))
+ fi
+ XE_RESTORE_ENV()
+
+
diff --git a/dev-db/firebird/files/firebird-3.0.10.33601.0-configure-clang16.patch b/dev-db/firebird/files/firebird-3.0.10.33601.0-configure-clang16.patch
new file mode 100644
index 000000000000..06d6907369ca
--- /dev/null
+++ b/dev-db/firebird/files/firebird-3.0.10.33601.0-configure-clang16.patch
@@ -0,0 +1,48 @@
+https://github.com/FirebirdSQL/firebird/pull/7407
+
+From a39cde31c4c78866c8f8ee0285fc4bcb81496d81 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Thu, 1 Dec 2022 18:26:06 +0100
+Subject: [PATCH] configure.ac: Add missing int return types to main
+
+Implicit ints are a language feature that was removed in C99 and
+future compilers may require declaration of all return types.
+--- a/configure.ac
++++ b/configure.ac
+@@ -1118,7 +1118,7 @@ AC_CHECK_FUNCS(sem_init)
+ if test "$ac_cv_func_sem_init" = "yes"; then
+ AC_MSG_CHECKING(for working sem_init())
+ AC_RUN_IFELSE([AC_LANG_SOURCE([[#include <semaphore.h>
+- main () {
++ int main () {
+ sem_t s;
+ return sem_init(&s,0,0);
+ }
+@@ -1159,7 +1159,7 @@ AC_SYS_LARGEFILE
+ if test "$ac_cv_sys_file_offset_bits" = "no"; then
+ AC_MSG_CHECKING(for native large file support)
+ AC_RUN_IFELSE([AC_LANG_SOURCE([[#include <unistd.h>
+- main () {
++ int main () {
+ return !(sizeof(off_t) == 8);
+ }]])],[ac_cv_sys_file_offset_bits=64; AC_DEFINE(_FILE_OFFSET_BITS,64)
+ AC_MSG_RESULT(yes)],[AC_MSG_RESULT(no)],[])
+@@ -1206,7 +1206,7 @@ dnl EKU: try to determine the alignment of long and double
+ dnl replaces FB_ALIGNMENT and FB_DOUBLE_ALIGN in src/jrd/common.h
+ AC_MSG_CHECKING(alignment of long)
+ AC_RUN_IFELSE([AC_LANG_SOURCE([[#include <semaphore.h>
+-main () {
++int main () {
+ struct s {
+ char a;
+ union { long long x; sem_t y; } b;
+@@ -1217,7 +1217,7 @@ AC_MSG_RESULT($ac_cv_c_alignment)
+ AC_DEFINE_UNQUOTED(FB_ALIGNMENT, $ac_cv_c_alignment, [Alignment of long])
+
+ AC_MSG_CHECKING(alignment of double)
+-AC_RUN_IFELSE([AC_LANG_SOURCE([[main () {
++AC_RUN_IFELSE([AC_LANG_SOURCE([[int main () {
+ struct s {
+ char a;
+ double b;
+
diff --git a/dev-db/firebird/files/firebird-3.0.10.33601.0-flags.patch b/dev-db/firebird/files/firebird-3.0.10.33601.0-flags.patch
new file mode 100644
index 000000000000..a0ecef4693c4
--- /dev/null
+++ b/dev-db/firebird/files/firebird-3.0.10.33601.0-flags.patch
@@ -0,0 +1,25 @@
+# Compile externs with same CXX/CC/CFLAGS/CXXFLAGS/LDFLAGS as main
+--- a/builds/posix/Makefile.in
++++ b/builds/posix/Makefile.in
+@@ -127,8 +127,8 @@
+ endif
+
+ extern:
+- $(MAKE) -C $(ROOT)/extern/btyacc
+- $(MAKE) -C $(ROOT)/extern/cloop TARGET=release WITH_FPC=0 BUILD_DIR=$(TMP_ROOT)/cloop OUT_DIR=$(GEN_ROOT)/$(TARGET)/cloop
++ $(MAKE) -C $(ROOT)/extern/btyacc CC="$(CC)" CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)"
++ $(MAKE) -C $(ROOT)/extern/cloop TARGET=release WITH_FPC=0 BUILD_DIR=$(TMP_ROOT)/cloop OUT_DIR=$(GEN_ROOT)/$(TARGET)/cloop CXX="$(CXX)" CXXFLAGS="$(OPTIMIZE_FLAGS)" CFLAGS="${CFLAGS}" CC="${CC}" LDFLAGS="$(LDDFLAGS)"
+
+ ifeq ($(TOMBUILD_FLG),Y)
+ $(MAKE) -C $(ROOT)/extern/libtommath -f makefile.shared LIBTOOL=$(LIBTOOL)
+@@ -592,8 +592,8 @@
+ $(EXE_LINK) $(EXE_LINK_OPTIONS) $^ -o $@ $(FIREBIRD_LIBRARY_LINK) $(LINK_LIBS) $(call LINK_DARWIN_RPATH,..)
+
+ examples: include_generic
+- $(MAKE) -f Makefile.examples -C $(GEN_ROOT)/examples/
+- $(MAKE) -f Makefile.plugins_examples
++ $(MAKE) -f Makefile.examples -C $(GEN_ROOT)/examples/ CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}"
++ $(MAKE) -f Makefile.plugins_examples CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}"
+
+ message_file: $(FIREBIRD_MSG)
+
diff --git a/dev-db/firebird/files/firebird-3.0.10.33601.0-unbundle.patch b/dev-db/firebird/files/firebird-3.0.10.33601.0-unbundle.patch
new file mode 100644
index 000000000000..4e5399f198b6
--- /dev/null
+++ b/dev-db/firebird/files/firebird-3.0.10.33601.0-unbundle.patch
@@ -0,0 +1,97 @@
+Partly based on:
+- https://github.com/freebsd/freebsd-ports/blob/main/databases/firebird30-server/files/patch-builds-posix_Makefile.in.plugins_examples
+- https://github.com/freebsd/freebsd-ports/blob/main/databases/firebird30-server/files/patch-extern_btyacc_Makefile
+- https://github.com/freebsd/freebsd-ports/blob/main/databases/firebird30-server/files/patch-extern_cloop_Makefile
+- https://github.com/freebsd/freebsd-ports/blob/main/databases/firebird30-server/files/patch-builds_posix_make.defaults
+--- a/builds/posix/Makefile.in
++++ b/builds/posix/Makefile.in
+@@ -688,8 +688,8 @@ install install-embedded silent_install package packages dist:
+ # various cleaning
+ #
+ .PHONY: clean clean_objects clean_dependancies clean_extern_objects clean_build \
+- clean_gpre_gen clean_icu clean_dbs clean_examples clean_makefiles \
+- clean_editline clean_all
++ clean_gpre_gen clean_dbs clean_examples clean_makefiles \
++ clean_all
+
+
+ clean: clean_objects clean_dependancies clean_extern_objects clean_build \
+@@ -708,8 +708,6 @@ clean_config clean_all: clean clean_makefiles
+ $(RM) $(ROOT)/config.status
+ $(RM) $(ROOT)/libtool
+ $(RM_R) $(ROOT)/autom4te.cache
+- -$(MAKE) -C $(ROOT)/extern/editline distclean
+-# -$(MAKE) -C $(ROOT)/extern/icu/source distclean
+ -$(MAKE) -C $(ROOT)/extern/btyacc distclean
+
+ clean_dbs:
+@@ -724,12 +722,6 @@ clean_dbs:
+ clean_examples:
+ $(RM) `find $(GEN_ROOT)/examples/ -type f ! -name 'Make*'`
+
+-clean_editline:
+- -$(MAKE) -C $(ROOT)/extern/editline clean
+-
+-#clean_icu:
+-# -$(MAKE) -C $(ROOT)/extern/icu/source clean
+-
+ clean_tommath:
+ -$(MAKE) -C $(ROOT)/extern/libtommath clean
+
+--- a/builds/posix/Makefile.in.plugins_examples
++++ b/builds/posix/Makefile.in.plugins_examples
+@@ -99,7 +99,7 @@ AllObjects += $(CA_Objects)
+ crypt_app: $(CRYPT_APP)
+
+ $(CRYPT_APP): $(CA_Objects)
+- $(EXE_LINK) $^ -o $@ $(FIREBIRD_LIBRARY_LINK)
++ $(EXE_LINK) $(LDFLAGS) $^ -o $@ $(FIREBIRD_LIBRARY_LINK)
+
+
+ include $(ROOT)/gen/make.shared.targets
+--- a/builds/posix/make.defaults
++++ b/builds/posix/make.defaults
+@@ -240,7 +240,7 @@ LIBFBINTL_SO = $(FB_BUILD)/intl/$(LIB_PREFIX)fbintl.$(SHRLIB_EXT)
+
+ ifeq ($(EDITLINE_FLG),Y)
+ ifeq ($(STD_EDITLINE), true)
+- LIBEDITLINE := -l$(READLINE)
++ LIBEDITLINE := $(shell ${PKG_CONFIG} libedit --libs)
+ else
+ LIBEDITLINE := $(LIB)/libedit.a
+ endif
+--- a/extern/btyacc/Makefile
++++ b/extern/btyacc/Makefile
+@@ -42,7 +42,7 @@ OTHERS = README README.BYACC \
+ all: $(PROGRAM)
+
+ $(PROGRAM): $(OBJS) $(LIBS)
+- $(CC) $(LDFLAGS) -o $(PROGRAM) $(OBJS) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(PROGRAM) $(OBJS) $(LIBS)
+
+ clean:; rm -f $(OBJS)
+
+--- a/extern/cloop/Makefile
++++ b/extern/cloop/Makefile
+@@ -6,7 +6,7 @@ TARGET := release
+
+ CC := $(CC)
+ CXX := $(CXX)
+-LD := $(CXX)
++LD := $(CXX) $(LDFLAGS)
+
+ SRC_DIR := src
+ BUILD_DIR := build
+@@ -27,8 +27,10 @@ SRCS_CPP := $(foreach sdir,$(SRC_DIRS),$(wildcard $(sdir)/*.cpp))
+ OBJS_C := $(patsubst $(SRC_DIR)/%.c,$(OBJ_DIR)/%.o,$(SRCS_C))
+ OBJS_CPP := $(patsubst $(SRC_DIR)/%.cpp,$(OBJ_DIR)/%.o,$(SRCS_CPP))
+
+-C_FLAGS := -ggdb -fPIC -MMD -MP -W -Wall -Wno-unused-parameter
+-CXX_FLAGS := $(C_FLAGS)
++
++COMMON_C_FLAGS := -ggdb -fPIC -MMD -MP -W -Wall -Wno-unused-parameter
++C_FLAGS := $(COMMON_C_FLAGS) $(CFLAGS) $(CPPFLAGS)
++CXX_FLAGS := $(COMMON_C_FLAGS) $(CXXFLAGS) $(CPPFLAGS)
+ FPC_FLAGS := -Mdelphi
+
+ ifeq ($(TARGET),release)