summaryrefslogtreecommitdiff
path: root/dev-db/libdbi/libdbi-0.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-db/libdbi/libdbi-0.9.0.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-db/libdbi/libdbi-0.9.0.ebuild')
-rw-r--r--dev-db/libdbi/libdbi-0.9.0.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/dev-db/libdbi/libdbi-0.9.0.ebuild b/dev-db/libdbi/libdbi-0.9.0.ebuild
deleted file mode 100644
index 7f6a738b7a40..000000000000
--- a/dev-db/libdbi/libdbi-0.9.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils autotools multilib
-
-DESCRIPTION="A database-independent abstraction layer in C"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-HOMEPAGE="http://libdbi.sourceforge.net/"
-LICENSE="LGPL-2.1"
-
-IUSE="doc static-libs"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-SLOT=0
-
-DOCS="AUTHORS ChangeLog README README.osx TODO"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4
- virtual/pkgconfig
- doc? ( app-text/openjade )
-"
-PDEPEND=">=dev-db/libdbi-drivers-0.9.0" # On purpose, libdbi-drivers 0.8.4 does not exist
-
-src_unpack() {
- unpack ${A}
- chown -R portage:portage "${S}"
-}
-
-src_prepare() {
- #epatch "${FILESDIR}"/${PN}-0.9.0-fix-ac-macro.patch
- #epatch "${FILESDIR}"/libdbi-0.8.1-pkg-config.patch
- #cp -f "${FILESDIR}"/dbi.pc.in "${S}"/dbi.pc.in
- epatch "${FILESDIR}"/libdbi-0.9.0-doc-build-fix.patch
-
- # configure.in has been changed
- eautoreconf
- # should append CFLAGS, not replace them
- sed -i.orig -e 's/^CFLAGS = /CFLAGS += /g' src/Makefile.in
-}
-
-src_configure() {
- econf \
- $(use_enable doc docs) \
- $(use_enable static-libs static)
-}
-
-src_install () {
- default
-
- prune_libtool_files --all
-
- # syslog-ng requires dbi.pc
- insinto /usr/$(get_libdir)/pkgconfig/
- doins dbi.pc
-}