summaryrefslogtreecommitdiff
path: root/dev-db/maatkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /dev-db/maatkit
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'dev-db/maatkit')
-rw-r--r--dev-db/maatkit/Manifest3
-rw-r--r--dev-db/maatkit/maatkit-7540-r1.ebuild110
-rw-r--r--dev-db/maatkit/metadata.xml14
3 files changed, 0 insertions, 127 deletions
diff --git a/dev-db/maatkit/Manifest b/dev-db/maatkit/Manifest
deleted file mode 100644
index 007c0a341ee9..000000000000
--- a/dev-db/maatkit/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST maatkit-7540.tar.gz 1312812 BLAKE2B fae133ac0fc95b6c824eccdd156941d6cc6693dda21756752b5f9244d4053b0d13d1464ab4dbb09b95da5385638f72f2e0c91c3ac64eeece0ad387324d8d01a9 SHA512 98cb44a5ebce09322b4d9a8cfa9e14e2ccb54ef9e0e8a95ee92b0fee5277f06157415152566497893488967735049d95c6efadc0d57c8a70060c7bc714afef9a
-EBUILD maatkit-7540-r1.ebuild 2648 BLAKE2B ff112cd9ecda8f35c52391c3956c9463c19ddd570a7752b4ad1f27307e36b9d3233365f38183d746c81b7654c5fafc4ae735c72031cfdc734c6d07333e1f0da9 SHA512 50bb20b8ed8f7cfe42e672c43803f62cc97756fd268be02e6166e7b184cf2671e8447aa7f12ec29c71872a493fa2b807318faaf62fa1ea94a95aa652bfef33eb
-MISC metadata.xml 665 BLAKE2B 564d2c428e52287e471afc42c2aa43516458b3dff6cdba5daa041145ff426d62480e3d0bc5ca9bd408a05cb22691c295616a2c22357ec05cde993e34ac9f356a SHA512 afbdf9167fdf5c3efacbbe3952cede0a377c3f2eb614e1b65e15bfcc1394e586f59c5786ef3e679453a3bf3f40ae54153b9f7d324f5e4d5e07a2d8cd43c3c25b
diff --git a/dev-db/maatkit/maatkit-7540-r1.ebuild b/dev-db/maatkit/maatkit-7540-r1.ebuild
deleted file mode 100644
index 9cefb50cea68..000000000000
--- a/dev-db/maatkit/maatkit-7540-r1.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit perl-app perl-module toolchain-funcs
-
-DESCRIPTION="essential command-line utilities for MySQL"
-HOMEPAGE="http://www.maatkit.org/"
-SRC_URI="https://maatkit.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="udf"
-
-COMMON_DEPEND="dev-perl/DBI
- dev-perl/DBD-mysql
- virtual/perl-Time-HiRes"
-RDEPEND="${COMMON_DEPEND}
- virtual/perl-Getopt-Long
- virtual/perl-Time-Local
- virtual/perl-Digest-MD5
- virtual/perl-IO-Compress
- virtual/perl-File-Temp
- virtual/perl-File-Spec
- virtual/perl-Time-HiRes
- virtual/perl-Scalar-List-Utils
- dev-perl/TermReadKey"
-DEPEND="${COMMON_DEPEND}
- udf? ( dev-db/mysql )
- virtual/perl-ExtUtils-MakeMaker"
-
-mysql-udf_src_compile() {
- local udfdir="${T}/udf/"
- mkdir -p "${udfdir}"
-
- local udfname udffile udfext udfoutpath
- udfname="${1}"
- udfext=".so"
- udffile="${udfname}${udfext}"
- udfoutpath="${udfdir}/${udffile}"
- shift
- CXX="$(tc-getCXX)"
- local src="$@"
- if [ -z "$@" ]; then
- src="${udfname}.cc"
- fi
- for f in ${src} ; do
- [ -f "${f}" ] || \
- die "UDF ${udfname}: Cannot find source file ${f} to compile"
- done
- einfo "UDF ${udfname}: compiling from ${src}"
- ${CXX} \
- ${CXXFLAGS} -I/usr/include/mysql \
- ${LDFLAGS} -fPIC -shared -o "${udfoutpath}" $src \
- || die "UDF ${udfname}: Failed to compile"
-}
-
-mysql-udf_src_install() {
- local udfdir="${T}/udf/"
- local udfname udfext udffile udfoutpath
- udfname="${1}"
- udfext=".so"
- udffile="${udfname}${udfext}"
- udfoutpath="${udfdir}/${udffile}"
- insinto /usr/$(get_libdir)/mysql/plugins
- doins "${udfoutpath}"
-}
-
-udf_done_intro=0
-mysql-udf_pkg_postinst() {
- local udfname udffile udfext udffunc udfreturn
- udfname="${1}"
- udfext=".so"
- udffile="${udfname}${udfext}"
- udffunc="${2}"
- udfreturn="${3}"
- if [ ${udf_done_intro} -eq 0 ]; then
- elog "To use the UDFs that were built:"
- elog "Update your configuration to include 'plugin_dir=/usr/$(get_libdir)/mysql/plugins'"
- elog "Issue the following commands as a user with FUNCTION privileges:"
- udf_done_intro=1
- fi
- elog "CREATE FUNCTION ${udffunc} RETURNS ${udfreturn} SONAME '${udffile}'"
-}
-
-src_compile() {
- perl-app_src_compile
- if use udf; then
- cd "${S}"/udf
- mysql-udf_src_compile murmur_udf
- mysql-udf_src_compile fnv_udf
- fi
-}
-
-src_install() {
- perl-module_src_install
- if use udf; then
- mysql-udf_src_install murmur_udf
- mysql-udf_src_install fnv_udf
- fi
-}
-
-pkg_postinst() {
- if use udf; then
- mysql-udf_pkg_postinst murmur_udf murmur_hash INTEGER
- mysql-udf_pkg_postinst fnv_udf fnv_64 INTEGER
- fi
-}
diff --git a/dev-db/maatkit/metadata.xml b/dev-db/maatkit/metadata.xml
deleted file mode 100644
index d3ab294dbcd0..000000000000
--- a/dev-db/maatkit/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <longdescription>maatkit, formerly MySQL Toolkit, is a collection of command-line utilities that
-provide missing functionality for MySQL. Some of the tools implement lacking
-server functionality, such as online consistency checks for master/slave
-replication; others are client-side utilities such as a query profiler.</longdescription>
- <use>
- <flag name="udf">Build the MySQL UDFs shipped with maatkit, requires non-minimal MySQL</flag>
- </use>
- <upstream>
- <remote-id type="google-code">maatkit</remote-id>
- </upstream>
-</pkgmetadata>