summaryrefslogtreecommitdiff
path: root/dev-db/mysql-super-smack/mysql-super-smack-1.3-r5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /dev-db/mysql-super-smack/mysql-super-smack-1.3-r5.ebuild
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'dev-db/mysql-super-smack/mysql-super-smack-1.3-r5.ebuild')
-rw-r--r--dev-db/mysql-super-smack/mysql-super-smack-1.3-r5.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/dev-db/mysql-super-smack/mysql-super-smack-1.3-r5.ebuild b/dev-db/mysql-super-smack/mysql-super-smack-1.3-r5.ebuild
new file mode 100644
index 000000000000..e47e1a187676
--- /dev/null
+++ b/dev-db/mysql-super-smack/mysql-super-smack-1.3-r5.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+MY_P="super-smack-${PV}"
+
+DESCRIPTION="Benchmarking, stress testing, and load generation tool for MySQL & PostGreSQL"
+HOMEPAGE="http://vegan.net/tony/supersmack/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+mysql postgres"
+REQUIRED_USE="|| ( mysql postgres )"
+
+DEPEND="
+ sys-libs/zlib:=
+ mysql? ( dev-db/mysql-connector-c:= )
+ postgres? ( dev-db/postgresql:*[server] )"
+RDEPEND="
+ ${DEPEND}
+ mysql? ( virtual/mysql )"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.destdir.patch
+ "${FILESDIR}"/${PN}-1.3.amd64.patch
+ "${FILESDIR}"/${PN}-1.3.gcc4.3.patch
+ "${FILESDIR}"/${PN}-1.3-gen-data.patch
+ "${FILESDIR}"/${PN}-1.3-autotools.patch
+)
+
+src_prepare() {
+ default
+ # Clean up files so eautoreconf does not pick up any
+ # deprecated autotools macros.
+ rm acinclude.m4 aclocal.m4 acconfig.h config.status config.h || die
+
+ eautoreconf
+}
+
+src_configure() {
+ append-cxxflags -std=gnu++98
+
+ local myeconfargs=(
+ $(usev mysql --with-mysql)
+ $(usev postgres --with-pgsql)
+ --with-datadir="${EPREFIX}"/var/tmp/super-smack
+ --with-smacks-dir="${EPREFIX}"/usr/share/super-smack
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ dodoc MANUAL TUTORIAL
+
+ keepdir /var/tmp/super-smack
+}
+
+pkg_postinst() {
+ elog "The gen-data binary is now installed as super-smack-gen-data"
+}