summaryrefslogtreecommitdiff
path: root/dev-db/mysqltuner/mysqltuner-1.6.18.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-db/mysqltuner/mysqltuner-1.6.18.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-db/mysqltuner/mysqltuner-1.6.18.ebuild')
-rw-r--r--dev-db/mysqltuner/mysqltuner-1.6.18.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-db/mysqltuner/mysqltuner-1.6.18.ebuild b/dev-db/mysqltuner/mysqltuner-1.6.18.ebuild
new file mode 100644
index 000000000000..4bb2ed7b6a9b
--- /dev/null
+++ b/dev-db/mysqltuner/mysqltuner-1.6.18.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN=MySQLTuner-perl
+
+DESCRIPTION="MySQLTuner is a high-performance MySQL tuning script"
+HOMEPAGE="http://www.mysqltuner.com/"
+SRC_URI="https://github.com/major/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+ virtual/perl-Getopt-Long
+ virtual/mysql"
+
+DOCS=( USAGE.md CONTRIBUTING.md INTERNALS.md basic_passwords.txt vulnerabilities.csv )
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_install() {
+ newbin "${PN}.pl" "${PN}"
+
+ # The passwords and vulnerabilities are meant to be fed to the script uncompressed
+ docompress -x "/usr/share/doc/${PF}/basic_passwords.txt" "/usr/share/doc/${PF}/vulnerabilities.csv"
+ einstalldocs
+}