summaryrefslogtreecommitdiff
path: root/dev-db/pg_top/pg_top-4.0.0-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-db/pg_top/pg_top-4.0.0-r3.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-db/pg_top/pg_top-4.0.0-r3.ebuild')
-rw-r--r--dev-db/pg_top/pg_top-4.0.0-r3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-db/pg_top/pg_top-4.0.0-r3.ebuild b/dev-db/pg_top/pg_top-4.0.0-r3.ebuild
new file mode 100644
index 000000000000..5f3dab62c30b
--- /dev/null
+++ b/dev-db/pg_top/pg_top-4.0.0-r3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="'top' for PostgreSQL"
+HOMEPAGE="https://pg_top.gitlab.io/"
+SRC_URI="https://pg_top.gitlab.io/source/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-db/postgresql:=
+ dev-libs/libbsd
+ sys-libs/ncurses:=
+ virtual/libelf:="
+DEPEND="${RDEPEND}"
+
+DOCS=( HISTORY.rst README.rst TODO Y2K )
+
+src_prepare() {
+ sed 's/set(CMAKE_C_FLAGS "-Wall")//' -i CMakeLists.txt || die
+ cmake_src_prepare
+}