summaryrefslogtreecommitdiff
path: root/dev-db/pgpool2/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
commitab3da91fb6c91a9df52fff8f991570f456fd3c7a (patch)
treee8f3bfa2c6c3d20ec3b9c352c839e23949068b6b /dev-db/pgpool2/files
parent6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (diff)
gentoo resync : 18.12.2020
Diffstat (limited to 'dev-db/pgpool2/files')
-rw-r--r--dev-db/pgpool2/files/pgpool-4.2.0-configure-memcached.patch60
-rw-r--r--dev-db/pgpool2/files/pgpool-4.2.0-configure-pthread.patch14
-rw-r--r--dev-db/pgpool2/files/pgpool-4.2.0-run_paths.patch432
3 files changed, 506 insertions, 0 deletions
diff --git a/dev-db/pgpool2/files/pgpool-4.2.0-configure-memcached.patch b/dev-db/pgpool2/files/pgpool-4.2.0-configure-memcached.patch
new file mode 100644
index 000000000000..9854e45e3a22
--- /dev/null
+++ b/dev-db/pgpool2/files/pgpool-4.2.0-configure-memcached.patch
@@ -0,0 +1,60 @@
+diff -Naruw pgpool-II-4.2.0.orig/configure.ac pgpool-II-4.2.0/configure.ac
+--- pgpool-II-4.2.0.orig/configure.ac 2020-11-25 20:25:42.000000000 -0500
++++ pgpool-II-4.2.0/configure.ac 2020-12-16 06:36:26.051076452 -0500
+@@ -392,37 +392,24 @@
+ fi
+
+
+-AC_ARG_WITH(memcached,
+- [ --with-memcached=DIR site header files for libmemcached in DIR],
+- [
+- case "$withval" in
+- "" | y | ye | yes | n | no)
+- AC_MSG_ERROR([*** You must supply an argument to the --with-memcached option.])
+- ;;
+- *)
+-
+- MEMCACHED_INCLUDE_DIR="$withval"/include
+- MEMCACHED_LIB_DIR="$withval"/lib
+- OLD_CFLAGS="$CFLAGS"
+- CFLAGS="$CFLAGS -I$MEMCACHED_INCLUDE_DIR"
++AC_ARG_WITH([memcached],
++ AS_HELP_STRING([--with-memcached], [Build with memcached support]))
++AS_IF([test "x$with_memcached" = "xyes"], [
++ PKG_CHECK_MODULES([MEMCACHED], [libmemcached])
++ CFLAGS="$CFLAGS $MEMCACHED_CFLAGS"
++ LIBS="$LIBS $MEMCACHED_LIBS"
++
+ AC_CHECK_HEADERS(
+ [libmemcached/memcached.h],
+ [AC_DEFINE([USE_MEMCACHED], 1, [Define to 1 to build with memcached support])],
+- [AC_MSG_ERROR([header file <libmemcached/memcached.h> is required for memcached support])])
+- CFLAGS=$OLD_CFLAGS
+- AC_CHECK_LIB(memcached, memcached_create, [], [AC_MSG_ERROR(libmemcached is not installed)])
+- MEMCACHED_INCLUDE_OPT="-I $MEMCACHED_INCLUDE_DIR"
+- MEMCACHED_LINK_OPT="-L$MEMCACHED_LIB_DIR"
+- MEMCACHED_RPATH_OPT="-rpath $MEMCACHED_LIB_DIR"
+- ;;
+- esac
++ [AC_MSG_ERROR([Couldn't find <libmemcached/memcached.h>])])
++
++ AC_SEARCH_LIBS(memcached_create, [], [],
++ [AC_MSG_ERROR(libmemcached is not installed)])
+ ])
+
+ CFLAGS="$CFLAGS -fno-strict-aliasing"
+
+-AC_SUBST(MEMCACHED_INCLUDE_OPT)
+-AC_SUBST(MEMCACHED_LINK_OPT)
+-AC_SUBST(MEMCACHED_RPATH_OPT)
+
+ OLD_LDFLAGS="$LDFLAGS"
+ LDFLAGS="-L$PGSQL_LIB_DIR $LDFLAGS"
+@@ -435,7 +422,6 @@
+ AC_SUBST(PGSQL_INCLUDE_DIR)
+ AC_SUBST(PGSQL_LIB_DIR)
+ AC_SUBST(PGSQL_BIN_DIR)
+-AC_SUBST(MEMCACHED_DIR)
+
+ # --enable(disable)-rpath option
+ AC_ARG_ENABLE(rpath,
diff --git a/dev-db/pgpool2/files/pgpool-4.2.0-configure-pthread.patch b/dev-db/pgpool2/files/pgpool-4.2.0-configure-pthread.patch
new file mode 100644
index 000000000000..842fd5fbad73
--- /dev/null
+++ b/dev-db/pgpool2/files/pgpool-4.2.0-configure-pthread.patch
@@ -0,0 +1,14 @@
+diff -Naruw pgpool-II-4.2.0.orig/configure.ac pgpool-II-4.2.0/configure.ac
+--- pgpool-II-4.2.0.orig/configure.ac 2020-11-25 20:25:42.000000000 -0500
++++ pgpool-II-4.2.0/configure.ac 2020-12-16 06:40:11.150611861 -0500
+@@ -4,6 +4,10 @@
+ dnl Checks for programs.
+ AC_PROG_CC
+ AC_PROG_CC_C99()
++AX_PTHREAD
++LIBS="$PTHREAD_LIBS $LIBS"
++CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
++CC="$PTHREAD_CC"
+
+ # Error out if the compiler does not support C99, as the codebase
+ # relies on that.
diff --git a/dev-db/pgpool2/files/pgpool-4.2.0-run_paths.patch b/dev-db/pgpool2/files/pgpool-4.2.0-run_paths.patch
new file mode 100644
index 000000000000..2eca0fd59185
--- /dev/null
+++ b/dev-db/pgpool2/files/pgpool-4.2.0-run_paths.patch
@@ -0,0 +1,432 @@
+diff -Naruw a/src/include/parser/pg_config_manual.h b/src/include/parser/pg_config_manual.h
+--- a/src/include/parser/pg_config_manual.h
++++ b/src/include/parser/pg_config_manual.h
+@@ -228,7 +228,7 @@
+ * support them yet.
+ */
+ #ifndef WIN32
+-#define DEFAULT_PGSOCKET_DIR "/tmp"
++#define DEFAULT_PGSOCKET_DIR "/run/postgresql"
+ #else
+ #define DEFAULT_PGSOCKET_DIR ""
+ #endif
+diff -Naruw a/src/include/pcp/pcp_stream.h b/src/include/pcp/pcp_stream.h
+--- a/src/include/pcp/pcp_stream.h
++++ b/src/include/pcp/pcp_stream.h
+@@ -49,6 +49,6 @@
+ extern int pcp_write(PCP_CONNECTION * pc, void *buf, int len);
+ extern int pcp_flush(PCP_CONNECTION * pc);
+
+-#define UNIX_DOMAIN_PATH "/tmp"
++#define UNIX_DOMAIN_PATH "/run/pgpool"
+
+ #endif /* PCP_STREAM_H */
+diff -Naruw a/src/include/pool.h b/src/include/pool.h
+--- a/src/include/pool.h
++++ b/src/include/pool.h
+@@ -69,16 +69,16 @@
+ #define HBA_CONF_FILE_NAME "pool_hba.conf"
+
+ /* pid file directory */
+-#define DEFAULT_LOGDIR "/tmp"
++#define DEFAULT_LOGDIR "/run/pgpool"
+
+ /* Unix domain socket directory */
+-#define DEFAULT_SOCKET_DIR "/tmp"
++#define DEFAULT_SOCKET_DIR "/run/postgresql"
+
+ /* Unix domain socket directory for watchdog IPC */
+-#define DEFAULT_WD_IPC_SOCKET_DIR "/tmp"
++#define DEFAULT_WD_IPC_SOCKET_DIR "/run/pgpool"
+
+ /* pid file name */
+-#define DEFAULT_PID_FILE_NAME "/var/run/pgpool/pgpool.pid"
++#define DEFAULT_PID_FILE_NAME "/run/pgpool/pgpool.pid"
+
+ /* status file name */
+ #define STATUS_FILE_NAME "pgpool_status"
+diff -Naruw a/src/sample/pgpool.conf.sample b/src/sample/pgpool.conf.sample
+--- a/src/sample/pgpool.conf.sample
++++ b/src/sample/pgpool.conf.sample
+@@ -39,10 +39,8 @@
+ port = 9999
+ # Port number
+ # (change requires restart)
+-socket_dir = '/tmp'
++socket_dir = '/run/postgresql'
+ # Unix domain socket path
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+ reserved_connections = 0
+ # Number of reserved connections.
+@@ -59,10 +57,8 @@
+ pcp_port = 9898
+ # Port number for pcp
+ # (change requires restart)
+-pcp_socket_dir = '/tmp'
++pcp_socket_dir = '/run/pgpool'
+ # Unix domain socket path for pcp
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+ listen_backlog_multiplier = 2
+ # Set the backlog parameter of listen(2) to
+@@ -286,13 +282,13 @@
+ # FILE LOCATIONS
+ #------------------------------------------------------------------------------
+
+-pid_file_name = '/var/run/pgpool/pgpool.pid'
++pid_file_name = '/run/pgpool/pgpool.pid'
+ # PID file name
+ # Can be specified as relative to the"
+ # location of pgpool.conf file or
+ # as an absolute path
+ # (change requires restart)
+-logdir = '/tmp'
++logdir = '/run/pgpool'
+ # Directory of pgPool status file
+ # (change requires restart)
+
+@@ -659,10 +655,8 @@
+ # Authentication key for watchdog communication
+ # (change requires restart)
+
+-wd_ipc_socket_dir = '/tmp'
++wd_ipc_socket_dir = '/run/pgpool'
+ # Unix domain socket path for watchdog IPC socket
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+
+
+diff -Naruw a/src/sample/pgpool.conf.sample-logical b/src/sample/pgpool.conf.sample-logical
+--- a/src/sample/pgpool.conf.sample-logical
++++ b/src/sample/pgpool.conf.sample-logical
+@@ -38,10 +38,8 @@
+ port = 9999
+ # Port number
+ # (change requires restart)
+-socket_dir = '/tmp'
++socket_dir = '/run/postgresql'
+ # Unix domain socket path
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+ reserved_connections = 0
+ # Number of reserved connections.
+@@ -58,10 +56,8 @@
+ pcp_port = 9898
+ # Port number for pcp
+ # (change requires restart)
+-pcp_socket_dir = '/tmp'
++pcp_socket_dir = '/run/pgpool'
+ # Unix domain socket path for pcp
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+ listen_backlog_multiplier = 2
+ # Set the backlog parameter of listen(2) to
+@@ -286,13 +282,13 @@
+ # FILE LOCATIONS
+ #------------------------------------------------------------------------------
+
+-pid_file_name = '/var/run/pgpool/pgpool.pid'
++pid_file_name = '/run/pgpool/pgpool.pid'
+ # PID file name
+ # Can be specified as relative to the"
+ # location of pgpool.conf file or
+ # as an absolute path
+ # (change requires restart)
+-logdir = '/tmp'
++logdir = '/run/pgpool'
+ # Directory of pgPool status file
+ # (change requires restart)
+
+@@ -621,10 +617,8 @@
+ # Authentication key for watchdog communication
+ # (change requires restart)
+
+-wd_ipc_socket_dir = '/tmp'
++wd_ipc_socket_dir = '/run/pgpool'
+ # Unix domain socket path for watchdog IPC socket
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+
+
+diff -Naruw a/src/sample/pgpool.conf.sample-raw b/src/sample/pgpool.conf.sample-raw
+--- a/src/sample/pgpool.conf.sample-raw
++++ b/src/sample/pgpool.conf.sample-raw
+@@ -39,10 +39,8 @@
+ port = 9999
+ # Port number
+ # (change requires restart)
+-socket_dir = '/tmp'
++socket_dir = '/run/postgresql'
+ # Unix domain socket path
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+ reserved_connections = 0
+ # Number of reserved connections.
+@@ -59,10 +57,8 @@
+ pcp_port = 9898
+ # Port number for pcp
+ # (change requires restart)
+-pcp_socket_dir = '/tmp'
++pcp_socket_dir = '/run/pgpool'
+ # Unix domain socket path for pcp
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+ listen_backlog_multiplier = 2
+ # Set the backlog parameter of listen(2) to
+@@ -287,13 +283,13 @@
+ # FILE LOCATIONS
+ #------------------------------------------------------------------------------
+
+-pid_file_name = '/var/run/pgpool/pgpool.pid'
++pid_file_name = '/run/pgpool/pgpool.pid'
+ # PID file name
+ # Can be specified as relative to the"
+ # location of pgpool.conf file or
+ # as an absolute path
+ # (change requires restart)
+-logdir = '/tmp'
++logdir = '/run/pgpool'
+ # Directory of pgPool status file
+ # (change requires restart)
+
+@@ -660,10 +656,8 @@
+ # Authentication key for watchdog communication
+ # (change requires restart)
+
+-wd_ipc_socket_dir = '/tmp'
++wd_ipc_socket_dir = '/run/pgpool'
+ # Unix domain socket path for watchdog IPC socket
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+
+ # - Virtual IP control Setting -
+diff -Naruw a/src/sample/pgpool.conf.sample-replication b/src/sample/pgpool.conf.sample-replication
+--- a/src/sample/pgpool.conf.sample-replication
++++ b/src/sample/pgpool.conf.sample-replication
+@@ -39,10 +39,8 @@
+ port = 9999
+ # Port number
+ # (change requires restart)
+-socket_dir = '/tmp'
++socket_dir = '/run/postgresql'
+ # Unix domain socket path
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+ listen_backlog_multiplier = 2
+ # Set the backlog parameter of listen(2) to
+@@ -65,10 +63,8 @@
+ pcp_port = 9898
+ # Port number for pcp
+ # (change requires restart)
+-pcp_socket_dir = '/tmp'
++pcp_socket_dir = '/run/pgpool'
+ # Unix domain socket path for pcp
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+
+ # - Backend Connection Settings -
+@@ -282,13 +278,13 @@
+ # FILE LOCATIONS
+ #------------------------------------------------------------------------------
+
+-pid_file_name = '/var/run/pgpool/pgpool.pid'
++pid_file_name = '/run/pgpool/pgpool.pid'
+ # PID file name
+ # Can be specified as relative to the"
+ # location of pgpool.conf file or
+ # as an absolute path
+ # (change requires restart)
+-logdir = '/tmp'
++logdir = '/run/pgpool'
+ # Directory of pgPool status file
+ # (change requires restart)
+
+@@ -657,10 +653,8 @@
+ # Authentication key for watchdog communication
+ # (change requires restart)
+
+-wd_ipc_socket_dir = '/tmp'
++wd_ipc_socket_dir = '/run/pgpool'
+ # Unix domain socket path for watchdog IPC socket
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+
+
+diff -Naruw a/src/sample/pgpool.conf.sample-slony b/src/sample/pgpool.conf.sample-slony
+--- a/src/sample/pgpool.conf.sample-slony
++++ b/src/sample/pgpool.conf.sample-slony
+@@ -39,10 +39,8 @@
+ port = 9999
+ # Port number
+ # (change requires restart)
+-socket_dir = '/tmp'
++socket_dir = '/run/postgresql'
+ # Unix domain socket path
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+ listen_backlog_multiplier = 2
+ # Set the backlog parameter of listen(2) to
+@@ -65,10 +63,8 @@
+ pcp_port = 9898
+ # Port number for pcp
+ # (change requires restart)
+-pcp_socket_dir = '/tmp'
++pcp_socket_dir = '/run/pgpool'
+ # Unix domain socket path for pcp
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+
+ # - Backend Connection Settings -
+@@ -283,13 +279,13 @@
+ # FILE LOCATIONS
+ #------------------------------------------------------------------------------
+
+-pid_file_name = '/var/run/pgpool/pgpool.pid'
++pid_file_name = '/run/pgpool/pgpool.pid'
+ # PID file name
+ # Can be specified as relative to the"
+ # location of pgpool.conf file or
+ # as an absolute path
+ # (change requires restart)
+-logdir = '/tmp'
++logdir = '/run/pgpool'
+ # Directory of pgPool status file
+ # (change requires restart)
+
+@@ -658,10 +654,8 @@
+ # Authentication key for watchdog communication
+ # (change requires restart)
+
+-wd_ipc_socket_dir = '/tmp'
++wd_ipc_socket_dir = '/run/pgpool'
+ # Unix domain socket path for watchdog IPC socket
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+
+ # - Virtual IP control Setting -
+diff -Naruw a/src/sample/pgpool.conf.sample-snapshot b/src/sample/pgpool.conf.sample-snapshot
+--- a/src/sample/pgpool.conf.sample-snapshot
++++ b/src/sample/pgpool.conf.sample-snapshot
+@@ -39,10 +39,8 @@
+ port = 9999
+ # Port number
+ # (change requires restart)
+-socket_dir = '/tmp'
++socket_dir = '/run/postgresql'
+ # Unix domain socket path
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+ listen_backlog_multiplier = 2
+ # Set the backlog parameter of listen(2) to
+@@ -65,10 +63,8 @@
+ pcp_port = 9898
+ # Port number for pcp
+ # (change requires restart)
+-pcp_socket_dir = '/tmp'
++pcp_socket_dir = '/run/pgpool'
+ # Unix domain socket path for pcp
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+
+ # - Backend Connection Settings -
+@@ -280,13 +276,13 @@
+ # FILE LOCATIONS
+ #------------------------------------------------------------------------------
+
+-pid_file_name = '/var/run/pgpool/pgpool.pid'
++pid_file_name = '/run/pgpool/pgpool.pid'
+ # PID file name
+ # Can be specified as relative to the"
+ # location of pgpool.conf file or
+ # as an absolute path
+ # (change requires restart)
+-logdir = '/tmp'
++logdir = '/run/pgpool'
+ # Directory of pgPool status file
+ # (change requires restart)
+
+@@ -655,10 +651,8 @@
+ # Authentication key for watchdog communication
+ # (change requires restart)
+
+-wd_ipc_socket_dir = '/tmp'
++wd_ipc_socket_dir = '/run/pgpool'
+ # Unix domain socket path for watchdog IPC socket
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+
+
+diff -Naruw a/src/sample/pgpool.conf.sample-stream b/src/sample/pgpool.conf.sample-stream
+--- a/src/sample/pgpool.conf.sample-stream
++++ b/src/sample/pgpool.conf.sample-stream
+@@ -39,10 +39,8 @@
+ port = 9999
+ # Port number
+ # (change requires restart)
+-socket_dir = '/tmp'
++socket_dir = '/run/postgresql'
+ # Unix domain socket path
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+ reserved_connections = 0
+ # Number of reserved connections.
+@@ -59,10 +57,8 @@
+ pcp_port = 9898
+ # Port number for pcp
+ # (change requires restart)
+-pcp_socket_dir = '/tmp'
++pcp_socket_dir = '/run/pgpool'
+ # Unix domain socket path for pcp
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+ listen_backlog_multiplier = 2
+ # Set the backlog parameter of listen(2) to
+@@ -286,13 +282,13 @@
+ # FILE LOCATIONS
+ #------------------------------------------------------------------------------
+
+-pid_file_name = '/var/run/pgpool/pgpool.pid'
++pid_file_name = '/run/pgpool/pgpool.pid'
+ # PID file name
+ # Can be specified as relative to the"
+ # location of pgpool.conf file or
+ # as an absolute path
+ # (change requires restart)
+-logdir = '/tmp'
++logdir = '/run/pgpool'
+ # Directory of pgPool status file
+ # (change requires restart)
+
+@@ -659,10 +655,8 @@
+ # Authentication key for watchdog communication
+ # (change requires restart)
+
+-wd_ipc_socket_dir = '/tmp'
++wd_ipc_socket_dir = '/run/pgpool'
+ # Unix domain socket path for watchdog IPC socket
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+
+