summaryrefslogtreecommitdiff
path: root/dev-db/pgrouting
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-db/pgrouting
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-db/pgrouting')
-rw-r--r--dev-db/pgrouting/Manifest3
-rw-r--r--dev-db/pgrouting/metadata.xml15
-rw-r--r--dev-db/pgrouting/pgrouting-2.5.2.ebuild64
3 files changed, 82 insertions, 0 deletions
diff --git a/dev-db/pgrouting/Manifest b/dev-db/pgrouting/Manifest
new file mode 100644
index 000000000000..d9d363d2ed42
--- /dev/null
+++ b/dev-db/pgrouting/Manifest
@@ -0,0 +1,3 @@
+DIST pgrouting-2.5.2.tar.gz 7221479 BLAKE2B afbf29b7cbd52df526203198fb76d9e9e37e88a4b92d2139975238a14fe5a30c8102449d157e391913e690129a1ca8ac718763d9242193cac4080bc7347e1553 SHA512 9d9d9ebbcbc003f62bf1f0d548363e756012cdce55a9c3ef56ae9a5a510f25337898becf42f3e04bf10e8d3672ebf698def03833bba33410b65e0d2bdd42aecd
+EBUILD pgrouting-2.5.2.ebuild 1388 BLAKE2B 5b87b2a0af8aa23f1ba34980b3bfa5520aed9f6a35d21c05334bc8bdc43c233efeb3c396e7f7179babf7eb8083c84510d6a6b7f389aabe45b399badad54f2134 SHA512 4c9aa0761df88209b8d3b0c5cc8bbede6dba141f502463778102d0ee6b3d1112ae4de2da1202f4656dedbdcf2b47a96317426195abaa623c94ee5bc0bf57f189
+MISC metadata.xml 534 BLAKE2B 3bc33ee8118ea199f4261665ffd62fd7cde78928ed64556ed0ea84346da4405b6f5b4765b9a11c02a9f3e719eac3ff9d8392accd11361372437eea26ac0b6e3c SHA512 2892a64cf6e8e34e1ede87ddbcbaabd7e66bc5a45c5a8e21b33103af83e1a6a92c665fbfc02af6ae8fa6aec9df6ba340a40d3332d2da557789c95a312439a55f
diff --git a/dev-db/pgrouting/metadata.xml b/dev-db/pgrouting/metadata.xml
new file mode 100644
index 000000000000..01cf346d26bd
--- /dev/null
+++ b/dev-db/pgrouting/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>pgsql-bugs@gentoo.org</email>
+ <name>PostgreSQL and Related Package Development</name>
+ </maintainer>
+ <use>
+ <flag name="html">Install HTML formatted documentation</flag>
+ <flag name="drivingdistance">Enable to calculate driving distance</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">pgRouting/pgrouting</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-db/pgrouting/pgrouting-2.5.2.ebuild b/dev-db/pgrouting/pgrouting-2.5.2.ebuild
new file mode 100644
index 000000000000..7a0afdc63eac
--- /dev/null
+++ b/dev-db/pgrouting/pgrouting-2.5.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+POSTGRES_COMPAT=( 9.{4,5,6} 10 )
+POSTGRES_USEDEP="server"
+
+inherit postgres cmake-utils
+
+DESCRIPTION="pgRouting extends PostGIS and PostgreSQL with geospatial routing functionality."
+HOMEPAGE="https://pgrouting.org/"
+LICENSE="GPL-2 MIT Boost-1.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+SRC_URI="https://github.com/pgRouting/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE="+drivingdistance doc pdf html"
+
+REQUIRED_USE="html? ( doc ) pdf? ( doc )"
+
+RDEPEND="${POSTGRES_DEP}
+ >=dev-db/postgis-2.0
+ dev-libs/boost
+ drivingdistance? ( sci-mathematics/cgal )
+"
+
+DEPEND="
+ doc? ( >=dev-python/sphinx-1.1 )
+ pdf? ( >=dev-python/sphinx-1.1[latex] )
+"
+
+# Needs a running psql instance, doesn't work out of the box
+RESTRICT="test"
+
+pkg_setup() {
+ postgres_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_HTML=$(usex html)
+ -DBUILD_LATEX=$(usex pdf)
+ -DBUILD_MAN=$(usex doc)
+ -DWITH_DD=$(usex drivingdistance)
+ -DWITH_DOC=$(usex doc)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ local make_opts
+ use doc && make_opts="all doc"
+ cmake-utils_src_make ${make_opts}
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ use doc && doman "${BUILD_DIR}"/doc/man/en/pgrouting.7
+ use html && dodoc -r "${BUILD_DIR}"/doc/html
+ use pdf && dodoc "${BUILD_DIR}"/doc/latex/en/*.pdf
+}