summaryrefslogtreecommitdiff
path: root/dev-db/plr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-19 14:07:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-19 14:07:55 +0000
commitd725480af7cbc67d784e5d96f973fa41e9030123 (patch)
tree620bbc21e2e1384f13394c32a7294bc1c0e8bae1 /dev-db/plr
parent0184387f6a748c74c5d29cddf20289dc94f05ddc (diff)
gentoo auto-resync : 19:01:2024 - 14:07:55
Diffstat (limited to 'dev-db/plr')
-rw-r--r--dev-db/plr/Manifest4
-rw-r--r--dev-db/plr/metadata.xml3
-rw-r--r--dev-db/plr/plr-8.4.6.ebuild70
3 files changed, 76 insertions, 1 deletions
diff --git a/dev-db/plr/Manifest b/dev-db/plr/Manifest
index fa1dd98dbd75..a675fb1c4034 100644
--- a/dev-db/plr/Manifest
+++ b/dev-db/plr/Manifest
@@ -1,3 +1,5 @@
DIST plr-8.4.5.tar.gz 273711 BLAKE2B 666941f1cbc7e74dee532b928102afda4684b344f3c69a6ac4e3449c057e8f4dbb74b765f4222bb06e61940fa1e4ba888cc60bac193ca43989b557da9d02ceaa SHA512 bb04a8956d1cdc7acb20c89ea3b17be6ee385dac52381ab0f8af7446480fa9b8d163ff6697a05b439a75f57841b203e65bea78db8a7c3d55c1118bebbf4ac81a
+DIST plr-8.4.6.tar.gz 277578 BLAKE2B 575426e44e553f52dfe9b4bd1eb8de1b72e9023abe086c6b1570dabcda1b5e99a8eebce9c5b0e97019aec969b369e15a83801d51b8531695026e1a9bdc79d5c0 SHA512 de5f6b094f4eb6f88df6134142c461bc4ebd6a692c3db03cf04e1d0f04b71d63a26bce22defc1f25fa627c7bc4ba63c533dd2df1f571b58cb04d29c7eada2e42
EBUILD plr-8.4.5.ebuild 1709 BLAKE2B 2470f0234a816812e339bdf8f66ac3cc849d6d8c6d0e727d3c3291add98d4d2ebcdc5b178e1cedae75c8b5aa04a8fbd5d7455341e08364508a76d9992d9be6b3 SHA512 a737941c229732843b686cb2a1a8d03e1f35244ef79cb6bcb0d2ad8bb5a0fa55765f42384322a6b456df2cee87cb10819725e0bf0d9132488ce8b51a97a9105a
-MISC metadata.xml 399 BLAKE2B 07f2d03ca54183e589cfe1b91cc2e672ea7999cbb978c4879ca7c0327929010cdfadd530105dc7206f5739bd06dd78b28329409768f7a7013e9d6807200e1c76 SHA512 b0ce0c61aa57841cbb7a147f5540d512fef89ea7c871a24d4ecce01eb34c067a31ee344c4ecb2a10679b338da31b750a67dba1547d18fb164e9a15f393dc966f
+EBUILD plr-8.4.6.ebuild 1705 BLAKE2B 7b83258c13d1fbc7b19b49bce895d65e8016db6b032c9ee5246fd973b572f285c35ffc1c6d3aab3e4208e459f08445b3887e7dafe6e993f285d939b5a6456a46 SHA512 492a638be082d626b44adde0ca63cf0c8e5b1eb9e7f88d57b1ffcf97bb33a0ff033eb50e090321c3b59795c14ddda16c27f62b0eb31a3f1c0a3452b3d662d87b
+MISC metadata.xml 484 BLAKE2B 1c3f1a4a3fd93444f6821ab8924ce6dfa271095956800a54e1dce8669d7ad4b657dbe2d49741bdec75d78f7094cc455cb5dd9a713e507d2ccf7ddc43a93422a1 SHA512 5d95755b2c573ddd851ad607389597a44bb74bb8e32559f13e279b64ce589cd707015f63da19847d787bef1bfeacecc80936a8c095cbac184fade338bf0a03d8
diff --git a/dev-db/plr/metadata.xml b/dev-db/plr/metadata.xml
index a4942cba46ae..7290965385bf 100644
--- a/dev-db/plr/metadata.xml
+++ b/dev-db/plr/metadata.xml
@@ -8,4 +8,7 @@
An extension for postgresql databases to allow direct usage of
<pkg>dev-lang/R</pkg> in SQL queries and database functions
</longdescription>
+ <upstream>
+ <remote-id type="github">postgres-plr/plr</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-db/plr/plr-8.4.6.ebuild b/dev-db/plr/plr-8.4.6.ebuild
new file mode 100644
index 000000000000..bb10bae54f14
--- /dev/null
+++ b/dev-db/plr/plr-8.4.6.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( {12..16} )
+POSTGRES_USEDEP="server"
+
+inherit postgres-multi
+
+DESCRIPTION="R language extension for postgresql database"
+HOMEPAGE="http://www.joeconway.com/plr/"
+SRC_URI="https://github.com/postgres-plr/plr/archive/REL${PV//./_}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-lang/R
+ ${POSTGRES_DEP}"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+REQUIRED_USE="${POSTGRES_REQ_USE}"
+
+S="${WORKDIR}"/contrib/${PN}
+
+src_unpack() {
+ unpack ${A}
+
+ # the build system wants 'contrib' to be part of the path
+ mkdir -p "${WORKDIR}/contrib" || die
+ mv "${WORKDIR}/${PN}-REL${PV//./_}" "${S}" || die
+}
+
+src_prepare() {
+ local BUILD_DIR="${S}"
+ postgres-multi_src_prepare
+}
+
+src_compile() {
+ pg_src_compile() {
+ cd "${BUILD_DIR}"
+ PG_CONFIG="${ESYSROOT}/usr/$(get_libdir)/postgresql-${MULTIBUILD_ID}/bin/pg_config" \
+ USE_PGXS=1 \
+ emake -j1
+ }
+ postgres-multi_foreach pg_src_compile
+}
+
+src_install() {
+ pg_src_install() {
+ cd "${BUILD_DIR}"
+ PG_CONFIG="${ESYSROOT}/usr/$(get_libdir)/postgresql-${MULTIBUILD_ID}/bin/pg_config" \
+ USE_PGXS=1 \
+ emake -j1 DESTDIR="${D}" install
+ }
+ postgres-multi_foreach pg_src_install
+}
+
+pkg_postinst() {
+ elog "The plr extension needs to be explicitly added (or 'created') on each database"
+ elog "you wish to use it with. As of postgresql-9.1 the easiest way to do this is"
+ elog "with the proprietary SQL statement:"
+ elog
+ elog "\tCREATE EXTENSION plr;"
+ elog
+ elog "For more info on how to add PL/R to your postgresql database(s), please visit"
+ elog "http://www.joeconway.com/doc/plr-install.html"
+}