summaryrefslogtreecommitdiff
path: root/dev-db/postgis/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
commit441d1370330332b7d78f238d2f5e13f7aed5e4e0 (patch)
tree6a5171dd615dfeee62a45044144c66e864738fb0 /dev-db/postgis/files
parentab3da91fb6c91a9df52fff8f991570f456fd3c7a (diff)
gentoo christmass resync : 25.12.2020
Diffstat (limited to 'dev-db/postgis/files')
-rw-r--r--dev-db/postgis/files/postgis-3.0.3-avoid-calling-ar-directly.patch85
-rw-r--r--dev-db/postgis/files/postgis-3.0.3-detect-only-stdc.patch17
-rw-r--r--dev-db/postgis/files/postgis-3.0.3-try-other-cpp-names.patch12
3 files changed, 114 insertions, 0 deletions
diff --git a/dev-db/postgis/files/postgis-3.0.3-avoid-calling-ar-directly.patch b/dev-db/postgis/files/postgis-3.0.3-avoid-calling-ar-directly.patch
new file mode 100644
index 000000000000..66a82e1e7261
--- /dev/null
+++ b/dev-db/postgis/files/postgis-3.0.3-avoid-calling-ar-directly.patch
@@ -0,0 +1,85 @@
+From 7c5acb8ab83ee278f6a16c7279c3a12ca93499e9 Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl@gmail.com>
+Date: Sat, 5 Dec 2020 13:38:03 +0100
+Subject: [PATCH] avoid calling ar directly
+
+Signed-off-by: Bernd Waibel <waebbl@gmail.com>
+---
+ configure.ac | 2 +-
+ deps/wagyu/Makefile.in | 4 +++-
+ libpgcommon/Makefile.in | 4 +++-
+ raster/rt_core/Makefile.in | 1 +
+ 4 files changed, 8 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 4f26390..362d3e6 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -14,7 +14,7 @@ AC_CONFIG_HEADERS([postgis_config.h])
+ AC_CONFIG_MACRO_DIR([macros])
+ AC_CONFIG_AUX_DIR([build-aux])
+ AC_PROG_INSTALL
+-
++AM_PROG_AR
+
+ dnl Invoke libtool: we do this as it is the easiest way to find the PIC
+ dnl flags required to build liblwgeom
+diff --git a/deps/wagyu/Makefile.in b/deps/wagyu/Makefile.in
+index 03d2279..05d6629 100644
+--- a/deps/wagyu/Makefile.in
++++ b/deps/wagyu/Makefile.in
+@@ -28,6 +28,8 @@ LDFLAGS = @LDFLAGS@
+ top_builddir = @top_builddir@
+ libdir = @libdir@
+ LIBTOOL = @LIBTOOL@
++AR = @AR@
++ARFLAGS = rs
+
+ WAGYU_OBJS = \
+ lwgeom_wagyu.o
+@@ -78,7 +80,7 @@ WAGYU_HEADERS = \
+ all: @WAGYU_LIB@
+
+ @WAGYU_LIB@: $(WAGYU_OBJS)
+- ar rs @WAGYU_LIB@ $(WAGYU_OBJS)
++ $(AR) $(ARFLAGS) @WAGYU_LIB@ $(WAGYU_OBJS)
+
+ $(WAGYU_OBJS): %.o: %.cpp ../../liblwgeom/liblwgeom.h $(WAGYU_HEADERS)
+ $(CXX) $(CXXFLAGS) -c -o $@ $<
+diff --git a/libpgcommon/Makefile.in b/libpgcommon/Makefile.in
+index c44cf5b..78eb282 100644
+--- a/libpgcommon/Makefile.in
++++ b/libpgcommon/Makefile.in
+@@ -12,6 +12,8 @@
+ CC=@CC@
+ CFLAGS=-I../liblwgeom @WARNFLAGS@ @CFLAGS@ @PGSQL_BE_CPPFLAGS@ @PROJ_CPPFLAGS@ @PICFLAGS@ @GETTEXT_CFLAGS@
+ LDFLAGS=@GETTEXT_LDFLAGS@ @LIBINTL@
++AR = @AR@
++ARFLAGS = rs
+
+ NUMERICFLAGS=@NUMERICFLAGS@
+
+@@ -39,7 +41,7 @@ all: libpgcommon.a
+ install uninstall:
+
+ libpgcommon.a: $(SA_OBJS) $(SA_HEADERS)
+- ar rs libpgcommon.a $(SA_OBJS)
++ $(AR) $(ARFLAGS) libpgcommon.a $(SA_OBJS)
+
+ maintainer-clean: clean
+
+diff --git a/raster/rt_core/Makefile.in b/raster/rt_core/Makefile.in
+index 380a3e7..b399661 100644
+--- a/raster/rt_core/Makefile.in
++++ b/raster/rt_core/Makefile.in
+@@ -18,6 +18,7 @@
+ #
+ #############################################################################
+
++AR = @AR@
+ ARFLAGS = rs
+
+ CC = @CC@
+--
+2.29.2
+
diff --git a/dev-db/postgis/files/postgis-3.0.3-detect-only-stdc.patch b/dev-db/postgis/files/postgis-3.0.3-detect-only-stdc.patch
new file mode 100644
index 000000000000..5b97102bb236
--- /dev/null
+++ b/dev-db/postgis/files/postgis-3.0.3-detect-only-stdc.patch
@@ -0,0 +1,17 @@
+diff -Naruw postgis-3.1.0.orig/configure.ac postgis-3.1.0/configure.ac
+--- postgis-3.1.0.orig/configure.ac 2020-12-18 14:39:26.000000000 -0500
++++ postgis-3.1.0/configure.ac 2020-12-19 07:35:13.232167083 -0500
+@@ -1501,12 +1501,9 @@
+ dnl ============================================================
+ CC="$WAGYU_CXX"
+
+- AC_CHECK_LIB(c++, main, [HAVE_CPP=yes], [HAVE_CPP=no])
+ AC_CHECK_LIB(stdc++, main, [HAVE_STDCPP=yes], [HAVE_STDCPP=no])
+
+- if test "x$HAVE_CPP" = "xyes"; then
+- WAGYU_LDFLAGS="-lc++"
+- elif test "x$HAVE_STDCPP" = "xyes"; then
++ if test "x$HAVE_STDCPP" = "xyes"; then
+ WAGYU_LDFLAGS="-lstdc++"
+ else
+ AC_MSG_WARN("Could not find a C++ standard library")
diff --git a/dev-db/postgis/files/postgis-3.0.3-try-other-cpp-names.patch b/dev-db/postgis/files/postgis-3.0.3-try-other-cpp-names.patch
new file mode 100644
index 000000000000..691cf8d1936f
--- /dev/null
+++ b/dev-db/postgis/files/postgis-3.0.3-try-other-cpp-names.patch
@@ -0,0 +1,12 @@
+diff -Naruw postgis-3.1.0.orig/configure.ac postgis-3.1.0/configure.ac
+--- postgis-3.1.0.orig/configure.ac 2020-12-18 14:39:26.000000000 -0500
++++ postgis-3.1.0/configure.ac 2020-12-23 21:44:09.223273050 -0500
+@@ -31,7 +31,7 @@
+ dnl
+ dnl SQL Preprocessor
+ dnl
+-AC_PATH_PROG([CPPBIN], [cpp], [])
++AC_PATH_PROGS([CPPBIN], [cpp x86_64-pc-linux-gnu-cpp x86-pc-linux-gnu-cpp], [])
+ if test "x$CPPBIN" != "x"; then
+ SQLPP="${CPPBIN} -traditional-cpp -w -P"
+ else