summaryrefslogtreecommitdiff
path: root/dev-db/postgis/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-db/postgis/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-db/postgis/files')
-rw-r--r--dev-db/postgis/files/postgis-2.2.0-arflags.patch18
-rw-r--r--dev-db/postgis/files/postgis-2.4.2-jsonc_0.13.patch23
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-db/postgis/files/postgis-2.2.0-arflags.patch b/dev-db/postgis/files/postgis-2.2.0-arflags.patch
new file mode 100644
index 000000000000..97770042d8f6
--- /dev/null
+++ b/dev-db/postgis/files/postgis-2.2.0-arflags.patch
@@ -0,0 +1,18 @@
+diff -Naruw a/raster/rt_core/Makefile.in b/raster/rt_core/Makefile.in
+--- a/raster/rt_core/Makefile.in 2015-05-13 14:13:18.000000000 -0400
++++ b/raster/rt_core/Makefile.in 2015-12-14 16:49:49.166156232 -0500
+@@ -18,7 +18,7 @@
+ #
+ #############################################################################
+
+-AR = ar rs
++ARFLAGS = rs
+
+ CC = @CC@
+ LIBLWGEOM_LDFLAGS = ../../liblwgeom/.libs/liblwgeom.a
+@@ -64,4 +64,4 @@
+ rm -f Makefile
+
+ librtcore.a: $(RT_OBJS)
+- $(AR) $(RT_LIB) $(RT_OBJS)
++ $(AR) $(ARFLAGS) $(RT_LIB) $(RT_OBJS)
diff --git a/dev-db/postgis/files/postgis-2.4.2-jsonc_0.13.patch b/dev-db/postgis/files/postgis-2.4.2-jsonc_0.13.patch
new file mode 100644
index 000000000000..b980e77333d6
--- /dev/null
+++ b/dev-db/postgis/files/postgis-2.4.2-jsonc_0.13.patch
@@ -0,0 +1,23 @@
+diff -Naur postgis-2.4.2.old/liblwgeom/lwin_geojson.c postgis-2.4.2/liblwgeom/lwin_geojson.c
+--- postgis-2.4.2.old/liblwgeom/lwin_geojson.c 2017-12-21 22:52:40.422802160 +0100
++++ postgis-2.4.2/liblwgeom/lwin_geojson.c 2017-12-21 22:55:36.605430945 +0100
+@@ -31,13 +31,19 @@
+
+ #if defined(HAVE_LIBJSON) || defined(HAVE_LIBJSON_C) /* --{ */
+
++#define JSON_C_VERSION_013 (13 << 8)
++
+ #ifdef HAVE_LIBJSON_C
+ #include <json-c/json.h>
++#if !defined(JSON_C_VERSION_NUM) || JSON_C_VERSION_NUM < JSON_C_VERSION_013
+ #include <json-c/json_object_private.h>
++#endif
+ #else
+ #include <json/json.h>
++#if !defined(JSON_C_VERSION_NUM) || JSON_C_VERSION_NUM < JSON_C_VERSION_013
+ #include <json/json_object_private.h>
+ #endif
++#endif
+
+ #ifndef JSON_C_VERSION
+ /* Adds support for libjson < 0.10 */