summaryrefslogtreecommitdiff
path: root/dev-db/postgresql/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-18 14:34:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-18 14:34:38 +0100
commit3fb6e94893672e0dfbae682e6a3418e3f1260bf2 (patch)
tree6b19e4b8d9cb929c7caba132adbd596883f582ca /dev-db/postgresql/files
parent933ed80ab9b645de54b16eeb7410c0a54f47574f (diff)
gentoo auto-resync : 18:08:2022 - 14:34:37
Diffstat (limited to 'dev-db/postgresql/files')
-rw-r--r--dev-db/postgresql/files/postgres-llvm14.patch154
-rw-r--r--dev-db/postgresql/files/postgresql-13_beta1-no-server.patch149
-rw-r--r--dev-db/postgresql/files/postgresql-14_rc1-no-server.patch151
-rw-r--r--dev-db/postgresql/files/postgresql-9.6.3-no-server.patch141
4 files changed, 0 insertions, 595 deletions
diff --git a/dev-db/postgresql/files/postgres-llvm14.patch b/dev-db/postgresql/files/postgres-llvm14.patch
deleted file mode 100644
index 2c7b91d75153..000000000000
--- a/dev-db/postgresql/files/postgres-llvm14.patch
+++ /dev/null
@@ -1,154 +0,0 @@
-From d9f7ad54e552262ee0090e88d5abd3e04fcdeac8 Mon Sep 17 00:00:00 2001
-From: Thomas Munro <tmunro@postgresql.org>
-Date: Wed, 16 Mar 2022 11:35:00 +1300
-Subject: [PATCH] Back-patch LLVM 14 API changes.
-
-Since LLVM 14 has stopped changing and is about to be released,
-back-patch the following changes from the master branch:
-
- e6a7600202105919bffd62b3dfd941f4a94e082b
- 807fee1a39de6bb8184082012e643951abb9ad1d
- a56e7b66010f330782243de9e25ac2a6596be0e1
-
-Back-patch to 11, where LLVM JIT support came in.
----
- src/backend/jit/llvm/Makefile | 6 +++++
- src/backend/jit/llvm/llvmjit_error.cpp | 35 +++++++++++++++++++++----
- src/backend/jit/llvm/llvmjit_inline.cpp | 12 ++++++++-
- 3 files changed, 47 insertions(+), 6 deletions(-)
-
-diff --git a/src/backend/jit/llvm/Makefile b/src/backend/jit/llvm/Makefile
-index 0268bd46d5..2da122a391 100644
---- a/src/backend/jit/llvm/Makefile
-+++ b/src/backend/jit/llvm/Makefile
-@@ -22,6 +22,12 @@ endif
- PGFILEDESC = "llvmjit - JIT using LLVM"
- NAME = llvmjit
-
-+# LLVM 14 produces deprecation warnings. We'll need to make some changes
-+# before the relevant functions are removed, but for now silence the warnings.
-+ifeq ($(GCC), yes)
-+LLVM_CFLAGS += -Wno-deprecated-declarations
-+endif
-+
- # All files in this directory use LLVM.
- CFLAGS += $(LLVM_CFLAGS)
- CXXFLAGS += $(LLVM_CXXFLAGS)
-diff --git a/src/backend/jit/llvm/llvmjit_error.cpp b/src/backend/jit/llvm/llvmjit_error.cpp
-index f4720732a3..5ad92f3090 100644
---- a/src/backend/jit/llvm/llvmjit_error.cpp
-+++ b/src/backend/jit/llvm/llvmjit_error.cpp
-@@ -23,15 +23,22 @@ extern "C"
-
- #include "jit/llvmjit.h"
-
-+#include <new>
-
- static int fatal_new_handler_depth = 0;
- static std::new_handler old_new_handler = NULL;
-
- static void fatal_system_new_handler(void);
- #if LLVM_VERSION_MAJOR > 4
-+static void fatal_llvm_new_handler(void *user_data, const char *reason, bool gen_crash_diag);
-+#if LLVM_VERSION_MAJOR < 14
- static void fatal_llvm_new_handler(void *user_data, const std::string& reason, bool gen_crash_diag);
- #endif
-+#endif
-+static void fatal_llvm_error_handler(void *user_data, const char *reason, bool gen_crash_diag);
-+#if LLVM_VERSION_MAJOR < 14
- static void fatal_llvm_error_handler(void *user_data, const std::string& reason, bool gen_crash_diag);
-+#endif
-
-
- /*
-@@ -129,23 +136,41 @@ fatal_system_new_handler(void)
- #if LLVM_VERSION_MAJOR > 4
- static void
- fatal_llvm_new_handler(void *user_data,
-- const std::string& reason,
-+ const char *reason,
- bool gen_crash_diag)
- {
- ereport(FATAL,
- (errcode(ERRCODE_OUT_OF_MEMORY),
- errmsg("out of memory"),
-- errdetail("While in LLVM: %s", reason.c_str())));
-+ errdetail("While in LLVM: %s", reason)));
-+}
-+#if LLVM_VERSION_MAJOR < 14
-+static void
-+fatal_llvm_new_handler(void *user_data,
-+ const std::string& reason,
-+ bool gen_crash_diag)
-+{
-+ fatal_llvm_new_handler(user_data, reason.c_str(), gen_crash_diag);
- }
- #endif
-+#endif
-
- static void
- fatal_llvm_error_handler(void *user_data,
-- const std::string& reason,
-+ const char *reason,
- bool gen_crash_diag)
- {
- ereport(FATAL,
- (errcode(ERRCODE_OUT_OF_MEMORY),
-- errmsg("fatal llvm error: %s",
-- reason.c_str())));
-+ errmsg("fatal llvm error: %s", reason)));
- }
-+
-+#if LLVM_VERSION_MAJOR < 14
-+static void
-+fatal_llvm_error_handler(void *user_data,
-+ const std::string& reason,
-+ bool gen_crash_diag)
-+{
-+ fatal_llvm_error_handler(user_data, reason.c_str(), gen_crash_diag);
-+}
-+#endif
-diff --git a/src/backend/jit/llvm/llvmjit_inline.cpp b/src/backend/jit/llvm/llvmjit_inline.cpp
-index 6f03595db5..9bb4b672a7 100644
---- a/src/backend/jit/llvm/llvmjit_inline.cpp
-+++ b/src/backend/jit/llvm/llvmjit_inline.cpp
-@@ -594,7 +594,11 @@ function_inlinable(llvm::Function &F,
- if (F.materialize())
- elog(FATAL, "failed to materialize metadata");
-
-- if (F.getAttributes().hasFnAttribute(llvm::Attribute::NoInline))
-+#if LLVM_VERSION_MAJOR < 14
-+#define hasFnAttr hasFnAttribute
-+#endif
-+
-+ if (F.getAttributes().hasFnAttr(llvm::Attribute::NoInline))
- {
- ilog(DEBUG1, "ineligibile to import %s due to noinline",
- F.getName().data());
-@@ -871,7 +875,9 @@ create_redirection_function(std::unique_ptr<llvm::Module> &importMod,
- llvm::Function *AF;
- llvm::BasicBlock *BB;
- llvm::CallInst *fwdcall;
-+#if LLVM_VERSION_MAJOR < 14
- llvm::Attribute inlineAttribute;
-+#endif
-
- AF = llvm::Function::Create(F->getFunctionType(),
- LinkageTypes::AvailableExternallyLinkage,
-@@ -880,9 +886,13 @@ create_redirection_function(std::unique_ptr<llvm::Module> &importMod,
-
- Builder.SetInsertPoint(BB);
- fwdcall = Builder.CreateCall(F, &*AF->arg_begin());
-+#if LLVM_VERSION_MAJOR < 14
- inlineAttribute = llvm::Attribute::get(Context,
- llvm::Attribute::AlwaysInline);
- fwdcall->addAttribute(~0U, inlineAttribute);
-+#else
-+ fwdcall->addFnAttr(llvm::Attribute::AlwaysInline);
-+#endif
- Builder.CreateRet(fwdcall);
-
- return AF;
---
-2.30.2
-
diff --git a/dev-db/postgresql/files/postgresql-13_beta1-no-server.patch b/dev-db/postgresql/files/postgresql-13_beta1-no-server.patch
deleted file mode 100644
index ceb0e3a61d25..000000000000
--- a/dev-db/postgresql/files/postgresql-13_beta1-no-server.patch
+++ /dev/null
@@ -1,149 +0,0 @@
-diff -Naruw postgresql-13beta1.orig/contrib/Makefile postgresql-13beta1/contrib/Makefile
---- postgresql-13beta1.orig/contrib/Makefile 2020-05-18 16:09:19.000000000 -0400
-+++ postgresql-13beta1/contrib/Makefile 2020-05-22 19:56:42.560113731 -0400
-@@ -5,56 +5,9 @@
- include $(top_builddir)/src/Makefile.global
-
- SUBDIRS = \
-- adminpack \
-- amcheck \
-- auth_delay \
-- auto_explain \
-- bloom \
-- btree_gin \
-- btree_gist \
-- citext \
-- cube \
-- dblink \
-- dict_int \
-- dict_xsyn \
-- earthdistance \
-- file_fdw \
-- fuzzystrmatch \
-- hstore \
-- intagg \
-- intarray \
-- isn \
-- lo \
-- ltree \
- oid2name \
-- pageinspect \
-- passwordcheck \
-- pg_buffercache \
-- pg_freespacemap \
-- pg_prewarm \
-- pg_standby \
-- pg_stat_statements \
-- pg_trgm \
-- pgcrypto \
-- pgrowlocks \
-- pgstattuple \
-- pg_visibility \
-- postgres_fdw \
-- seg \
-- spi \
-- tablefunc \
-- tcn \
-- test_decoding \
-- tsm_system_rows \
-- tsm_system_time \
-- unaccent \
- vacuumlo
-
--ifeq ($(with_openssl),yes)
--SUBDIRS += sslinfo
--else
--ALWAYS_SUBDIRS += sslinfo
--endif
-
- ifneq ($(with_uuid),no)
- SUBDIRS += uuid-ossp
-diff -Naruw postgresql-13beta1.orig/src/backend/Makefile postgresql-13beta1/src/backend/Makefile
---- postgresql-13beta1.orig/src/backend/Makefile 2020-05-18 16:09:19.000000000 -0400
-+++ postgresql-13beta1/src/backend/Makefile 2020-05-22 19:58:14.403299909 -0400
-@@ -56,7 +56,7 @@
-
- ##########################################################################
-
--all: submake-libpgport submake-catalog-headers submake-utils-headers postgres $(POSTGRES_IMP)
-+all: generated-headers
-
- ifneq ($(PORTNAME), cygwin)
- ifneq ($(PORTNAME), win32)
-@@ -195,23 +195,7 @@
-
- ##########################################################################
-
--install: all installdirs install-bin
--ifeq ($(PORTNAME), cygwin)
--ifeq ($(MAKE_DLL), true)
-- $(INSTALL_DATA) libpostgres.a '$(DESTDIR)$(libdir)/libpostgres.a'
--endif
--endif
--ifeq ($(PORTNAME), win32)
--ifeq ($(MAKE_DLL), true)
-- $(INSTALL_DATA) libpostgres.a '$(DESTDIR)$(libdir)/libpostgres.a'
--endif
--endif
-- $(MAKE) -C catalog install-data
-- $(MAKE) -C tsearch install-data
-- $(MAKE) -C utils install-data
-- $(INSTALL_DATA) $(srcdir)/libpq/pg_hba.conf.sample '$(DESTDIR)$(datadir)/pg_hba.conf.sample'
-- $(INSTALL_DATA) $(srcdir)/libpq/pg_ident.conf.sample '$(DESTDIR)$(datadir)/pg_ident.conf.sample'
-- $(INSTALL_DATA) $(srcdir)/utils/misc/postgresql.conf.sample '$(DESTDIR)$(datadir)/postgresql.conf.sample'
-+install:
-
- ifeq ($(with_llvm), yes)
- install-bin: install-postgres-bitcode
-diff -Naruw postgresql-13beta1.orig/src/bin/Makefile postgresql-13beta1/src/bin/Makefile
---- postgresql-13beta1.orig/src/bin/Makefile 2020-05-18 16:09:19.000000000 -0400
-+++ postgresql-13beta1/src/bin/Makefile 2020-05-22 19:59:11.399875256 -0400
-@@ -14,22 +14,8 @@
- include $(top_builddir)/src/Makefile.global
-
- SUBDIRS = \
-- initdb \
-- pg_archivecleanup \
-- pg_basebackup \
-- pg_checksums \
- pg_config \
-- pg_controldata \
-- pg_ctl \
- pg_dump \
-- pg_resetwal \
-- pg_rewind \
-- pg_test_fsync \
-- pg_test_timing \
-- pg_upgrade \
-- pg_verifybackup \
-- pg_waldump \
-- pgbench \
- psql \
- scripts
-
-diff -Naruw postgresql-13beta1.orig/src/Makefile postgresql-13beta1/src/Makefile
---- postgresql-13beta1.orig/src/Makefile 2020-05-18 16:09:19.000000000 -0400
-+++ postgresql-13beta1/src/Makefile 2020-05-22 19:59:59.656464613 -0400
-@@ -15,21 +15,12 @@
- SUBDIRS = \
- common \
- port \
-- timezone \
- backend \
-- backend/utils/mb/conversion_procs \
-- backend/snowball \
- include \
- interfaces \
-- backend/replication/libpqwalreceiver \
-- backend/replication/pgoutput \
- fe_utils \
- bin \
-- pl \
-- makefiles \
-- test/regress \
-- test/isolation \
-- test/perl
-+ makefiles
-
- ifeq ($(with_llvm), yes)
- SUBDIRS += backend/jit/llvm
diff --git a/dev-db/postgresql/files/postgresql-14_rc1-no-server.patch b/dev-db/postgresql/files/postgresql-14_rc1-no-server.patch
deleted file mode 100644
index 4f2d388386a2..000000000000
--- a/dev-db/postgresql/files/postgresql-14_rc1-no-server.patch
+++ /dev/null
@@ -1,151 +0,0 @@
-diff -Naruw a/contrib/Makefile b/contrib/Makefile
---- a/contrib/Makefile 2021-09-20 17:33:01.000000000 -0400
-+++ b/contrib/Makefile 2021-09-23 16:28:52.919265033 -0400
-@@ -5,57 +5,9 @@
- include $(top_builddir)/src/Makefile.global
-
- SUBDIRS = \
-- adminpack \
-- amcheck \
-- auth_delay \
-- auto_explain \
-- bloom \
-- btree_gin \
-- btree_gist \
-- citext \
-- cube \
-- dblink \
-- dict_int \
-- dict_xsyn \
-- earthdistance \
-- file_fdw \
-- fuzzystrmatch \
-- hstore \
-- intagg \
-- intarray \
-- isn \
-- lo \
-- ltree \
- oid2name \
-- old_snapshot \
-- pageinspect \
-- passwordcheck \
-- pg_buffercache \
-- pg_freespacemap \
-- pg_prewarm \
-- pg_stat_statements \
-- pg_surgery \
-- pg_trgm \
-- pgcrypto \
-- pgrowlocks \
-- pgstattuple \
-- pg_visibility \
-- postgres_fdw \
-- seg \
-- spi \
-- tablefunc \
-- tcn \
-- test_decoding \
-- tsm_system_rows \
-- tsm_system_time \
-- unaccent \
- vacuumlo
-
--ifeq ($(with_ssl),openssl)
--SUBDIRS += sslinfo
--else
--ALWAYS_SUBDIRS += sslinfo
--endif
-
- ifneq ($(with_uuid),no)
- SUBDIRS += uuid-ossp
-diff -Naruw a/src/backend/Makefile b/src/backend/Makefile
---- a/src/backend/Makefile 2021-09-20 17:33:01.000000000 -0400
-+++ b/src/backend/Makefile 2021-09-23 16:30:03.015728022 -0400
-@@ -56,7 +56,7 @@
-
- ##########################################################################
-
--all: submake-libpgport submake-catalog-headers submake-utils-headers postgres $(POSTGRES_IMP)
-+all: generated-headers
-
- ifneq ($(PORTNAME), cygwin)
- ifneq ($(PORTNAME), win32)
-@@ -194,23 +194,7 @@
-
- ##########################################################################
-
--install: all installdirs install-bin
--ifeq ($(PORTNAME), cygwin)
--ifeq ($(MAKE_DLL), true)
-- $(INSTALL_DATA) libpostgres.a '$(DESTDIR)$(libdir)/libpostgres.a'
--endif
--endif
--ifeq ($(PORTNAME), win32)
--ifeq ($(MAKE_DLL), true)
-- $(INSTALL_DATA) libpostgres.a '$(DESTDIR)$(libdir)/libpostgres.a'
--endif
--endif
-- $(MAKE) -C catalog install-data
-- $(MAKE) -C tsearch install-data
-- $(MAKE) -C utils install-data
-- $(INSTALL_DATA) $(srcdir)/libpq/pg_hba.conf.sample '$(DESTDIR)$(datadir)/pg_hba.conf.sample'
-- $(INSTALL_DATA) $(srcdir)/libpq/pg_ident.conf.sample '$(DESTDIR)$(datadir)/pg_ident.conf.sample'
-- $(INSTALL_DATA) $(srcdir)/utils/misc/postgresql.conf.sample '$(DESTDIR)$(datadir)/postgresql.conf.sample'
-+install:
-
- ifeq ($(with_llvm), yes)
- install-bin: install-postgres-bitcode
-diff -Naruw a/src/bin/Makefile b/src/bin/Makefile
---- a/src/bin/Makefile 2021-09-20 17:33:01.000000000 -0400
-+++ b/src/bin/Makefile 2021-09-23 16:30:50.718922745 -0400
-@@ -14,23 +14,8 @@
- include $(top_builddir)/src/Makefile.global
-
- SUBDIRS = \
-- initdb \
-- pg_amcheck \
-- pg_archivecleanup \
-- pg_basebackup \
-- pg_checksums \
- pg_config \
-- pg_controldata \
-- pg_ctl \
- pg_dump \
-- pg_resetwal \
-- pg_rewind \
-- pg_test_fsync \
-- pg_test_timing \
-- pg_upgrade \
-- pg_verifybackup \
-- pg_waldump \
-- pgbench \
- psql \
- scripts
-
-diff -Naruw a/src/Makefile b/src/Makefile
---- a/src/Makefile 2021-09-20 17:33:01.000000000 -0400
-+++ b/src/Makefile 2021-09-23 16:31:41.842107531 -0400
-@@ -15,21 +15,12 @@
- SUBDIRS = \
- common \
- port \
-- timezone \
- backend \
-- backend/utils/mb/conversion_procs \
-- backend/snowball \
- include \
- interfaces \
-- backend/replication/libpqwalreceiver \
-- backend/replication/pgoutput \
- fe_utils \
- bin \
-- pl \
-- makefiles \
-- test/regress \
-- test/isolation \
-- test/perl
-+ makefiles
-
- ifeq ($(with_llvm), yes)
- SUBDIRS += backend/jit/llvm
diff --git a/dev-db/postgresql/files/postgresql-9.6.3-no-server.patch b/dev-db/postgresql/files/postgresql-9.6.3-no-server.patch
deleted file mode 100644
index aa7cf773a39a..000000000000
--- a/dev-db/postgresql/files/postgresql-9.6.3-no-server.patch
+++ /dev/null
@@ -1,141 +0,0 @@
---- a/contrib/Makefile
-+++ b/contrib/Makefile
-@@ -5,57 +5,9 @@
- include $(top_builddir)/src/Makefile.global
-
- SUBDIRS = \
-- adminpack \
-- auth_delay \
-- auto_explain \
-- bloom \
-- btree_gin \
-- btree_gist \
-- chkpass \
-- citext \
-- cube \
-- dblink \
-- dict_int \
-- dict_xsyn \
-- earthdistance \
-- file_fdw \
-- fuzzystrmatch \
-- hstore \
-- intagg \
-- intarray \
-- isn \
-- lo \
-- ltree \
- oid2name \
-- pageinspect \
-- passwordcheck \
-- pg_buffercache \
-- pg_freespacemap \
-- pg_prewarm \
-- pg_standby \
-- pg_stat_statements \
-- pg_trgm \
-- pgcrypto \
-- pgrowlocks \
-- pgstattuple \
-- pg_visibility \
-- postgres_fdw \
-- seg \
-- spi \
-- tablefunc \
-- tcn \
-- test_decoding \
-- tsm_system_rows \
-- tsm_system_time \
-- tsearch2 \
-- unaccent \
- vacuumlo
-
--ifeq ($(with_openssl),yes)
--SUBDIRS += sslinfo
--else
--ALWAYS_SUBDIRS += sslinfo
--endif
-
- ifneq ($(with_uuid),no)
- SUBDIRS += uuid-ossp
---- a/src/backend/Makefile
-+++ b/src/backend/Makefile
-@@ -51,7 +51,7 @@
-
- ##########################################################################
-
--all: submake-libpgport submake-schemapg postgres $(POSTGRES_IMP)
-+all: generated-headers
-
- ifneq ($(PORTNAME), cygwin)
- ifneq ($(PORTNAME), win32)
-@@ -218,23 +218,7 @@
-
- ##########################################################################
-
--install: all installdirs install-bin
--ifeq ($(PORTNAME), cygwin)
--ifeq ($(MAKE_DLL), true)
-- $(INSTALL_DATA) libpostgres.a '$(DESTDIR)$(libdir)/libpostgres.a'
--endif
--endif
--ifeq ($(PORTNAME), win32)
--ifeq ($(MAKE_DLL), true)
-- $(INSTALL_DATA) libpostgres.a '$(DESTDIR)$(libdir)/libpostgres.a'
--endif
--endif
-- $(MAKE) -C catalog install-data
-- $(MAKE) -C tsearch install-data
-- $(INSTALL_DATA) $(srcdir)/libpq/pg_hba.conf.sample '$(DESTDIR)$(datadir)/pg_hba.conf.sample'
-- $(INSTALL_DATA) $(srcdir)/libpq/pg_ident.conf.sample '$(DESTDIR)$(datadir)/pg_ident.conf.sample'
-- $(INSTALL_DATA) $(srcdir)/utils/misc/postgresql.conf.sample '$(DESTDIR)$(datadir)/postgresql.conf.sample'
-- $(INSTALL_DATA) $(srcdir)/access/transam/recovery.conf.sample '$(DESTDIR)$(datadir)/recovery.conf.sample'
-+install:
-
- install-bin: postgres $(POSTGRES_IMP) installdirs
- $(INSTALL_PROGRAM) postgres$(X) '$(DESTDIR)$(bindir)/postgres$(X)'
---- a/src/bin/Makefile
-+++ b/src/bin/Makefile
-@@ -14,19 +14,8 @@
- include $(top_builddir)/src/Makefile.global
-
- SUBDIRS = \
-- initdb \
-- pg_archivecleanup \
-- pg_basebackup \
- pg_config \
-- pg_controldata \
-- pg_ctl \
- pg_dump \
-- pg_resetxlog \
-- pg_rewind \
-- pg_test_fsync \
-- pg_test_timing \
-- pg_upgrade \
-- pg_xlogdump \
- pgbench \
- psql \
- scripts
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -15,19 +15,12 @@
- SUBDIRS = \
- common \
- port \
-- timezone \
- backend \
-- backend/utils/mb/conversion_procs \
-- backend/snowball \
- include \
- interfaces \
-- backend/replication/libpqwalreceiver \
- fe_utils \
- bin \
-- pl \
-- makefiles \
-- test/regress \
-- test/perl
-+ makefiles
-
- # There are too many interdependencies between the subdirectories, so
- # don't attempt parallel make here.