summaryrefslogtreecommitdiff
path: root/dev-db/psqlodbc/psqlodbc-16.00.0000.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-07 00:00:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-07 00:00:56 +0100
commit7bcfea9c5e79a425a62a66bba477b9d3c0d7fdd0 (patch)
tree02bad8e4f1f060d4858a1a2ec3fc9404f0b7a197 /dev-db/psqlodbc/psqlodbc-16.00.0000.ebuild
parent43c2a85d4e20318dd3d35872e348707900870067 (diff)
gentoo auto-resync : 07:05:2024 - 00:00:56
Diffstat (limited to 'dev-db/psqlodbc/psqlodbc-16.00.0000.ebuild')
-rw-r--r--dev-db/psqlodbc/psqlodbc-16.00.0000.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-db/psqlodbc/psqlodbc-16.00.0000.ebuild b/dev-db/psqlodbc/psqlodbc-16.00.0000.ebuild
new file mode 100644
index 000000000000..eb924528a69d
--- /dev/null
+++ b/dev-db/psqlodbc/psqlodbc-16.00.0000.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Official ODBC driver for PostgreSQL"
+HOMEPAGE="https://odbc.postgresql.org/"
+SRC_URI="https://ftp.postgresql.org/pub/odbc/versions/src/${P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="iodbc ssl threads"
+
+DEPEND="dev-db/postgresql:*[ssl?]
+ !iodbc? ( dev-db/unixODBC )
+ iodbc? ( dev-db/libiodbc )
+"
+RDEPEND="${DEPEND}"
+
+# Tests require installation and a server setup for the purpose.
+RESTRICT="test"
+
+DOCS=( readme.txt )
+HTML_DOCS=(
+ docs/config.html
+ docs/config-opt.html
+ docs/editConfiguration.jpg
+ docs/release-7.3.html
+ docs/release.html
+)
+
+src_configure() {
+ econf \
+ $(use_with iodbc) \
+ $(use_with !iodbc unixodbc) \
+ $(use_enable threads pthreads)
+}