summaryrefslogtreecommitdiff
path: root/dev-db/redis/files/redis-7.2.0-system-jemalloc.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-17 09:31:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-17 09:31:54 +0100
commit5a21cec0c36dba03507dcbd5e8ab6698d00b39bf (patch)
treeaa76c2f85f9c77c2f9a5af47ae0aa6509585770a /dev-db/redis/files/redis-7.2.0-system-jemalloc.patch
parent280d9db9f9470686aae5ce1fa4cfa57b26e9beb2 (diff)
gentoo auto-resync : 17:08:2023 - 09:31:54
Diffstat (limited to 'dev-db/redis/files/redis-7.2.0-system-jemalloc.patch')
-rw-r--r--dev-db/redis/files/redis-7.2.0-system-jemalloc.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-db/redis/files/redis-7.2.0-system-jemalloc.patch b/dev-db/redis/files/redis-7.2.0-system-jemalloc.patch
new file mode 100644
index 000000000000..cc2c51a50ea9
--- /dev/null
+++ b/dev-db/redis/files/redis-7.2.0-system-jemalloc.patch
@@ -0,0 +1,33 @@
+Rebased from original redis-5.0-shared.patch
+
+diff --git a/src/Makefile b/src/Makefile
+index ecbd2753d..275446338 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -65,10 +65,7 @@ PYTHON := $(shell which python3 || which python)
+ endif
+
+ # Default allocator defaults to Jemalloc on Linux and libc otherwise
+-MALLOC=libc
+-ifeq ($(uname_S),Linux)
+- MALLOC=jemalloc
+-endif
++MALLOC?=jemalloc
+
+ # To get ARM stack traces if Redis crashes we need a special C flag.
+ ifneq (,$(filter aarch64 armv%,$(uname_M)))
+@@ -266,9 +263,8 @@ ifeq ($(MALLOC),tcmalloc_minimal)
+ endif
+
+ ifeq ($(MALLOC),jemalloc)
+- DEPENDENCY_TARGETS+= jemalloc
+- FINAL_CFLAGS+= -DUSE_JEMALLOC -I../deps/jemalloc/include
+- FINAL_LIBS := ../deps/jemalloc/lib/libjemalloc.a $(FINAL_LIBS)
++ FINAL_CFLAGS+= -DUSE_JEMALLOC -DJEMALLOC_NO_DEMANGLE
++ FINAL_LIBS+= -ljemalloc -ldl
+ endif
+
+ # LIBSSL & LIBCRYPTO
+--
+2.41.0
+