summaryrefslogtreecommitdiff
path: root/dev-db/slony1
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-db/slony1
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-db/slony1')
-rw-r--r--dev-db/slony1/Manifest6
-rw-r--r--dev-db/slony1/files/slony1.conf11
-rw-r--r--dev-db/slony1/files/slony1.init36
-rw-r--r--dev-db/slony1/metadata.xml8
-rw-r--r--dev-db/slony1/slony1-2.2.6.ebuild64
5 files changed, 125 insertions, 0 deletions
diff --git a/dev-db/slony1/Manifest b/dev-db/slony1/Manifest
new file mode 100644
index 000000000000..781f7794dba5
--- /dev/null
+++ b/dev-db/slony1/Manifest
@@ -0,0 +1,6 @@
+AUX slony1.conf 249 BLAKE2B ec214fb9a7d51bcaa58dc191d7e943c0d07be85c0f31dadbf199f5b309fb61c631d62eac659f4473120ee67649029c45cab606205fd62e1679413d2077fedac6 SHA512 3ef2b9a326cb237aa6ceaf4f161d9ff183c291f423b7ad29cb9102a67de849dbf5a52120ecc756efc5a8d226f0860a2517ced64ab44f135e62cb2e53611775a8
+AUX slony1.init 615 BLAKE2B f1b3fc27ad3c4087713cceb6c2bb9451004b70e87c0347274c75e1c3ed8d439bb99f51d5e6e904d3957150e62760272312423a47235ff4e76792e0661b683bb3 SHA512 d450bba5f65372509e542f138d297202371bcaf78332ba13de72ddf937fcffe419083dddc5032c7bafd51993fbc677b37262e1b1e938e9e3c927e130c0a7c693
+DIST slony1-2.2.6-docs.tar.bz2 1450956 BLAKE2B 949d0736eb9ab021767b80b4240e30a8cd11daa218cac6d722827a8db98f2b54cc093031e02d0cd14cb1eb60d56dc160dcd1c2e0708e7228fdac31ef26d2fcf4 SHA512 b5a870d5688ca24c0a9012d7da539917c74ee697f1b1ae663ead3cb1032345c0d8f5fc5bddc2ca2fec5d738fb9ca74822343cce8739b3b4b478928f26d214a0d
+DIST slony1-2.2.6.tar.bz2 1465709 BLAKE2B 87e581638aab5ac9f51437fc43b65f200c29e012fa2b5331d4a7972359bb345c8d5aec9917fbc348ce8338115f8270d6e55025905aa5aba642090a8486d0a3fc SHA512 5aeadb9ed72b83d303596e4f8513409a1f826f25fe283ca6aa969a7563172bbc5f5360f876fa87780f6a6fc70cb55688a2daf678b9cf91972a3c403cb76184b8
+EBUILD slony1-2.2.6.ebuild 1646 BLAKE2B 41751e24ac6d64d484f4c7502d093dcb36236eac011d79f8e9fc8095be906f45e1285d6c5305e95253d3fcb2636040354fa58e968cbf44e4d0c541f1161bc284 SHA512 9e220005ba13513b8f7d20853bc659d586e8d0b5a5d2c93b0997601dc84cee845826d31d37cb2726d37b114341d9f60502557e8fe7dfd3447720fd41021c90eb
+MISC metadata.xml 280 BLAKE2B 75bfaba3095bd67dfa80654885579e51053fd130ae4e3ad61ac75192eebad9fe8d08cbdf63773dad3837ef2805e0594d0823655966fde8876ba5919e01f0e698 SHA512 efb5fb6652ac8cd75fff4eea8b2b044a2c9201cce2faf3bbe13a97565d150e64f9ba0dd8bb691a44a1b6726455306ea8b6c1b121678a721a82e7ea8b6589c94f
diff --git a/dev-db/slony1/files/slony1.conf b/dev-db/slony1/files/slony1.conf
new file mode 100644
index 000000000000..a660b0b16c40
--- /dev/null
+++ b/dev-db/slony1/files/slony1.conf
@@ -0,0 +1,11 @@
+# /etc/conf.d/slony1:
+
+# Configuration file for /etc/init.d/slony1
+
+USER=postgres
+CLUSTER=your_cluster_name
+DBUSER=postgres
+DBNAME=your_database_name
+DBHOST=localhost
+LOGFILE=/var/lib/postgresql/data/slony1.log
+LOGLEVEL=1 # 1(minimum)..4(maximum)
diff --git a/dev-db/slony1/files/slony1.init b/dev-db/slony1/files/slony1.init
new file mode 100644
index 000000000000..d85c99c733f0
--- /dev/null
+++ b/dev-db/slony1/files/slony1.init
@@ -0,0 +1,36 @@
+#!/sbin/openrc-run
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need postgresql
+}
+
+start() {
+ ebegin "Starting slony1"
+ /usr/bin/slon -p /var/run/slony1.pid -d $LOGLEVEL $CLUSTER "dbname=$DBNAME user=$DBUSER host=$DBHOST" >> $LOGFILE 2>&1 &
+
+ while :
+ do
+ cnt=$(($cnt + 1))
+ if [ -f "/var/run/slony1.pid" ]; then
+ ret=0
+ break
+ fi
+
+ if [ $cnt -eq 30 ]; then
+ eerror "Please see log file: $LOGFILE"
+ ret=1
+ break
+ fi
+ sleep 1
+ done
+ eend $ret
+}
+
+stop() {
+ ebegin "Stopping slony1"
+ kill `cat /var/run/slony1.pid`
+ eend $?
+}
+
diff --git a/dev-db/slony1/metadata.xml b/dev-db/slony1/metadata.xml
new file mode 100644
index 000000000000..711734ad7566
--- /dev/null
+++ b/dev-db/slony1/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>pgsql-bugs@gentoo.org</email>
+ <name>PostgreSQL and Related Package Development</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-db/slony1/slony1-2.2.6.ebuild b/dev-db/slony1/slony1-2.2.6.ebuild
new file mode 100644
index 000000000000..c390f13f5a65
--- /dev/null
+++ b/dev-db/slony1/slony1-2.2.6.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+POSTGRES_COMPAT=( 9.{3..6} 10 )
+POSTGRES_USEDEP="server,threads"
+
+inherit eutils postgres-multi versionator
+
+IUSE="doc perl"
+
+DESCRIPTION="A replication system for the PostgreSQL Database Management System"
+HOMEPAGE="http://slony.info/"
+
+# ${P}-docs.tar.bz2 contains man pages as well as additional documentation
+MAJ_PV=$(get_version_component_range 1-2)
+SRC_URI="http://main.slony.info/downloads/${MAJ_PV}/source/${P}.tar.bz2
+ http://main.slony.info/downloads/${MAJ_PV}/source/${P}-docs.tar.bz2"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+DEPEND="${POSTGRES_DEP}
+ perl? ( dev-perl/DBD-Pg )
+"
+
+RDEPEND=${DEPEND}
+
+REQUIRE_USE="${POSTGRES_REQ_USE}"
+
+RESTRICT="test"
+
+src_configure() {
+ local slot_bin_dir="/usr/$(get_libdir)/postgresql-@PG_SLOT@/bin"
+ use perl && myconf=" --with-perltools=\"${slot_bin_dir}\""
+ postgres-multi_foreach econf ${myconf} \
+ --with-pgconfigdir="${slot_bin_dir}" \
+ --with-slonybindir="${slot_bin_dir}"
+}
+
+src_install() {
+ postgres-multi_foreach emake DESTDIR="${D}" install
+
+ dodoc INSTALL README SAMPLE TODO UPGRADING share/slon.conf-sample
+
+ if use doc ; then
+ cd "${S}"/doc
+ dohtml -r *
+ fi
+
+ newinitd "${FILESDIR}"/slony1.init slony1
+ newconfd "${FILESDIR}"/slony1.conf slony1
+}
+
+pkg_postinst() {
+ # Slony-I installs its executables into a directory that is
+ # processed by the PostgreSQL eselect module. Call it here so that
+ # the symlinks will be created.
+ ebegin "Refreshing PostgreSQL $(postgresql-config show) symlinks"
+ postgresql-config update
+ eend $?
+}