summaryrefslogtreecommitdiff
path: root/dev-debug/ddd/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-18 20:07:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-18 20:07:15 +0000
commita4c0eb2444b57e79bce0a088e5936ed71c415e8f (patch)
tree61a990b001109844a226b1fbe33bb38486a88c8e /dev-debug/ddd/files
parente60b61e39bb9b7cbf525baa183a5a19234f335fa (diff)
gentoo auto-resync : 18:01:2024 - 20:07:15
Diffstat (limited to 'dev-debug/ddd/files')
-rw-r--r--dev-debug/ddd/files/ddd-3.3.12-clang.patch15
-rw-r--r--dev-debug/ddd/files/ddd-3.3.12-gcc44.patch10
-rw-r--r--dev-debug/ddd/files/ddd-3.3.12-gcc9.patch93
-rw-r--r--dev-debug/ddd/files/ddd-3.3.12-gdb-disassembler-bug.patch11
-rw-r--r--dev-debug/ddd/files/ddd-3.3.12-man.patch16
-rw-r--r--dev-debug/ddd/files/ddd-3.3.12-parallel.patch15
-rw-r--r--dev-debug/ddd/files/ddd-3.3.12-tinfo.patch11
7 files changed, 171 insertions, 0 deletions
diff --git a/dev-debug/ddd/files/ddd-3.3.12-clang.patch b/dev-debug/ddd/files/ddd-3.3.12-clang.patch
new file mode 100644
index 000000000000..a1f8da27b116
--- /dev/null
+++ b/dev-debug/ddd/files/ddd-3.3.12-clang.patch
@@ -0,0 +1,15 @@
+diff -ruN ddd-3.3.12/ddd/exit.C ddd-my/ddd/exit.C
+--- ddd-3.3.12/ddd/exit.C 2009-02-11 18:25:07.000000000 +0100
++++ ddd-my/ddd/exit.C 2020-09-27 03:23:14.713650981 +0200
+@@ -769,7 +769,11 @@
+
+ static XtAppContext xt_error_app_context = 0;
+
++#ifdef __clang__
++static void ddd_xt_error(String message = 0) _X_NORETURN
++#else
+ static void ddd_xt_error(String message = 0)
++#endif
+ {
+ ddd_has_crashed = true;
+
diff --git a/dev-debug/ddd/files/ddd-3.3.12-gcc44.patch b/dev-debug/ddd/files/ddd-3.3.12-gcc44.patch
new file mode 100644
index 000000000000..2464b2b4a9c4
--- /dev/null
+++ b/dev-debug/ddd/files/ddd-3.3.12-gcc44.patch
@@ -0,0 +1,10 @@
+--- ddd-3.3.12-orig/ddd/strclass.C
++++ ddd-3.3.12/ddd/strclass.C
+@@ -39,6 +39,7 @@
+ #include <limits.h>
+ #include <new>
+ #include <stdlib.h>
++#include <stdio.h>
+
+ void string::error(const char* msg) const
+ {
diff --git a/dev-debug/ddd/files/ddd-3.3.12-gcc9.patch b/dev-debug/ddd/files/ddd-3.3.12-gcc9.patch
new file mode 100644
index 000000000000..ce12a41c91d2
--- /dev/null
+++ b/dev-debug/ddd/files/ddd-3.3.12-gcc9.patch
@@ -0,0 +1,93 @@
+diff -ruN -x '*.am' ddd-3.3.12/ddd/strclass.h my/ddd/strclass.h
+--- ddd-3.3.12/ddd/strclass.h 2009-02-11 18:25:06.000000000 +0100
++++ my/ddd/strclass.h 2019-11-22 22:00:49.000267420 +0100
+@@ -543,7 +543,6 @@
+ bool OK() const;
+ };
+
+-
+ class string
+ {
+ friend class subString;
+@@ -811,9 +810,9 @@
+ const regex& sep);
+
+ friend string common_prefix(const string& x, const string& y,
+- int startpos = 0);
++ int startpos);
+ friend string common_suffix(const string& x, const string& y,
+- int startpos = -1);
++ int startpos);
+ friend string replicate(char c, int n);
+ friend string replicate(const string& y, int n);
+ friend string join(const string *src, int n, const string& sep);
+@@ -864,8 +863,8 @@
+ friend std::istream& operator>>(std::istream& s, string& x);
+
+ friend int readline(std::istream& s, string& x,
+- char terminator = '\n',
+- int discard_terminator = 1);
++ char terminator,
++ int discard_terminator);
+
+ // Status
+ unsigned int length() const;
+@@ -882,6 +881,58 @@
+ bool OK() const;
+ };
+
++inline void cat(const string&, const string&, string&);
++inline void cat(const string&, const subString&, string&);
++inline void cat(const string&, const constSubString&, string&);
++inline void cat(const string&, const char*, string&);
++inline void cat(const string&, char*, string&);
++inline void cat(const string&, char, string&);
++
++inline void cat(const subString&, const string&, string&);
++inline void cat(const subString&, const subString&, string&);
++inline void cat(const subString&, const char*, string&);
++inline void cat(const subString&, char*, string&);
++inline void cat(const subString&, char, string&);
++
++inline void cat(const char*, const string&, string&);
++inline void cat(const char*, const subString&, string&);
++inline void cat(const char*, const char*, string&);
++inline void cat(const char*, char*, string&);
++inline void cat(const char*, char, string&);
++
++inline void cat(char*, const string&, string&);
++inline void cat(char*, const subString&, string&);
++inline void cat(char*, const char*, string&);
++inline void cat(char*, char*, string&);
++inline void cat(char*, char, string&);
++
++inline void cat(char, const string&, string&);
++inline void cat(char, const subString&, string&);
++inline void cat(char, const char*, string&);
++inline void cat(char, char*, string&);
++inline void cat(char, char, string&);
++
++int split(const string& x, string *res, int maxn,
++ const string& sep);
++int split(const string& x, string *res, int maxn,
++ const regex& sep);
++
++string common_prefix(const string& x, const string& y,
++ int startpos = 0);
++string common_suffix(const string& x, const string& y,
++ int startpos = -1);
++string replicate(char c, int n);
++string replicate(const string& y, int n);
++string join(const string *src, int n, const string& sep);
++
++inline std::ostream& operator<<(std::ostream& s, const string& x);
++inline std::ostream& operator<<(std::ostream& s, const subString& x);
++std::istream& operator>>(std::istream& s, string& x);
++
++int readline(std::istream& s, string& x,
++ char terminator = '\n',
++ int discard_terminator = 1);
++
+ // Inject names manually to accomodate argument-dependent name lookup (ADL)
+ // (aka Koenig lookup). The rule is that friend declarations are visible
+ // when found through ADL because an argument of the call happens to be
diff --git a/dev-debug/ddd/files/ddd-3.3.12-gdb-disassembler-bug.patch b/dev-debug/ddd/files/ddd-3.3.12-gdb-disassembler-bug.patch
new file mode 100644
index 000000000000..738cda5946f9
--- /dev/null
+++ b/dev-debug/ddd/files/ddd-3.3.12-gdb-disassembler-bug.patch
@@ -0,0 +1,11 @@
+--- a/ddd/GDBAgent.C 2004-09-01 20:07:38.000000000 +0200
++++ b/ddd/GDBAgent.C 2010-06-15 14:16:34.000000000 +0200
+@@ -3078,7 +3078,7 @@
+ {
+ string end_( end );
+ normalize_address(end_);
+- cmd += ' ';
++ cmd += ',';
+ cmd += end_;
+ }
+ return cmd;
diff --git a/dev-debug/ddd/files/ddd-3.3.12-man.patch b/dev-debug/ddd/files/ddd-3.3.12-man.patch
new file mode 100644
index 000000000000..06f9deb806f0
--- /dev/null
+++ b/dev-debug/ddd/files/ddd-3.3.12-man.patch
@@ -0,0 +1,16 @@
+diff -ruN ddd-3.3.12/ddd/Makefile.am ddd-my/ddd/Makefile.am
+--- ddd-3.3.12/ddd/Makefile.am 2009-02-11 18:25:07.000000000 +0100
++++ ddd-my/ddd/Makefile.am 2012-11-06 01:48:46.363493473 +0100
+@@ -1371,10 +1371,8 @@
+ man_MANS = ddd.1
+
+ # `ddd.man' has 8-bit format, `ddd.1' has 7-bit format
+-ddd.1: ddd.man $(srcdir)/unumlaut.sed
+- -$(SED) -f $(srcdir)/unumlaut.sed ddd.man | $(DELETE_CR) > $@~ \
+- && $(MV) $@~ $@
+-
++ddd.1: ddd.man
++ iconv -f ISO8859-15 -t UTF-8 ddd.man > ddd.1
+
+
+ # -----------------------------------------------------------------------------
diff --git a/dev-debug/ddd/files/ddd-3.3.12-parallel.patch b/dev-debug/ddd/files/ddd-3.3.12-parallel.patch
new file mode 100644
index 000000000000..21624a2ab614
--- /dev/null
+++ b/dev-debug/ddd/files/ddd-3.3.12-parallel.patch
@@ -0,0 +1,15 @@
+diff -ruN -x strclass.h ddd-3.3.12/ddd/Makefile.am my/ddd/Makefile.am
+--- ddd-3.3.12/ddd/Makefile.am 2009-02-11 18:25:07.000000000 +0100
++++ my/ddd/Makefile.am 2019-11-22 22:49:26.212765331 +0100
+@@ -580,9 +580,8 @@
+
+ # Make sure needed headers are built before trying to compile these files
+ # (Assume ddd.C is the first source file to be built.)
+-ddd.o: version.h host.h root.h
+-resources.o: Ddd.ad.h
+-show.o: build.h
++# MM: AND WHY WOULD YOU ASSUME THAT??
++BUILT_SOURCES = version.h host.h root.h Ddd.ad.h build.h
+
+ # -----------------------------------------------------------------------------
+ # Local Libraries.
diff --git a/dev-debug/ddd/files/ddd-3.3.12-tinfo.patch b/dev-debug/ddd/files/ddd-3.3.12-tinfo.patch
new file mode 100644
index 000000000000..ab7df14ae9d9
--- /dev/null
+++ b/dev-debug/ddd/files/ddd-3.3.12-tinfo.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -360,7 +360,7 @@
+ dnl
+ _termlib="${ddd_termlib}"
+ if test "x${ddd_termlib}" = x; then
+- _termlib="mytinfo ncurses curses termcap terminfo termlib"
++ _termlib="mytinfo ncurses tinfo curses termcap terminfo termlib"
+ fi
+ _termlib_path=
+ if test x"${ddd_termlib_libraries_path}" != x; then