summaryrefslogtreecommitdiff
path: root/dev-debug/strace/strace-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-20 00:30:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-20 00:30:25 +0000
commit77684468238b8755c1aa3e72f3055f4e62fcf14c (patch)
tree7c18f4b036e2a73cd48b63c5d7c711bc5cf1b989 /dev-debug/strace/strace-9999.ebuild
parent781c9128468d2e8302221d4d7152ae09cffc4a9e (diff)
gentoo auto-resync : 20:03:2025 - 00:30:24HEADmaster
Diffstat (limited to 'dev-debug/strace/strace-9999.ebuild')
-rw-r--r--dev-debug/strace/strace-9999.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-debug/strace/strace-9999.ebuild b/dev-debug/strace/strace-9999.ebuild
index 3b7b64121199..196f558d280a 100644
--- a/dev-debug/strace/strace-9999.ebuild
+++ b/dev-debug/strace/strace-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -40,7 +40,6 @@ LIB_DEPEND="
DEPEND="
static? ( ${LIB_DEPEND} )
aio? ( >=dev-libs/libaio-0.3.106 )
- sys-kernel/linux-headers
"
RDEPEND="
!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
@@ -87,11 +86,15 @@ src_configure() {
# Don't require mpers support on non-multilib systems. #649560
--enable-mpers=check
+ # We don't want to pin to exact linux-headers versions (bug #950309)
+ --enable-bundled=yes
+
$(use_enable static)
$(use_with unwind libunwind)
$(use_with elfutils libdw)
$(use_with selinux libselinux)
)
+
econf "${myeconfargs[@]}"
}